Ortur LM2 Pro & win 10 / 100% CPU Load - Confilct with antivirus causing random stop

I have also been having this issue with my laser (different brand) and I think, for me anyway, I may have discovered the reason. I run my laser (an OLM2 Pro) on a windows 10 PC and the last time it halted in the middle of an engrave I glanced over at Task Manager and it was maxed out at 100% CPU usage. My firewall was running the CPU at full blast and I wasn’t doing anything that should have caused it too. The point I’m trying to make is, if you are using Windows, there could be services running in th background that are interfering with USB communications. I don’t have a Mac so I’m not sure if they can do the same thing. Just my two cents worth.

On a USB connected Diode laser i’d be interested to know if the firewall/CPU burden drops if you disconnect from the internet. Are you using cloud storage for your project files?

I’m sorry that it took so long to reply. During an engrave the only program running is Lightburn. When I saw that the laser had stopped, I could see the Task Manager icon down in the service tray was maxed out at 100% CPU usage. But it wasn’t Zonealarm, it was one of its services (Check Point Sandblast Agent Threat Emulation) that was running in the background, all the time. It would swing from 4 or 5 percent all the way to 90 or 95 percent, stay there for 30 seconds or so and then drop back down. I was not on the internet or running any other programs. I uninstalled ZoneAlarm (Check Point) but then Windows Defender (again, one of its background services) started doing the same thing, so I disabled it. I am using Malwarebytes for anti-virus, so I am not totally unprotected. I do all my design work on my office PC (which, by the way, is running these same programs but does not exhibit the same problems) and I drag the files over the wired network to the micro-PC in my shop. The micro-PC doesn’t need internet access, but it does need network access. Since shutting down these programs I haven’t had this problem reoccur, but that’s the thing, in the past I’ve made a change and my laser will run problem free, right up until it doesn’t. I really believe that these Windows 10 background services have been the issue all along. Because this type of laser requires a continuous uninterrupted flow of data, any disruption will cause it to halt. Time will tell if I have finally solved the problem.

1 Like

No worries at all. Thanks for getting back to us about this.
I moved your post off the 3018 Maxx thread because the Ortur has some pretty significantly different software (and hardware) and so Gil @OrturTech can comment on it.

If this is an emerging concern I’d like to know more and how it could be avoided or be more readily detected.

There is nothing on ortur/Lightburn that could cause such a high cpu usage. I would think if the gcode stream was so heavy that it would cause 100% cpu load lightburn wouldnt load on the first place
Something else must be going on
What i would do would be
a) export design as gcode - Save Gcode in lightburn > save to desktop test.gcode
b) install or run lasergrbl → run the gcode file and monitor task bar

Any difference?

1 Like

First of all, my apologizes for crashing in on the other post. I chimed in because I thought they might have a similar cause. I do not believe that Lightburn is what’s causing my firewall/anti-virus to freak out. From what I’ve reading online over the last week, it’s that these programs themselves (ZoneAlarm and Windows Defender) have services running in the background that will randomly max out the CPU usage. When I googled each of these services (Check Point Sandblast Agent Threat Emulation was one of them) they were all showing issues with high CPU usage in Windows 10. So, LightBurn is not the problem, it’s the other programs that are causing the issue. I only mentioned it in the other thread in case he was running into the same issue as I was with Windows 10/11 and CPU usage. Sorry for the confusion I may have caused, it was not my intent. I have since disabled those programs and the problem seems to have gone away (for now anyway :thinking:). As to Gil’s point, I don’t think it matters which program is outputting to my laser if the problem is Windows itself, or at least Windows running on my micro PC.

Could be an interesting test to try still.
Maybe the check point thing is getting confused for such ammount of traffic via serial com and is “scanning” each bit of data for malice code/data. That woudl explain the high cpu read

But if you tried lasergrbl as a sanity check you could for sure make sure if its at service lever or executable level
IN other words. is it scanning lightburn.exe or the serial com service itself?

1 Like

I’m glad you did mention it, did some analysis and dug into it.
The distinction between service level and executable level that Gil draws is intriguing.

If the firewall (second party) software is snooping the serial bus and causing communication issues (and if it can be resolved) it could knock a huge workload out of the industry in general.

There are plenty of 3rd party “securty” software that are quite anoying
McAfee is a nightmare to deal with, with going as far as compleatly blocking serial com communications for “reasons”
The main problem seems to be mostly though the lack of consistency. 2 computers, 2 machines 2 installs of the same security software might not render the same results
So is a multi variant issue at play thats mostly un replicatable, well at least in a way that wont drive people to spend more time diagnosing than engraving.

My point above was more to see where the software was snooping at, and if there could be some footprint on the executable itself that could be flagging the coms.
The only variable we could try thre would be the executable. Lightburn.exe vs laserbrbl.exe streaming the same gcode (which would be hard coded and present no variability).

This said lasergrbl also uses a variant of the usb serial com protocol so…
again bit of a nightmare of variables

That is very true. I have 2 PC’s, one is an HP all-in-one desktop and the other is a mini PC. Both are running Windows 10. The mini PC has solid state internal memory (no hard drive) and I use a tv monitor and a wireless keyboard/mouse. They are both running the same anti-virus and firewall. The desktop hasn’t had any problems with maxed out CPU usage but the mini PC does. I control a 3d printer with the desktop and will soon be moving the OLM2 Pro onto it as well. It will be interesting to see if the problem follows or not. The mini PC has been quiet since I disabled the firewall and anti-virus. I’ll update this post if anything changes.

out of curiosity, any chance you could post the specs of your mini pc?

I started out using this mini-PC with a 3018 Pro about a year and a half ago, and then added an Ender 3 3D printer a few months later. LaserGRBL was a pain to use so I downloaded LightBurn last year. I bought the OLM2 Pro mid-summer of 2021 and ran it on the mini-PC as well (only one device is connected and running at a time). The issue with an engrave stopping mid job started about 3 or 4 months ago and only seems to affect the OLM2. Below are the specs that I could find. Amazon no longer carries this model, but they do have the next one in the series, the N4020, different processor but similar specs.

MINISFORUM Windows 10 Pro Mini Fanless Desktop Computer
Intel Celeron N3350 Dual-Core Processor,
Supports 4K HD/HDMI+VGA Port,
Dual Wi-Fi,
Gigabit Ethernet, (I use a wired network connection)
BT 4.2

Well, in fairness it wont take much to put that CPU at 100%, but still it should not make it to 100% on streaming GRBL Gcode really.
Neat little machine for a streamer but i dont think it would compare to your main computer

I agree with you that the specs aren’t that great, but it was working fairly well up until recently. Within the next few days the OLM2P will be moved into my office (an air-conditioned space) and I will be using my HP desktop to stream the LightBurn GRBL G-code to the laser. The mini-PC will stay in the workshop to control my OMTECH 50w CO2 laser. The good thing about the Ruida controller is I can send the whole file to the controllers memory and run it from there. Perhaps you could suggest to the engineers that they could add a similar capability to the Ortur product line. A guy can dream can’t he :laughing:.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.