Ortur LM2Pro Will not update firmware

I have had a few issues with the Ortur Laser Master 2 Pro since setting it up. At first the fire sensor alarm would constantly go off (even if laser was not running). Disabled this in the code ($261=0), but then started having issues with the travel/bump sensor, and had to adjust it in the code as well to keep it running. I am still having several little issues (will not stay connected for long, and sometimes drops in the middle of a burn, sometimes have to turn it on twice - first time only the blue light on the control panel comes on, but wont connect or home, have to hold the power button again).

I have tried to update the firmware but it will always disconnect when I drag the firmware (version 1.55) over to the machine. Copy/paste has the same results. It will stay open as long as I am not moving the firmware, can even open and read the read me file in there with no issues.

Also, the current firmware version on there is OLF 170, when Ortur has the latest at 1.55. Not sure why or if that is part of the problem.
I have tried to update on a Windows 10 machine and on a second computer running Windows 7 with the same results.

Any help would be appreciated (and an idea about the OLF 170 being shipped on the machine as opposed to 155 or lower).

For the fire sensor, have you checked for any infrared sources nearby? My webcam kept tripping mine until I turned off night vision mode. Any IR source that is bright enough will trigger it.

There really isn’t any sources close by it. It is sitting in front of a window, but even with the thick curtains drawn it was still going off. I haven’t built an enclosure for it yet. That might help that problem. My biggest issue is I would like to flash the firmware back to OLF 155 (and try to understand what OLF 170 is).

I just looked on mine and it is also OLF 170 ! No idea what is going on when the latest published version is 1.55. In version numbering 1.70 is many updates removed from 1.55. Possibly someone else knows?
My machine is running great after running many files through it. Sometimes certain hardware won’t let you downgrade to a previous version.

Thank you for the response.
Mine isn’t unusable by any means (after basically shutting off a couple of the safety features). It just still has a few little annoying quirks. And really confused on the whole OLF 170 thing and why it won’t let me update (downgrade?) the firmware.
Maybe @OrturTech?

I sent a message to Ortur Tech Support and this is their reply (BTW I have a one week old Ortur LM2 Pro)


OLF stands for Ortur Laser Firmware short
Depending on the machine production date some have 1.5 series others 1.7
Those users with 1.70 version are on the latest firmware and they cannot install (because would be going backwards) 1.55 firmware on those machines

This is a way for Ortur to know the production runs of the machines and keep some control on the type of machines users have as the machines do not have yet serial numbers (Something in the pipeline)

Gil Araújo
Ortur Support Admin"

So there you have it straight from the horses mouth. I hope this helps.

1 Like

Thank you. The info does help. Unfortunately it just looks like i will have to live with the minor issues.