Ortur LM3 WiFi access

It is buffer related and showed up when Oz was troubleshooting the WiFi connection with an LM3. I believe that you will see it in the testing groups in the next go-round.

Ortur does NOT use CH340 drivers.

Could i ask, in your console type
press enter, send output pelase?

[ORIGIN: China]
[MODEL: Ortur Laser Master 3]
[OLF: 205_RC9]
[SN: CF4F46B6920A3E53F46CFEAB559DCB58]
Target buffer size found
[BOARD:Ortur Laser Master 3]
[PLUGIN:Power Detecter v1.0]
[PLUGIN:Power Control v1.0]
[PLUGIN:gyroscope sensor v1.0]
[PLUGIN:Trinamic v0.09]
[PLUGIN:ESP32 WebUI v0.03]

RC9 we are on RC33 :blush:
Hikes thats old old firmware
Question, [IP:******]
Do you have local ip can you access webui?

Hi Gil.

I masked the MAC/IP to protect the innocent :wink:

I haven’t had any permanent success with wifi access, either with the Ortur software or LB over wifi.

Currently my IP is set to connect to my router (subnet is different from the default 192.168.5.xxx). It connects and I can ping it, but that is all.
On rare occasions I can connect with LB, but it’ll print out about 1K characters after issuing an “$$”, followed by locking up.

When the webUI worked (maybe twice) I could operate fine over my router-wifi connection.

Re. the firmware RC9 → RC33.

The Ortur website has no firmware page for the LM3 (just LM2 and others) Can you point me? I’d like to see the delta list or at least know what may have changed.


Is a local IP so is “safe”

Right so we need to get you into the local ip so we can get you into the simplest firmware mode
I am assuming you have local WIFI
please replace mywifissid and mywifipassword by your ACTUAL - case sensitive - credentials

press enteR
press enter
perss enter
Machine will think a moment then give you local ip

Once done, and it says in local the ip
Open a browser
Type the ip n the browser address and press enter
Ortur WebUi will pop up and ask you for user and password. In both cases they are admin

Now left side
System → Upgrade → use the file browser to local the file ESP_OLM3_205_RC29.bin and proceed with update instructions

As i cant send zip file here, i am using wetransfer:
Link: RC29

a) KEY “on” position might have changed from your RC9 - please make sure after update its pointing RIGHT
b) it should auto restart, if not you must power on
c) once done make sure you $RST=* in nconsole. This will however clear you wifi credentials, you might have to repeat above after.

Report back any issues please?

1 Like

Yeah, private network.

No problems hooking up to my wifi (with the SSID and passwd)
Once I was able to connect via browser to the webUI with the admin/admin and operate basic movements, etc.
Several days later after setting up in a more permanent operating location, the webUI and all other associations with the Ortur wifi interface failed, except for the ability to ping the IP showing connectivity and the occasional ability of LB to connect with the Ortur over wifi with the apparent buffering issues (1K characters then lockup)
This issue is a post of mine asking for info Ortur LM3 WiFi access

I’ll see if I can resurrect the webUI to get RC29 loaded up. No problem typing in the creds, I’ve done it dozens of times already :face_with_diagonal_mouth:

if all fails $RST=*
it will restore basics, then you can reuse the steps above

I’ll give it a go in a few days and let you know (day job gets in the way of fun)

Can I reset, (enter my wifi info via USB console) and enter my routers IP (which line? $302/$312 or both) to get it on the local subnet or should I just try to change my router to allow the .5 default subnet?

My router is set to assign a fixed IP based on the Ortur MAC.

CJ: Sorry to apparently have hijacked your thread!

1 Like

I would just give it the WIFI credentials
It will DHCP in the rest of the data, if you gave your machine a IP, DCHP from the router should give it that ip and all the data.

Gil, thanks for the help.

I was able to connect via HTTP and get the firmware update installed. The AP was re-assigned the fixed IP provided by my router.

LB can access the LM3 now via ethernet as before, difference is before the console would hang after line $312 when issuing a ‘$$’.
Now it pauses for a few seconds at that same line, then continues on with the rest of the parameter list through line $662.

The console is constantly reporting back the following (at about a line per second)

Anyway, I’m tempted to try a job over ethernet but hesitant based on JohnJohn’s comment about this capability is not yet ready.

waiting for 1.2.02 launch would be ideal but i been using beta without issue

I see you have both webui and lightbun at once connected, that might cause the little hangs,
However as a test, try a project at 1% power. wont spoil anything and will take it to its paces

WIFI does require some stable wifi connectivity, i am a bit spoiled as i have a over kill unifi setup at home. because… well i am a geek lol

But if you have a low wifi signal some stutery can happen, the system SHOULD recover from it though

If you’re interested and willing to tolerate and report unanticipated behaviours, I believe that I can get the beta version to you for testing.

I will send you a message with a download link shortly.
Thank you for your patience.

I’d love to play lab rat John. :grin:
Gil, correct, webUI was also running and that of course has a refresh interval (oops).
I have a solid wifi connection with a single bridge.

I disconnected from the web UI and the previous symptom of the console hanging after line $312 has returned (assuming a LB vs. webUI difference here).

1 Like

You have mail. :slight_smile:

Install went smooth.

Won’t be able to give it a thrashing until tomorrow however.

Still hangs on '$$" ( gets to $313 now ) but I’ll avoid doing that in the mean time.
Thanks John.

1 Like

Spent today cutting wood veneers, basically vectors from a DXF import (macDraft).

Feels great to be untethered :grin:

These were relatively short runs (~10 minutes) but zero issues. On occasion the laser would stop (beam turns off, no movement) for up to 10 seconds, continues on fine so I’m assuming that is some delay for buffering.
So far I’m elated! Tomorrow I plan on trying some image tests which will elevate the data rates.

All other aspects of LB that I used remain as I remembered, no issues.

I did a bunch of laser test grids using the LB laser tool item, 10x10 and some 5x5. Run times were about 30 minutes, the 5x5’s were 2-pass burns.

The first three went fine, some pauses but completed.

The next two had some issues. First of these apparently crashed the OM3. Power button was dark, LB was essentially locked up and I needed to kill the process. Not sure of which one occurred first, but if I had to guess, the guilty party was the OM3. It died while printing the test pattern header (first stage of the job)
I powered the OM3 back on and was able to reconnect w/LB. Restarted the same job and it finished normally.

A few changes of power/speed and ran another test. Same crash symptoms but it did get about 3 minutes further to the axis labels before the OM3 went dark.
All these tests had a max power level of 75% and no indications of any excessive laser heating.

I switched to USB and restarted the job (finished normally), also ran two more which finished normally.

Not quite sure what to make of this, but I’ll try some more next weekend.

1 Like

Thank you for the testing and feedback - much appreciated.

Hi, I am a new LB and laser user, too. And I also have issues with the Wi-Fi connection:

I am using a MacBook Air and have only USB-C Ports, that’s why I’d like to use Wi-Fi. At the beginning I had problems to connect the App. That’s why I startet with an old windows laptop with USB. First tests worked fine, an finally I was able to connect the Laser to my local network. I set the Wi-Fi router to give the laser always the same IP:
But when I started jobs via Wi-Fi, the machine stopped with an error (number 24 if I’m right).
I started to search for a solution and found this thread. First I installed the new firmware (thank you for that). But the engraving stopped again with an error, number 2 and number 25 this time. I turned the machine off and on again and again, checked the web interface (I also found the IP in the settings in line $312 and $313 ) but now I am not able to connect via Wi-Fi again, not with the Mac, nor with the app or the web-UI. But the strange thing about this is that the OLM3 seems to be connected to my local Network: it’s blinking orange every 4 seconds, and the UI of my router says it’s online.

Long story short: I would like to reset the machine completely and start from the beginning. Probably I’ve done an error in the settings in the web interface of the OLM3 while I was testing out the Wi-Fi settings ( Ithink I changed DHCP to static if I remember right but because I can’t enter the web interface anymore I can’t check this).
How can I make a factory reset?