Pen Up / Pen Down ( Z - Moves ) problems

Hi,

in RDWorks I could easily move the Z-axis as I wanted. I can’t do that in Lightburn.

The function of pen up / pen down is not taken over in the way I could use it.

I need a return trip to Z = 0 for each layer.

At the moment it is like this:

A circle as a layer

→ Z moves down

→ It is driven to the circle and this is followed

→ Back to Origin

→ Z-axis moves up

Two circles as two layers

→ Z moves down

→ It is driven to the first circle and this is followed

→ Z-axis moves down

→ It is driven to the first circle and this is followed

→ Back to Origin

→ Z-axis moves up.

As a result, it is no longer possible to use the Ruida controller as a CNC, which I plan to do :slight_smile:

It would be nice if the old pen up / pen down function worked.

A circle as a layer

→ It is driven to the circle

→ Z moves down

→ The circle is driven

→ Z-axis moves up

→ Back to Origin

Two circles as two layers

→ It is driven to the first circle

→ Z moves down

→ The first circle is driven

→ Z-axis moves up

→ It is driven to the second circle

→ Z-axis moves down

→ The second circle is driven

→ Z-axis moves up

→ Back to Origin

Here in this Video´s from me, you can see as example what will be nice to work.

If the pen up / down is now turned in the properties, then I can mill.

or like this …

:slight_smile:

I used a RD6332G Controller with a Gravograph VX92.

kindly regards
michael

This is worth review: Device Settings - LightBurn Software Documentation

Hi Rick,
thank you for your answer

I am sure that I checked and tried all the points yesterday. I used the upper limit switch and also the lower one.

I turned the engine in setup and back again.

I played with the height of the material and the height / depth

But I’ll try again :slight_smile:

If I succeed, I’ll take screenshots.

If I don’t succeed, I’ll make a video :slight_smile:

thx
michael

Sorry, but the bug is there.

No matter what setting.

Z moves at the beginning of the layer before it goes to the actual coordinates ( vector zero point )

That is not right.

And then…

When you have two layers and layer 1 is over, z goes to zero (that’s right) and then z goes to layer height 2 (that’s wrong) and then goes to the coordinates for the second layer ( you will crashed into layer 1 )

Lightburn moves Z on start/end of the Layer and not start at the vektor

Can you check it please :slight_smile:

Hello.

I can confirm Michaels problem on my machine with Ruida 6442G an lastest Lightburn.

Even with Z move optimization disabled, the z axis moves down BEFORE moving to the start point of the cut. This was definately changed somehow.

In earlier Versions the Head Moved to the sart of the Vector, then moved down, cut and moved up at the End of the cut. This is imho the only meaningful sequence.

I would be pleased if that can be fixed too.

Cheers, Christian

We’ve had customers argue for both - Some people want the Z move to happen first, for example if the starting height is lower than the material surface, and others want what you’re asking for. I’m leaning toward making it happen after the first X/Y move, but I’ll have to verify that it’s even possible - Ruida controllers can be very picky about where Z moves go.

1 Like

It would be great if you could check that out.

Think about it, someone would like to laser a glass bowl or something similar from the inside, several times next to each other.

That doesn’t work then :slight_smile:

the laser head moves in front of the bowl edge.

greetings
Michael