Port Failed to Open Already in use? Error Message

I’m brand new to the laser and lightburn. We received our laser last week Xtool D1 Pro , hooked it up, downloaded lightburn and connected without a problem. Tried a few tests. We shut down, and today we tried to connect to it again, and it will not connect. There is only 1 com option, Com 1 and that is selected. Everything is up to date, I literally just downloaded and updated everything. I’ve tried uninstalling and reinstalling, but absolutly nothing. Any ideas?

I’m sorry I can’t help with your question. I’m having the same issue and I can’t find answers ANYWHERE!!. I’ve had my xtool d1 pro for a few months now. Yesterday I did an update to version 1.3.01and now I’m getting a message saying, “waiting for connection”. The laser says “ready” but won’t do anything, So I know whatever port it’s in is working fine, my computer also makes a “ding” noise when something gets plugged in, so I know the computer is fine. Creative space works fine so I know the laser works, but I didn’t pay for creative space I paid for Lightburn. I have tried everything I can think of. I’ve switched ports, uninstalled, reinstalled, uninstalled, reinstalled with that little switch on the xtool in both directions and nothing and getting support from Lightburn or xtool is next to impossible, I have typed this problem on so many forums its driving me crazy! The same answer every time. Is it in the correct port? It’s like people just want to answer and not read the entire explanation. I’m looking for someone who has had this issue and can explain how to fix it. so good luck to you. And if you don’t know already there is a few Facebook groups that are WAYYYYYYYYYY more helpful than xtool or Lightburn. One is Xtool for beginners. If they can’t help, they actually research and eventually get back to you with a solution. I’m still waiting for an answer on there. Guaranteed I’ll get an answer there before xtool or Lightburn

simply pull the usb plug and wait one minute than reconnect it and it should pick it up

1 Like

nope… simply unplugging things and plugging them back in after 1 min does nothing. says laser is busy. Haven’t used Lightburn for over a week

Try this:

  1. Confirm that the COM port is being created/removed in Device Manager when you plug/unplug the device. Note the COM number.
  2. Make sure XCS is not running.
  3. In LightBurn, make sure the corresponding port identified in the first step is selected in Laser window

If that doesn’t work can you take a full screenshot of LightBurn with Console and Laser windows showing?

Also a screenshot of Edit->Device Settings window.

did you ever figure this out bc mine is doing the same thing now.

I would also be interested in any answer found to this issue - I am having the exact same problem as the OP described.

Had the same issue. Uninstalled v 1.3.01 and re-installed v1.2.04 and the problem went away. Hope this works for you!

I tried reassigning it the correct COM Channel. In the laser window, next to devices, you will see a dropdown with different COM option. My xtool worked with COM10 yesterday. Today it was at COM3. I changed it to COM10 and it was able to establish connection again. Let me know if you have questions.

1 Like

The correct port for an xTool D1 will have ‘wch’ in the name.
We had a couple of MacBook Pro laptops in testing yesterday and there was one unanticipated quirk I could share.

Please confirm that you’ve downloaded the CH341 driver from xTool.

With the Driver installed one of the Serial port options will have ‘wch’ in the name.
Select that port and see if that connects. If it doesn’t, please test the strange Mac Ventura quirk we observed yesterday.

With the ‘wch’ named port selected, if the connection didn’t happen, close LightBurn and relaunch it. We had two engravers that wouldn’t connect without the restart.