Position shift between layers

I may be new to this forum but not to troubleshooting. That said this is driving me up the wall.
when running a file with multiple layers (or colors) I am intermittently getting some sort of shift between layers, particularly when switching from engraving (fill) to cut (line) I have run similar and more complicated files before with no issue and older files of the same variety run fine. I am sometimes able to get it back to normal with a default parameter reset but it’s becoming more frequent. I am not losing steps, powercycling does nothing and I have made no headway on this in the past 18 hours.
Here’s the weird part, on the HMI as its tracking the head position it usually just changes the color of what’s on screen as it is completed, in the event of a shift however it draws a second image in the shifted position. shifts have been anywhere between 1/8" to 3/4" and I can find no other rhyme or reason as to why.
Any insight would be greatly apreciated

4 posts were split to a new topic: Fills are shifted when sent to controller

You most likely have one of your motors skipping when moving between sections of the file. Check to make sure that your idle speed and accelerations for both engraving and cutting are not too high.

I have been experiencing the exact same thing, twice now with the same file. I have cut the file maybe 15 times without issue; twice with the issue. No other files have done this. I have three engrave layers, then it cuts out the shape on the final layer, and jumps the circle about 1/2 inch to the left. I have pictures; can I share those here or do I need to start a new topic?

Oh found it. Here we go; this is what it is supposed to look like:

And this is what it does:

It did the same thing each time; looks like the same offset from my pictures. I will try and watch it like a hawk (I have three of these to cut tomorrow) to see when (if) it occurs. Certainly the file loads normally and starts engraving OK.

Click ‘Devices’, then double click your laser, click ‘Next’ to get to the protocol selection page, and try switching to ‘Packet/USB’ instead of ‘Serial/USB’. For Thunder systems this seems to help the stability.

OK; thanks. Is the ‘packet/USB’ a Windows-only option? I have serial or Ethernet.
Now, I did get one of those Ethernet adapters and I’ve been a bit slack in using it as I lose internet on my computer when it’s plugged in. Lazy, I know! I’ll try using it for this file in future. Going to try it right now…

Ok, test run and dismally failed. The file was reloaded from the ethernet connection and did exactly the same thing. I think I am going to have to split this file up and cut the circle as a separate operation; this is a waste of acrylic.

Do you use ‘Send’ or ‘Start’ when sending jobs to the laser? And yes, ‘Packet/USB’ is a Windows only option.

This is not going well. I split the file up so one file engraved, then I loaded the second file to cut the circle. While the cut then worked fine, it turns out that all the numbers got offset from the inner circle. It never did that before. Is there something up with this file?

Edit: I’m using ‘send’, I never use ‘start’ since it messes with the air control on Thunders.

Email the file to support@lightburnsoftware.com and include a link to this thread. I can have a look.

Thank you so much. Email sent.

Your C26 (first) layer is set to 450 mm/sec, for a line layer - the machine will never hit that speed for these, and depending on the acceleration settings, it’s likely to shake pretty hard and could slip as a result. (You also have most of those shapes set to power scale at 14%, though that shouldn’t affect it)

OK, thank you. I was not aware that 450 was too high for line engraving. I will try slowing it down a bit and see if that helps.

Just a quick update for info; I cut five of these yesterday at 250mm/s and they behaved just fine. (Hoping I’m not jinxing the three I have to cut today!)
Thanks.

I am also having a shift issue, but it is not layer based and my speeds vary but this job is at 200mm/s.

I have tried different positions, different files altogether and even rotating 90* and cannot seem to solve.

Other trials and placements:

That looks like you have a physical issue with the machine - like loose pinion gear or coupling connected to one of the motor pinions or shafts. My second guess would be a bad motor driver.