Positioning problem

At first, I am sorry. I don’t know English so I use google translator.
I have a licensed LightBurn. The device is a Sculpfun S9 laser plotter. The plotter has installed zero points in the lower left corner and updated firmware from the manufacturer. After connecting the laser and turning on the LightBurn, the device automatically sets to zero. The layout origin and the job origin are the lower left corner. Work is to start with absolute coordinates. Unfortunately, every figure you draw won’t start to cut. Instead, there is a warning that the target of the G-code motion exceeds the machine’s range of motion.

<Idle|MPos:-407.000,-397.000,0.000|FS:0,0|WCO:0.000,0.000,0.000>
ok
<Idle|MPos:-407.000,-397.000,0.000|FS:0,0|Ov:100,100,100>
ok
Starting streaming
ALARM: 2
The target of the G-code movement exceeds the range of movement of the machine. The position of the machine is held securely. The alarm can be unlocked (Right click on the “Devices” button to reset the connection).

On or near line 2:
Streaming will end in 0:00
[MSG:Reset to continue]
ok

Grbl 1.1h [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
[MSG:Caution: Unlocked]
ok

If I use the go to starting point button, the laser head goes to the upper right corner. I am attaching a GRBL code dump in the machine:
$$
$0=10
$1=25
$2=0
$3=0
$4=0
$5=0
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=1
$21=1
$22=1
$23=3
$24=200.000
$25=3000.000
$26=250
$27=3.000
$30=1000
$31=0
$32=1
$100=80.000
$101=80.000
$102=250.000
$110=6000.000
$111=6000.000
$112=1000.000
$120=1000.000
$121=1000.000
$122=1000.000
$130=410.000
$131=400.000
$132=200.000
ok

and a screenshot of when I try to make a cut.
Additionally, I attach a screenshot when I run the option: get position.
The values for the X and Y axes with zero values become X: -407 and Y: -397.


Before turning on the laser, make sure the laser head is positioned on the front-left of the machine. When you turn on the laser the front left will be 0,0. This will allow you to address the entire work area.

This is what you usually ask.

$I
[VER:1.1h.20190825:]
[OPT:V,15,128]
Target buffer size found
ok

$$
$0=10
$1=25
$2=0
$3=0
$4=0
$5=0
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=1
$21=1
$22=1
$23=3
$24=200.000
$25=3000.000
$26=250
$27=3.000
$30=1000
$31=0
$32=1
$100=80.000
$101=80.000
$102=250.000
$110=6000.000
$111=6000.000
$112=1000.000
$120=1000.000
$121=1000.000
$122=1000.000
$130=410.000
$131=400.000
$132=200.000
ok

$#
[G54:0.000,0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
ok
?
<Idle|MPos:-407.000,-397.000,0.000|FS:0,0|WCO:0.000,0.000,0.000>
ok

I always pay attention to it.

Does this mean that starting with laser at front left did not work?

Is it possible that your laser is oriented backwards? I believe for your laser that the controller should be at front right? Is that the case here?

According to the instructions, the zero point is in the front left. There I also have a limit switch mounted on the X and Y axes. Connecting the laser in LightBurn after the HOME command, the head moves to the lower left corner.

You didn’t mention earlier that you added limit switches.

More information on this Topic:

But do this… run a homing cycle. Then type into Console:

G92 X0 Y0

Then retest.

You’ll likely need to do this after every power cycle. Or consider flashing a generic GRBL firmware.