Possibility to offset Z material thickness for Gweike Cloud machines

Hello fellow laser-enthusiastics,

I have a Gweike Cloud machine for a little over a year now and worked with Lightburn from the start.
Everything is working fine but I would love to have the material thickness making sense for this unit. If you want to know, I have set it up just like this tutorial: How to use Gweike Cloud with LightBurn + tips, tricks & FAQ

As you can see the Z index is the challenging one. The detault home position is 0, and the laser needs to move closer to the material by going down, positive value (or negative Z offset called OUT in material settings). But when you also enable the nice feature of setting a material thickness (which is a very neat feature!) the offset is calculated the wrong way (even closer to the material), which makes sense if it was the bed which was moving. But with Gweike it’s the wrong way.
I have played with the machine settings, inverted some Z settings, but ended up with the home (z = 0) being ON the material, because the material thickness is a positive value, so further away from the material. So that’s not a solution.

What is your opinion about it?
I dream about a setting called something like “negative material thickness” being in Lightburn device settings, so that the z-offset of the layer is always at 17 mm (OUT), and the thickness will just be subtracted from that, so for example 3mm thickness will result in (17 - 3 =) 14mm setting as Z for the laser.
Looking forward to hear from you :slight_smile:

Try this thread…

:smile_cat:

I just answered this thread you mentioned, so no…
I am looking for the option in Lightburn to have a negative material thickness.

I understand the axes locations are all positive numbers…

Hang in there and maybe someone from Lightburn will drop in and advise you…

:smile_cat:

Thanks Guys, I’ll take a look at that guide and probably go with removing the honeycomb tray and remeasure. Appreciate the quick response
Paul

I think this answer from @taffy was on the wrong thread. But thanks anyway :slight_smile:

Hey, just wanted to see if you had sorted your issue?

I wrote the guide you linked to and on my machine it doesn’t function the way you have described.

And if it helps, I like to think of the number 17 being the default home and to move up from there you take the material thickness from 17. e.g. for 4mm material your material thickness should be 13.

I don’t vary the Z offset based on material thickness. I only change that if I want to defocus the laser for engraves, or cut through thick material and set the focal point down into the material on later passes.

1 Like

Thanks @BillieRuben for your reply.
My Gweike laser is running fine. But I think Lightburn can improve the software by changing it slightly, so we can indeed just use ‘material thickness’ setting the way it supposed to work, the value of the thickness of the material. Not some kind of calculation.

You said it doensn’t work the way I describe it. Do I have another version of the machine, or what do you actually think is different?

With this request I just wanted to make it easier for everybody to use Lightburn.
Thanks!

I agree that having that ability sounds good for sure! I’ve passed it onto the lead developer in the past. :slight_smile:

I just re-read your post and I think I had misread it the first time, I’m sorry. I had thought you were using the z-offset (in the cut settings) to designate the material thickness, but I realise now you were asking for the ability to offset the Z universally for this machine.

My bad!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.