Possible Bug - Galvo with Rotary

I have been running an OMTech Galvo laser with Rotary (chuck type)

The rotary is making several unnecessary moves, rotating multiple revolutions between slices (and sometimes ends up marking in the wrong place)
I’m not sure where this figure comes from, but seems to conicide with the 10 full rotations that the chuck does between slices.

Rotary settings

Lightburn File
TL-002.lbrn2 (19.0 KB)

I have a video of this behaviour, but can’t attach it here.

2 things to do/ check. before starting click “Go to zero” to clear the 942.139
I have had numbers in the thousands up there and rotary wil spin that far before starting, and spin back after done, I posted a long time ago about his number which seems to change at random at times.
2nd thing, next screen uncheck “Run whole shapes if possible” , that may be the cause of the jumping around. If you do want to use that setting, go to optimization and check “Reduce Travel Moves”
Always scan parallel with axis unless using the “Whole Shapes” setting.

Thanks for the response.

Clicking “go to zero” doesn’t really help - the chuck still has to actually turn to go to zero. (which for 10 turns takes time - I can’t run the chuck any faster as I am marking devices with cables attached)
Maybe a “zero offset” button is needed? Or auto zero when starting the software.

“Run whole shapes” is unticked already.

And yes, I’m scanning parallel with the rotary axis.

When I originally open the window on mine, when it was coming up with random “Pos:” numbers, the go to zero just cleared the position. After using the jog buttons, the return to zero then moved the rotary to the previously zero. So apparently my issue was different.
Just guessing, power off, unplug your rotary, power back on open the rotary window and see if you can reset zero. Then turn power off and re-connect, power back on. (It is really hard on a driver to unplug a stepper motor while powered, even if not in motion.)
One last thing, try “Run All Shapes in each slice”
Can you do a video?
I wish I could be more help.

Oz commented on how the rotary worked on the fiber and stated the zero point is where ever it is when you run the job…

Can’t say it hasn’t surprised me a few times by it’s operation…


This was me having the similar issue July 2022. An if I hit start, it would rotate 9,941mm before it started burning, but go to zero would clear it.

That’s not exactly true.
If you run an image, then jog around to look at the back side, then start again, it will spin back to original starting point before starting. Even if you leave the rotary screen and come back. At least for me.

I just remember reading his description…

Mine has done a couple weird things that I can’t explain…

Maybe he meant when Lightburn connects… goes into rotary mode…?


That is how it typically behaves, except when it doesn’t! :rofl:
Mine has been behaving well lately but I still have to clear the “Pos” field from time to time
I also put a neutral button on mine so I can rotate it while the framing laser is running.

Took advantage of the Enable on the microstep driver

Squeezed in one more GX 12-2 aviation Jack

Modifying the laser marker is not an option here - I’m not voiding the warranty.

I’d like to get to the bottom of where the random starting zero number comes from ideally, and how I can reset it without running the chuck through multiple turns.

1 Like

Agreed… not a good idea…


I would like to know where that random number comes from as well. Been going on since LB for galvos came out. Funny though how my “Return to zero” resets it without spinning if I select it before I do any jogging. (Regardless whether I have the engage button on or off)

No comment from Lightburn Staff on this one?

There is currently a significant effort in Galvo Rotary support refinement and fixes being worked on, with updates expected soon-ish. :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.