Power levels not changing between layers/sublayers

@JohnJohn Heard anything back? I’m running a job next week with 100 parts that would really be nice to one as one program. Thanks.

I’ve bumped it where I reported it. I’ll draw some more attention to it if I don’t hear back shortly.

I just bumped it again in a more prominent channel. I’m trying… :slight_smile:

The first time I read this, I mistakenly thought this problem emerged after an update from a previously working version.

Because this hasn’t worked correctly for you up to this point, we’ll take a precautionary step, reimport the markcfg7 file, and retest. Do you still have the software (USB stick) that originally shipped with your engraver? If you’re willing, please share the markcfg7 file here. It’s possible that a very early version of the importer didn’t apply the settings correctly. I’ll try to verify what happened.

To start this process, Please Identify the Laser Source (JPT, IPG, etc.) and the version of LightBurn you’ve selected.

In LightBurn, click File, click Export Prefs, and save this file on your local Hard Drive in a directory without ‘OneDrive’ anywhere in the full path. Double-click the address bar to verify that OneDrive isn’t involved with your selection. Select a filename that you would find easy to remember.

Feel free to share that file here as a backup plan.

With those two files in hand, (markcfg7 and lbprefs files) use the Importer in LightBurn and build a new device profile for your Galvo.

Follow these steps to build a new Device Profile for your laser.

Please let us know if this process allows power levels to be changed in LightBurn between layers.

When you get this working and calibrated to your liking, save a new copy of your lbprefs file into the same directory as before. It’ll be good to have it to compare to the previous file for further troubleshooting.

Thank you so much. I was only able to set up and do a quick test today, but it seems like it’s working as expected. I’ll run a real program through it tomorrow and verify, but I think that did the trick. I figured it had to be something with the laser setup.

1 Like

If you saved the old prefs file and a new prefs file we may be able to determine the cause.

It’s not letting me upload the markcfg7 files.
I had copied the markcfg7 into a “laser config” folder and thats where I imported from originally. This time, I imported directly off the USB drive and that seems to be the fix. They have the same date modified dates.
I’ve run a few tests, and everything seems to be acting normally now. Let me know if I can help share any more information to determine a cause.

Lightburn Preferences 11-6-23 (original).lbprefs (40.1 KB)
Lightburn Preferences 11-7-23 (after reimport).lbprefs (40.6 KB)

If you add a .txt extension to the file, it will let you…

You can also put it in something like a google drive and post the link here. Make sure you set it so everybody with the link can read it.


1 Like

Here is the original.
markcfg7.txt (10.2 KB)

1 Like

Here is the one off the USB.
markcfg7.txt (10.2 KB)

6 posts were split to a new topic: Galvo not changing power levels between cleaning and engraving passes

For the 50W Galvo laser, It looks like there are different 50W models with different sources.

Which laser source (JPT, IPG, etc) are you using?
Which version of LightBurn?

I don’t know how I missed this when you responded but I’ll get the files in for analysis right away.

Mine has a Raycus laser.
Currently on 1.4.03. I’ve had my laser for a year, and it’s occurred on every version of LB I’ve used in that period.
I seem to be having the same issue as CJ. It seems to work right after I reimport the mark file, but if I change any settings I experience the power issue again. I haven’t done enough testing to narrow it down to what settings affect it.

1 Like

I just posted in the new thread. I will be posting there for any future discussion.

1 Like

5 posts were merged into an existing topic: Raycus RFL-P30QS Power Levels not changing between layers

This statement is confusing - How would you know it was working if you weren’t able to change any settings? (what settings are you changing that makes it stop working?)

1 Like

Sorry for not being clear, I meant the device settings. I haven’t done enough testing, but, from I can tell, I can import the markcfg7 file, and I can load the COR file. But anything else on the device settings screen will cause the power issue.
I need to be a little more methodical, and note what was changed when I see the problem, I hope to dive in deeper after Christmas. It seems to be working now, so I’m hesitant to go poking around until I get some orders finished.

1 Like

The markcfg7 file is set when you create a device… The COR file is used after it’s created…

As far as I know/knew, you used one or the other, not both…?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Reimporting the markcfg7 file seems to have reset the Simmer Current “Laser_SPI_Simmer” setting to 80 which is expected.

Since this thread is time-locked and it appears resolved, please DM me and let me know if the unwanted power level behavior was solved by reimporting the markcfg7 file.

I’ll attach the Direct Message here and delete the DM comments.