Power modulation problem I think

I have an inexpensive Ortur 15W Laser Master (don’t laugh at the name, I didn’t name it) that runs on a Pi knockoff board (I’ve been told) that came with LaserGRBL and does pretty well for the sub $200 price tag all in all. My problems arise with grayscale prints.using LaserGRBL if I tweaked every image using countless test prints eating up material I found that the process of converting using their import too and setting speeds and power was too inconsistent for any kind of workflow.

So I decided to check out Lightburn which is pretty amazing all in all! I watched a few tutorial videos and dove in starting with vector images and solids etc, everything worked out great! So, let’s see if I can make sense of grayscale settings via a couple of test images…

he first was a grayscale image created in photoshop that is a gradient band going form 255-0

This band is 80mm wide (half the bed area), I would attempt a run and if it didn’t look right I would adjust the speed, move the image up in LB and try again. After fiddling with this for a while I found a topic that I thought would help and created a Power Scale Test (going from 10% power on the left to 100% on the right) just to get a baseline of speed to start with. I know we are dealing with vector and grayscale here but the power percentage change should be visible.

Again, there should be 10 blocks here! I’ll include my machine settings below, thank you in advance for your help!


What is your S-Value max setting in the Device Settings box? It should be 1000 to match the setting in GRBL. I also noticed the $33 setting in your firmware, which usually means 'pwm modulation frequency in Hz", and it’s set to 350, which is pretty low. You didn’t mention what speed you’re running these boxes at, how you created them, or what the preview looked like. All of those things would be good to know.

1 Like

S-Value max is 1000 as well.

$33 is the factory setting, I’d be glad to experiment, what’s the easiest way to change that?

The boxes were created in LB and repeated using the array command and then the power scale modified in the Shape Properties window.

Fill and Line for the boxes at 1000mm/min

Grayscale (last test) was at 1500mm/min. Just to be clear the grayscale should fill left to right most of the image…

Preview looks correct.

BTW, thank you for both creating a pretty awesome program and keeping it updated and adding features and for being so active in your support role!

To change it, just type $33=xxx in the console, where xxx is the new value. It kind of looks like you’re getting threshold behavior from the diode instead of grayscale control, which is weird.

I’ll play around with that, will that change it permanently each time or per “job”?

It’s sticky - set in the firmware of the controller until something changes it.

Thanks Oz, I’ll give it a try and let you know!

Changes up to 1000 and even 2000 haven’t had any effect.

I would suggest you contact the seller / maker of the hardware to see if that machine supports PWM control of the laser output.

You should be able to use dithering without issue, and LightBurn will do that transparently for you.

I’ve reached out to the distributor, sending them sample files and sample outputs on my end. Here is the LightBurn file I created and the results, if you could look at the layers and the laser power percentages to make sure I created it correctly I’d appreciate it.

test file.lbrn (32.0 KB)

I would set your power min to be the same as your power max throughout your fill layers. Currently you’ve got them set all to 10%.

Or at least that’s what I would do with my Ruida controlled co2 laser.

Also, is there a reason you’re running them at a 45 degree angle?

Thanks for the reply! I don’t see anywhere to set the minimum anywhere (screenshot attached). It’s greyed out in the cuts window and I don’t see it in the cut settings, is there somewhere else?

I think I just set it at 45 initially and wound up copying settings from there.

I see. When I load it for use on my laser, I have the option. That’s a tad confusing. I know with the co2 laser, doing a 45 degree burn doesn’t work the same as doing it straight 0 or 180. I get pretty torched edges with 45s.

Anyhow, I guess I’m pretty useless here lol.

I appreciate you trying man, this is all foreign to me! I think 45 was recommended for grayscale or one of the dithering patterns, I dunno, but it shouldn’t affect the craziness that I’m seeing :wink:
I seriously appreciate this community and Oz!

I just got the same laser engraver and I have been messing with the same thing! It is supposed to be PWM but nothing seems to be working. I will be continuing to mess with it and hopefully we can get this figured out!

Glad to know it’s not just mine (maybe). I reached out to Brandon Cullum of the Make or Break podcast to see if he could test these files as well, he was where I saw it originally. He seemed to be getting good results with LightBurn so that brought me here to try it.

Try to download the file and see what you get as well!

I’ve been in touch with GearBest and they’ll replace my machine for free but if it’s a widespread problem I’m not even going to bother. Let me know what happens for you and I’ll go from there.

I can see the laser change intensity but also when it’s over 20% it kind of sputters in the middle along the white to black test strip. Not sure if I can upload videos on here but I can record it. Have you had similar issues?

Nevermind hahaha from the pics above it looks like our lasers act the same way with that sputtering or skipping.

Thanks for trying! I’m waiting on one more test before I make my decision, if the only 3 people I know that have this machine all have the same issue I may just keep it and not do any grayscale.

If you can upload a pic that would be great!