Power problem on one axis


I got a problem with my NEJE Laser.
As in the picture you can see, one axis cuts good, the other one just makes a dotted line.

I changed the laser head from the standard (something 2.5W) to a stronger (5.5W).
With the old laser there was not such a problem.

I tired to tention the belt, but nothing changed.
I know that the diode is square, tried focusing and so on. But i just can’t belive i have to use lower speed than with the old laser head.

Any ideas?

Thanks Mo

Is it possible your power adapter is not rated for the increased current requirements from the higher power laser module?

I changed the power supply to match the new head.

What’s the current rating of the new supply?

What model of laser module did you have before and what did you move to?

Power Supply: 12V/ 5A (60W)
Laser Head: NEJE N40630 (5.5W output)

The old one was the NEJE Master 2S standard head. Not sure but i think something about 2.5W.

Did you make any configuration changes after swapping the module?

Can you provide the following:

  1. screenshot of Device Settings?
  2. Run these commands in Console and return output:
  1. Save some g-code for a sample project set for 100% power in Laser window with a .txt extension and upload here.

No changes made.

Target buffer size found

Sample.txt (275 Bytes)

I don’t see a fundamental configuration issue or an issue with the generated g-code so the problem lies somewhere either at the controller or laser module.

If you’re not experiencing this with the old module then it’s likely a hardware issue with the new module.

Initially I thought you might be getting power drop-out at low speed or power but that doesn’t seem the be the issue in this case.

What material are you cutting in that photo? It look like MDF or chipboard or something similar. Can’t quite tell. If it’s something with a grain then perhaps rotating it to see if the problem moves to the vertical cut.

Thank you!

The picture is a thin cardboard. I tried to turn it, had the same intention.
Saw the same dotted line with wood but didn’t saw the problem at this point.

I thought about a hardware issue but I don’t get it why the head works good on the x-Axis but not ok the y-Axis. The laser should not care about the direction the motor moves!? So it must be something with the controller?
Maybe I can switch the cables of the motors to see how the cut behaves.

Good test.

Also, do you see any mechanical differences in the movement of X and Y? Any vibration or anything?

Can you actively see the light going in and out as it moves across X?

I know you got a new power supply for the laser module but this still feels a bit like a power supply issue.

Did you get an adapter board with the laser module that you can use to provide separate power to the laser module? If so, I suggest you try that and power the module separately from the controller.

Did you get an adapter board with the laser module that you can use to provide separate power to the laser module? If so, I suggest you try that and power the module separately from the controller.

I have an adapter board, but I’m somehow to dumb to use it…
4 Pin from the driver board but only 2 or 3 pin input to the adapter…

Can you take some good photos of the adapter that show the overall layout as well as any markings on the PCB?

I have one of these animals… Works well … I run it off a 12V/4A supply that only feeds the laser, but it appears that it could easily support the addition of the small ‘blue pill’ controller… I don’t think it’s a power/current issue.


Here’s mine on a jl1.

There are only three wires to the laser module that are required, the left three in the pin out diagram (first image) … 12V, GND and TTL/PWM, respectively.

Although the it says TTL it will allow 12V on it’s input … meaning it switches at ttl levels, but will tolerate 12V.

@berainlb notice the input current/wattage data :exploding_head:


3A for the laser module + ~1.5A for the board and steppers brings overall draw to around 4.5A so should be below the 5A rating of the power supply. However, it’s unclear if the power supply is performing to rating. If the adapter is available than a relatively easy test to take power supply out of the equation.

Besides, I don’t have an alternative better hypothesis for what might be going on. :rofl:

Pick up one of these < $50 digital handheld scopes and look at the pwm…

My only suggestion is to make a vertical line and a horizontal line at the same pwm setting…

Measure each pwm and see if they agree… at least you could eliminate or confirm it is or isn’t the controller.

Simplest way is to make a rectangle and monitor the pwm… they should agree during the straight parts. Just single lines will also work…


@Mo_99 indicated that this was not a problem with his old laser module so my assumption is that PWM is functioning correctly at the controller.

I’m sure you know about assumptions… I’m just trying to eliminate or identify something useful.


1 Like

Answer from the NEJE support:

Reduce the speed to 500mm/min, and reduce the power to 70%-80% accordingly

Cool, got an new Ferrari to drive in first gear :man_facepalming:

The Adapter:

top left corner goes to the Laser Head
And there are the inputs A, B, and C with two or three pins.

Laser Head:

4 pin comes from the controller directly to the Laser

So to use the adapter board i have to get a 4 to 3 pin adapter cable?!

Thats a good point, I’ll see if i can arrange a scope to measure.