Power Settings Won't Adjust

s-value max is a gcode thing and not relevant to your ruida controller. That’s why you don’t find it.

Hi Hank,
Thank you for the clarification! I knew this at one time and didn’t put together the DSP vs GRBL.

I did another video today for OMTech Tech support, per their request, I downloaded the lastest version of RDWorks, but it is still doing the same 19-20 milliamps. I’m looking forward to hopefully hearing something positive to be able to share on here.

Thanks again,
Mark C.

Hi Mike you need to make some tests before changing the firmware, u need to check if the signal is going right to the power supply

1 Like

I’ve noticed something that makes me curious. You have a 60 watt compared to my 50 watt. When I run 80% I start getting into the 20+ma range and I can push it further. Can you get more than 19 ma through it?

It may be a symptom associated with the problem in that it is NOT going to full power but something different…?

dont mix up the settings for grbl and ruida controllers

display on the ruida shows 8% power, try see what happens if you plug the connector into the 2nd laser port, enable dual laser and set laser 2 to 8% see what is the outcome?

I had mine of Ruida and or some facebook groups

I’m running short on time tonight, but I quickly tried 95% burn and it did not go above 20 mA. It maybe a setting I missed, so I’ll try again tomorrow…thanks for the idea! I’ll check in tomorrow after a retry.

I’m running short on time tonight, but I did try laser two and got two results:

I got water protect shut down
I got the actions without any laser fire.

I put everything back to the way it was and tested. I’ll give your idea another try tomorrow and try to find the setting that I’m missing. I did enable water protect for laser #2, but apparently there’s something else I’m still missing…thank you for the idea!

Just another part of the puzzle :slight_smile:

I think my problem is the PS

Carmel, what did you find that is pointing you to the PS?

I got a reply from OMTech, so I’m waiting to hear back. As far as the two other tests mentioned above I’m getting a slow start, but want to review the manual a little first.

OMTech’s last response, received 6:20am today:

Dear customer,

Thank you for contacting us. We will look into your question and contact our supplier for the best possible answer. We will get back to you once we get a reply.
Thanks for your understanding.

Best Regards

We made some tests and it resulted that the power supply is receiving the signal well from the controller but the power supply is not emitting it well. If for example we did two tests of 10% power & 80% power , the power supply received different signals but when sending the signal to the laser tube it sends the same power of 19ma

Wow, I’m surprise that the power supply would work ok in Fill mode, but give full power in Line.

Did you do the in-line test with an amp meter on the red high voltage wire?

Did you try scanning at 2% power if yes what was the result?

Yes, 2% and even 0.01%. The result was 19-20mA draw and burn through 1/8" plywood.

You’re right, that smells funny. How do you (they) know the controller is sending the right signal?

If it works for one and not the other, that is not logical. If it stuck full on maybe, but this is not the behavior I’d expect either.

Carmel, did they have you do voltage tests or something that the controller was sending out to the PS? If so, I’d like to try those tests tomorrow. If yes, can you please share how those are done? Did you hear from the vendor if they are sending you a power supply?

I ended up not doing anything laser related today, other than watching a few related youtube videos, and other house work. I’ll work on lasers tomorrow and try to see what I can see related to the max power burn and Laser 2 port usage.

Great idea, never looked to see if you could use Laser 2 part of the controller. I’ll have to look at mine and see if the connectors look interchangeable. If it did work as laser 2, it would identify it as the controller. If there was no change, I don’t know if it would help much.

But anything extra we know is good.

There’s 2 water protection inputs on the controller, one for each laser (1 & 2)
If you enable laser #2 for testing and enable water protect for it then you’ll need to put a jumper wire on the controller to make it think that water flow is good.