Preview window is invisible

preview window is invisible on my computer, it simply does not appear anything, but with alt+tab i can see the window is in fact oppened

Has this ever worked before?

If you select the window in the alt-tab screen does it appear?

If you close the Steam client, do you get different behavior?

Try resetting window layout with Window->Reset to default layout and see if that changes anything.

-Yes
-No
-No
-and also no.

if i reinstall i loose the license key?

Reinstalling should have no change in this (or other) unwanted behaviors you’re seeing.

Please reset the window layout using the instructions above:

nop, same problem.

Before this happened, where you running 2 monitors and now only one?

What has changed since the last time this worked?

Try holding shift while starting LightBurn. Does that change the behavior?

with one monitor or 2, it behaves the same.

Thought I would try. Mine did that a day or so ago. Had to reset to display 1 only.

i dont remember exactly, i’ve used a few months ago and then the preview does not work now, restarted the computer without my external monitor and still not working. i’ll try deactivate the discrete graphics card for the LB

still, same problem.

The image is somewhat unclear. A blank preview window is expected behavior with “Cut Selected Graphics” Enabled in the Laser window and nothing ‘Selected’ in the work area.

2024-02-12 129313 forum preview window

You can either turn off the Cut Selected Graphics switch in the Laser Window or select some graphics in the work area to send to the engraver.

A clear capture of the Laser window may help if this isn’t the case.

From what I can tell, OP is not reporting an empty Preview. He’s saying the Preview window itself is not focused and visible. It’s likely rendering somewhere else. What’s odd is that for me the Preview window doesn’t show as its own window that I can switch to. It’s coupled to the main LightBurn window as far as task switching goes.

exactly, i still didnt figure it out, you guys use in what OS? i’m using windows 11 latest update

Just curious. When you invoke the Alt-Tab sequence and you see that it’s showing like in your first attachment, can you land on it by cycling the sequence (border should turn blue) and let off the keyboard? This will bring the window into “focus”.

If so and it’s still not showing on your desktop, use the arrow keys on the keyboard to move it around to see if it will reappear.

Not an uncommon problem when using extended monitor setup when/where the end user has an open window outside of the current desktop and reverts to another state.

I use on W11 without issue.

You indicated earlier that you tried holding shift while starting LightBurn had no effect. Is this right? That should basically be a full reset of LightBurn windows so find that really surprising.

Yes, please try this and let us know the results.

I note you are running a very old version. We have fixed, added and changed many things since the 09.07 version release (September 6, 2019) and highly recommend updating.

i’ve tried opening lightburn while pressing shift and the problem persisted, but i didnt knew 09.07 was old… i’ll look for an update when i’m back home and send a feedback

Yes, the current public release as of 2024-02-14T08:00:00Z is version 1.5.01 - released February 7, 2024. You can check for updates from within LightBurn under the ‘Help’→’Check for Updates’ or download directly from here:

guys, i think i breaked my lightburn, take a look
image
and was there for a few minutes.

if i do a fresh install i’ll lose the license?