Print and Cut Bug?


Can’t seem to make Print and Cut work for me consistently. I’m making some cardboard boxes. Started at But parts of the box are too large. Have cut in half and attempting to use Print and Cut. In past it has worked fine for me and was even able to make work for the piece that has holes in it.

No problem cutting the first half and making reference marks. For the second half. Select the top most reference point and Set First Target Position. Then move laser to bottom reference point and Set Second Target Position. Then select the half I want to cut. Return to Laser Tools and select Align Output to Targets. Press Start and laser goes to home position and does nothing.

Have tried turning off the laser (xtool D1) and closing Lightburn. Neither seem to make an improvement.

Is there a bug in the 1.2.04 version? Like I said haven’t previously had an issue making the Print and Cut work for me.

I am having a few issues as well with features after this new update. I haven’t used the Print and Cut feature since the update, but I’m having issues with my absolute coordinates not being consistent. I use absolute coords for everything and know the ins and outs of using that option. It just doesn’t work properly any more.

Not sure this is any help for you.

In discussion with Lightburn and further research with this issue…

The KEY to making this work is to break the project up into a bunch of individual files. i.e. If the project calls for three print & cut operations then need to have three files. Each containing only the portion needing to be cut.

Would think they could all be in one file and each piece processed (cut) individually but won’t work that way. The following YouTube video does a good job showing the process. It isn’t mentioned (at least I didn’t hear it) that the project must be cut up into individual files.

I followed a video tutorial done by lightburn where they do the 3 foot mermaid. i’ll follow this to the letter and made sure my laser was calibrated and running perfectly. I had rehomed and done test cuts and could reproduce the results every time.

I created my main image and saved that as full image.

I then created a new file and I only had the left side of the image available and deleted everything else. This was saved as page one. I then went through the process for page 2.

The first part of the project burned beautifully and cut as it should have. The registration marks were burned in first thing. I opened the print and cut wizard selected the first point, and using absolute coordinates. use the arrow keys from the move tab to line up directly on the crosshairs.

I then clicked it to select the first point. I then asked it to jog to the second point after selecting it.

i’ve been went through the process of lining up the laser with the crosshairs on the second point. Once this was completed I selected to use scaling. I checked the preview and the tilt and everything on it looked good. I then ran the job and it was shifted at least 3 mm up. This makes no sense as I had it lined up perfectly with the crosshairs

Is there a reason why you used scaling? Given this was all from the same design I assume you could have done this without scaling. Or rather, it would have been better to not use scaling as that could add yet another error factor.

How far apart are your registration marks? Ideally these are as far apart as possible to reduce the impact of any alignment error.

What laser were you using for this burn? If using the xTool, are you using the red light for alignment?

I was using the xTool D1 10W

in the video tutorial that’s how he does it, that is why I use the scaling option. And no I don’t use the red cross hairs those suck and have to be calibrated. I use the laser pointer only for framing. I did my calibration March the same way they did in the video with the mermaid. I went to the top of the box are used to cut the image with cut shapes. I put a registration mark there and then brought it down slightly. I did that at the top & the bottom, Giving it at least a 12 inch spread I would say

Scaling would only be used if the material to be cut was not based on the original LightBurn design scale. Imagine if you were cutting out a photograph on 4x6 photo paper but the design you were working with in LightBurn was either much smaller or bigger than the physical dimensions on paper. You would use scaling to scale to the dimensions of the material.

Since you started and ended with the LightBurn design you would not need to use the scaling mechanism.

That’s a wide enough spread where I wouldn’t expect a 3 mm discrepancy.

Can you confirm you were working in Absolute Coords in both halves of the burn?

I reported this to Lightburn and response was that no problem had been reported. I’m still of opinion that something is still off. Had used the Print and Cut previous to recent version of Lightburn and seemed to work just fine for me. Recently I was cutting some cardboard for a special box and had need of the Print and Cut option. Needed to cut top, bottom and side pieces with Print and Cut. Made 6 separate files, having split all the pieces in two. Top cut no problem. Bottom was off by about 5-6mm. Sides were fine. Double checked the halves of the bottom piece and all lined up fine in Lightburn. Tried a second cut and came out fine. Each time I lined up the blue dot precisely with my reference marks (can’t be more than .5mm off center if that much). Selected the “no scaling” option. The side pieces I cut had only 100 mm (4 in) between reference marks and they came out fine first cut. Again believe something not right with Lightburn but falls on deaf ears. I too am using a xTool D1 10w. Could be an issue with xTool but this has been the only issue I’ve had with burns not working as expected. Good luck.

For me Absolute Coords is automatically selected once I indicate first Target position. Don’t know if that is a setting I have selected in the set-up.

For what version did you report an issue? I believe I’ve tested this on 1.2.04 when I last saw someone bring this up but can test again.

It’s possible there’s an issue that’s being triggered by a particular design or possibly not seen in all device types.

These issues are often reported by xTool users but I think for the issues I’ve seen they’ve typically been due to unfamiliarity with the tool or something to do with the red pointing laser and overcome once those hurdles are cleared.

Can you provide two parts of the design that you’re having an issue with and I can test to see if I can reproduce the issue?

Also, is this a sporadic issue or repeatable?

Okay cool. I couldn’t recall if LightBurn enforced that and have a vague memory that it was once a source of trouble… but could be a false memory.

Hi, I’m using the 1.2.04 version.
Sweetie Pie Box (Top 1).lbrn2 (26.1 KB)
Sweetie Pie Box (Top 2).lbrn2 (19.5 KB)
Here are the files I used and had an issue with.
Seems to be sporadic. I’m not using Print and Cut that often. But as mentioned had three separate operations to complete. First and third operations went as should but 2nd operation had to be performed twice. Don’t know what could have changed for that one and not the others. All were performed one after the other.
Have been meticulous in making sure blue dot is lined up a close as possible. Ensured that reference marks in Lightburn were not moved. Since previous project that required Print and Cut also had issues. Made sure I was precise in every step of the way with this one. Still had an issue.

I should add that when the second cut was made the bottom line was only off by a fraction but the top line was off by the 5-6mm.
For these cuts I set up a work space on a large worktable. I made runners to the left and right of the honeycomb that were screwed to the worktable top. In turn the cardboard piece to be cut was attached to the runners with screws. Was not possible for the cardboard piece to be bumped or moved. xTool was also securely attached to worktable to ensure it didn’t move or could be bumped.
If it helps any here are two more files I used that did NOT have an issue.
Sweetie Pie Box (Sides 1).lbrn2 (38.5 KB)
Sweetie Pie Box (Sides 2).lbrn2 (41.5 KB)
Thanks for looking into.

I’m curious. Whenever I’ve tested I’ve only done 2 cuts back to back… never a third. I wonder if there’s something going on in the transition to the 3rd cut…

This is odd. And were these done with non-scale? If so, not sure what to make of that. If these were done with the scale feature that could make sense.

I’ll try to take a closer look at the files tomorrow.

Okay. Couldn’t resist.

Some notes:

  1. The file setups looked fine for both sets. One oddity is that your registration marks are internal to the design. I would generally prefer to have them outside the design so as to not leave a mark but shouldn’t affect functionality.
  2. I ran the print & cut and the results came out fine and as expected. In fact, I ran it twice because I prematurely lifted the material from the bed not realizing it hadn’t cut all the way through. So I ran print & cut to recut the first half. I turned the material roughly 30 degrees for the second cut just for good measure.
  3. Note that I did scale down both designs by 80% to fit the material. That should not make a difference although it’s a variable to note.
  4. This is not exactly apples-to-apples because I’m running a beta 1.3.0 version but I haven’t heard of any print & cut changes to this version.
  5. I don’t have an xTool laser. This was run on a Ruida controller so would be a variable. However, I don’t think the fundamentals of print & cut diverge until the final moments before the code is generated for each device type. I’ve done print & cut on grbl controllers in exactly the same way.

Really not sure what more I can add. Could be an xTool issue. Just know that the few times I used the option prior to this release they all worked okay. Isn’t something I use often. When I do, will attempt to try to note every step of the way and make sure no deviations occur. Thanks for looking into.

You’re saying that you’ve used print & cut without issue in previous releases?

Does the problem set of files fail every time for you in the current version? If it’s repeatable then it can be solved or at least root caused isolated so that the devs can fix the issue.

I was under the impression that failures were sporadic.

I only work an absolute coordinates

no like I stated in my post I used paste and cut before and had no issues with it. I followed the tutorial online that light burn put out with the mermaid wall art.

I had only used it a couple of times but it worked for me and I was able to recover fail jobs using the feature. After this last update I have been unable to get the feature to work in six attempts. Whereas previously, as long as you were lined up with your registration marks You would get a successful burn or cut.

You’re saying you have an issue 100% of the time now?

If so, can you provide the following:

  1. Screenshot of Device Settings
  2. Full screenshot of LightBurn with one of the designs loaded
  3. Sample .lbrn files where you are actually experiencing this issue

Is there an email address for me to send the file to? It’s a custom file that I made for somebody I’m not posting it publicly