Print not maintaining square?

I tried printing some text and noticed shape didn’t look right. I tried to print a 20mm square and the first 2 sides are good then when it started the last 2 they are no where near correct. I’m running a generic rig with a NEJE 7.5W optical laser. Any ideas what I should look at?

Looks like a couple of loose screws between the motors and the laser head, probably in the belt drive pulleys. The frame may also be sloppy-loose.

Go through all the mechanical adjustments and tuning described over there:

That’s for Sculpfun lasers, but all the common tabletop diode lasers have roughly the same mechanics and pretty much the same adjustment problems, so you’ll be able to apply what you read to what you have.

Will go thru all that when i get home after this rain stops. I’m on a motorcycle so 30min in the rain is no fun… lol. I just discovered the error late last night so haven’t dug in deeply yet.

all the hardware is secure, adjusted the belts and still getting the big shift in the Y and a little in the X axis. Feeling the movement while engraving the cube I find that there is a noticeable lag in the left Y axis stepper on the return trip. Could this be a failing driver chip or do I need to bring up the driver voltage for the Y? If so, what is a good voltage to set the driver at? Static I am at .830 on the X and .860 on the Y, but the Y is shared between the left and right steppers. Y goes to .862 when in motion.

That can well be the mechanical backlash you seek. :grin:

Now that I can see the mechanics, that’s a pretty machine. However, backlash is lurking in every joint, particularly from the rollers up through the gantry.

Quick test: put a visible laser dot on a sheet of paper, then touch the head with your finger down near the bottom. How much force can you apply without moving the dot? Repeat for X, Y, and diagonally.

Quick answer: not much force at all. That’s what you’re up against.

Which suggests whatever power supply you have isn’t producing enough current. Those reference voltages are derived directly from the supply, so any droop there indicates the power supply voltage is also drooping.

Fix that before proceeding.

If the Y axis motors are in series, then the typical 12 V supply is inadequate.

If they’re in parallel, then the Y axis driver must supply twice the current of the X axis driver, up to whatever the maximum current that little board can regulate without forced-air cooling.

A 24 volt supply about as much as the driver boards can handle and will dramatically improve the driver performance.

The supply should have a current rating maybe twice the sum of the peak current setting for three drivers. If they’re at 1.5 A each, then you want close to a 10 A supply = 2 × 3 × 1.5. Yes, you can get away with less, but the typical cheap supply brick needs more headroom than anybody expects.

Then proceed with motion tuning!

actually on the Y the driver Vref goes from .860 to .862 when in motion. I’m using a 12V supply. I’ll look again tonight to see if both motors are moving at the same time or if there is slack in the left belt, but I believe there isn’t any slop in the belt, it just feels like it takes a second for the left stepper to start moving after the right starts. The last time I had adjusted Vref on any of my 3D printers I believe they were closer to 1.2V vs this board at .860. Just wondering if the lower V would cause the lag by right stepper using what it needs to get moving then the left one starts. Just a thought. I played with the belt tension last night to decrease the resistance in the system because they were pretty taught.

Issue resolved, found that the left Stepper had a bad connection so the lag was actually caused by the right stepper pulling the left along for the ride. If anything I now know all my connections and hardware are fully seated and secure. Thanks for the help.

Happens to all of us every now and again: welcome!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.