Problem with Waiting for connection

I got a two trees TTS 10 pro, it was working fine with the program but since a couple of day is giving an issue about waiting for connection, tried everything i can or could find , like review the correct port update driver ETC, but nothing, , i have uninstalled and install the Lightburn and nothing, tried with the laserGRBL and looks to have the same problem about about be working with a project or something like that, any advice or suggestion for this matter?

image

Do this, close lightburn

Right click your windows start menu > Device manager
Expand ports

Unplug laser
Take screenshot

Plug laser
Take screenshot

POst both please

3 Likes

with the laser unplug (looks that does not shows de port options)

laser plugged

Interesting
Notice when you was trying to connect to lightburn you had COM4 selected
Now your machine is COM5

wonder what might have changed
Can you retry lightburn connection but select com5 on your dropdown menu?

1 Like

What change is that i tried another USB port on my laptop, looks that when i change the usb port change the number after COM, I already tried with al the 3 USB port that my laptop has ,each one provide a number COM4, COM5 and COM 6. and light burn will just show the COM that is connected

what you get in console?
And that behaviour is quite abnormal, a device is given the serial port number and should keep it regardless of which port is connected

2 Likes

note: I just change the languages, for better understanding from Spanish to English

Something definitely wonky with your serial

I would suggest connecting machine → right click in device manager → Uninstall and remove drivers

then unplug and plug again.
SEe what com port it finds

and try to connect to that one in lightburn

1 Like

In Edit > Device Settings, try toggling off ‘Enable DTR signal’.

1 Like

I just did and show me the one com4, i also add the laser manually in LB, and looks that now is working properly I did a couple of try, going to keep doing it, because before it used to work for a couple of minute and then the issue come back., but now looks and feel really different to those time, as I already disconnect the laser, turn off and also change the port and not problem at all

but i really appreciate your help now i have more knowledge about how to troubleshooting the laser and LB.

I going to keep dis topic opened for a couples of day, just to keep doing test and confirm if was the final resolution for future users, one more time Thank you a million times

1 Like

The problem, happened again, and try this and it works immediately. Thank you very much as well.

gonna keep doing test to confirm

Is the laser the only thing plugged into a USB connection on your PC?

This has always happened to me. I just keep unplugging and plugging the laser back into the USB port, after a few times it connects.

It always connects on COM5. Laser is the only USB device and I’m running windows 11.

A post was split to a new topic: Comgrow Z1 no longer connects