Problem with z crashing - Gweike cloud

Is this some setting that makes this happen? Every time i finish a cut it will defocus and crash into the material and goes back to home position. See video.

Well it looks like the homing position for your lens (Z axis) is set below the height of the material. How are you setting the focal height?

A big part of the problem is that Z is usually a setting for moving a bed up and down, not a lens up and down, so everything is inverted, however Ruida won’t allow negative settings for Z. The issues with focus on GWeike Cloud are on the Development teams radar but haven’t yet been implemented in LightBurn.

As mentioned I’d like to know what settings if any you’ve adjusted and how you’ve been setting your focal height?

In this case I’m cutting 8mm HDF and i use the formula 17-material thickness = 9. So in the layer settings i set the Z offset to -9. It all seems to work for all layers until the job is done, then it does this.

Actually if i have multiple layers with different Z offset it will crash inbetween every layer.

And also, the machine homes itself each time so it will be in top position at zero Z.

Which way does the Z value increase, up or down?

:smile_cat:

If i do -5 z offset the laser head will go down. After the job it will go up home to zero point.

I would suggest focusing it using the Move Z function and not mathematics within the software for now.

Yeah, i probably need to do that. Just sucks when i have engraving and cutting stuff in different heights on the same job.

Wondering about getting a 4060 100w ruida china laser and be done with this. At least i can customize it as needed.

I stumbled upon exactly the same problem on my Gweikecloud RF and thought I was the only one. Hopefully the dev team at Lightburn and/or Gweikecloud will come with a solution soon, because manual focussing every print just sucks, especially with multiple processes.

https://forum.lightburnsoftware.com/t/autofocus-crashing-laserhead-into-workpiece

1 Like

Same issue here