Problems with artwork in illustrator not coming out to size on laser

Hello Everyone,
I have a question about lightburn. I setup my files in Illustrator for my cnc sain smart 3018 pro and the measurmen’ts, dont come out the same on laser as artfile. I tried exporting in svg and dxf and still the same thing. Everything works great except for the size coming out to scale as art file. Tried changing settings in Illustrator to inchs and controller to inchs and vice a versa. About to witts end with trying to solve this. Can anyone help me with this? Don’t know if its the settings in controller or what? Really excited to get ready to make some cool stuff just need it to come out to size. My controller board in a replacement boad which is a camtool 3.3 from sain smart, newest board they came out with. Will post pics later but at work right now. Another thing the artwork sizes match in lightburn software just burns like 2 1/2" smaller for some reason. Any help will be appreciated. Love the software and figured out most of the speeds and power settings.

Kendall Hammann

Most likely your machine isn’t calibrated correctly.

In the console, try this:
G0 X0 Y0 (press enter)
Mark the point where the laser head is.

Then type:
G0 X100 Y0 (press enter)
Mark the new point.

If they aren’t 100mm apart, your controller doesn’t know how big a mm is and needs to be calibrated in the firmware. These are the $100 and $101 settings in GRBL.

This post walks you through figuring out the proper values:

Ok, thanks for the response will try later after work. Also thanks for the fast response. I figured it had something to do with the calibration of board, was just frustrated and lost. This stuff is all new to me but glad I decided to try to conquer new things. Might have more questions later.

Kendall Hammann

Hello, and thank you for your help. That worked now on to creating new and better things. So excited. Thanks Again.

Kendall Hammann

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.