Problems with Gcode

My Gcode is not the same as my DXF file or PDF files
In the image with colors the is my dxf file and the black and white pic is the Gcode.
Thay are not the same what is going on?

Do you possibly have tabs/spaces enabled on the layers? If so, disable and retest.

If that’s not the issue, can you upload the .lbrn file for review?

Hi I have attached the 2 files as the tabs are not the problem.
TEST FILE.gc (1.4 MB)
TEST FILE.lbrn2 (286.9 KB)

Disable the “Add Lead-in” under Advanced tab in Cut settings.

Thank you for your help.
Now my small problem is how to get Start pause time to work. I have tried to get this working? Your help with this would be appreciated.

What are you doing, what are you expecting to happen, and what’s happening instead?

1 Like

Nothing different is happening.
I want to add a delay in the start of the burn.
We have a big laser at work and there you can set a delay time when cutting steel to cut though before the machine starts moving?

When you say delay, do you mean after the laser starts burning? Or do you mean you just want a general pause before any laser activity?

It sounds like the former.

If so, it looked like you were already configured for this. The Cut Through setting in Advanced tab of Cut setting allows this to work.

Is there something that isn’t working as you’d like?

Yes I configured the setting in advanced but its not working or there is no delay happening at the start of the burn this is my problem. Can I try something different

I can see that there is in fact a cut-through dwell in the g-code:

G1 F100 S10000
G4 P9

The G4 P9 essentially should be dwelling on the initial cut start for 9 seconds. Are you not seeing this?

Unless it’s a mutant G-Code variant using milliseconds, in which case the delay is gone before you’d notice … :person_shrugging:

If that’s the case, try delaying for 9000.

Marlin uses P for milliseconds and S for seconds, but I have no idea who else got on board that train.

Indeed. I’m going by the basis that this is a GRBL machine. GRBL follows LinuxCNC convention on this which should be in seconds.

Note that in the Cut settings that this was indeed represented as 9000 ms.

Entered in milliseconds, converted to seconds, then sent to a controller expecting milliseconds! :grin:

Been there, done like that:

You realize you’re steadily becoming the xkcd of the lasering world… always seem to have an appropriate post.

1 Like

Eventually becoming Peanuts: fossilized. :grin:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.