Public Beta Release - LightBurn v1.6.00

We have released the first beta release for LightBurn v1.6 which is available to download in the public beta folder.

This is intentionally a small release, mainly focused on the “bundle” import/export feature. This is available under File > Preferences and will allow you to export and import not only preferences but everything else as well: hotkeys, devices, art libraries, material libraries, and image presets. All to a single portable file.

In total this release includes the following

  • Added User and Vendor Bundles, Export and Import

  • Pressing Ctrl enables the drag-dots for corner radius and polyon sides

  • Added ability to rotate workspace for GCode machines (portrait → landscape)

  • Added support for negative workspace for GCode machines

  • Allow ‘Mirror across line’ if the line is a bezier, but straight

  • Shift+Click on ‘Reset to defaults’ in Optimization Settings resets to LightBurn standard defaults

  • External start trigger for galvos will show a status warning if nothing selected or enabled for output

  • Added option to clean whole image or just recent passes with 3DSlice on galvos

  • Added ‘randomize orientation’ flag to grid array

  • Added ability to nudge rotation during galvo framing

  • Added option to set custom device icons

  • Bugfix: Handle different image paddings in PDF files

  • Bugfix: Remember last extension used when saving device specific files (gc, gcode, txt, etc…)

  • Bugfix: Setting a kerf offset on a sub-layer that wasn’t the last sub would not apply the kerf properly

  • Bugfix: Extremely large decompressed streams (>2Gb) would cause Illustrator files to fail to load

  • Bugfix: Corner Rounding tool crashed or didn’t work on a few specific cases

  • Bugfix: pressing ‘Frame’ on rotary screen for galvos could freeze, or frame incorrectly

  • Bugfix: Galvo lens correction wizard would fail bounds check with lens size smaller than 100mm

  • Bugfix: If using ‘Order by Priority’ or ‘Order by Group’ with ‘Angle per Pass’, partitions after the first would get an incorrect number of passes

  • Bugfix: Stroke in exported SVGs wasn’t properly scaled by shape scale

  • Bugfix: Fixed Global Passes not applying Cylinder Projection

  • Bugfix: Don’t show missing material libraries in list


thank you ! wait so long for this feature


Enabling “CNC Machine” in Edit->Device Settings does not seem to change g-code in any way as compared to not having that enabled.

I’m using Absolute Coords with a GRBL device. I would have expected the workspace grid markers to be shown in negative and g-code to also have negative coordinates.

Am I thinking of this incorrectly?

Also, what does “Overwrite files on device by default” do?

Can we get the same behavior for Cut/Layer settings?

@LightBurn can you comment? I’m not 100% sure of the details of that change.

You can now tell it to always overwrite files of the same name on the controller instead of having to confirm every time… this is mainly for Ruida.

If I’m understanding what you want correct, that has been available for almost 4 years… If you hold shift while clicking on “Reset to Default” at the lower left corner of the cut setting/layer dialog in LB it will be reset to the factory standard LB setting.

1 Like

any chance a little explanation on this feature could be made?

This was showing for me on GRBL. Does that mean GRBL devices will allow some sort file transfer now?

That’s indeed what I was referring to. I even tested this before asking the question but apparently was already on factory settings so didn’t see a change. It’s something I thought would be useful so nice to have.

By the way, may have found a bug there:

  1. Import image. Layer setting will be set to “Image” automatically.
  2. Open that layer setting, Shift+“Reset to Default”. This will result in the layer changing to “Line” mode.

The image disappears although the outline of the image is visible as a line. Changing to another layer will bring the image back. However, going back to the original layer will revert to “Line” mode with the image again disappearing. No amount of fiddling seems to allow images on that particular layer again.

Restarting LightBurn seems to resolve the issue and allows images back onto that layer.

Can replicate this as well however my image remains.

This looks to be for the Bundle export in File->Preferences but may be wrong. If you go there, you can choose from a long list of user and device related items to export.

A few nice touches not listed in the release notes are updated device icons and protocol information showing in Devices window.

noticed this too yes, i was more interested on the “vendor” part of the inport/export :smiley:

1 Like

@berainlb You win the prize for not just finding two bugs but for one of them having been around for a long time! Not sure how old… at least a year, maybe two. That would be the reset to defaults with images.

Also, the overwrite file by default is only for Ruida - I’ve fixed it now to show up properly.

These will be fixed in the next 1.6 drop… no specific ETA on that other than likely in the next few days.

@gilaraujo So yes - we were going to be putting more info out soon about the vendor bundle thing, but I can give you the short version now:

Vendor bundles are just like regular bundles except that:

  • You cannot export prefs or hotkeys (because they are global and overwrite what you have)
  • You can include vendor information such as: Logo, device icon, vendor name, website, description, support contact email

This is all in prep for a soon to be announced program we’ll be working on with our many wonderful device manufacturers for which specific details will be announced soon. But for now know that the intent of the “vendor bundle” is that it provides manufacturers a way to bundle up everything their customers could want to get started with a new machine, all in a single file. You can either have a single bundle that covers all your devices or one for each device - up to you.

I’m sure you, @JoeSpanier, and I will be having more conversations about this shortly.

@gilaraujo if you want to try that feature note that it’s hidden for normal users. DM or email me your license key and I will provision you as a vendor in the system.


He deserves a “bug hunter of the year award” :smiley:


I will get in touch Thanks!

1 Like

I am curious… When are these upgrades / new features added to the documentation?

Hi Eric,

To avoid confusion about what features are in the current version of LightBurn, we publish documentation for new features and version-specific changes alongside the public release of a new version.

We’re currently working on some improvements to be able to make documentation for beta releases more easily accessible.



Thank you!


I have gone to my Lightburn Software and clicked on the PDF documentation link.
Where would I look to see what software version this documentation equates to?
Would this be equal to the 1.5.06 version I curently use?

Found something that I would consider a bug at least. Exists in the 1.6.00 Public Beta as well as 1.7 Private Beta. If you do a taper warp on a design, it works fine. However, if you open another file, change things in existing, whatever without completely exiting LightBurn, you are unable to do a second Taper Warp operation. Doesn’t seem to matter what I try, it will not work again until I completely exit and restart LightBurn. Doing a bunch of tapered glasses, and that certainly slows things down having to exit and restart every time.


I can reproduce on 1.6.00 Public Beta on Windows.

This doesn’t require opening existing file:

  1. Start LightBurn
  2. Run a Taper Warp; works
  3. New file
  4. Run a Taper Warp; doesn’t work

Multiple taper warps within the initial session seems to work without an issue.


EDIT: I was able to replicate
Trick was… to unselect then select shape again
Then NEW file

I have been unable to repo this on my MBP. @gilaraujo @berainlb, tried these exact steps, neither caused issue for me. I can taper a shape, repeat taper on same shape again, start a new file create shape and taper without issue. Still digging. :slight_smile:

A little more info. What I’m seeing, is that if I open a new file, or start a new file after I’ve done a taper warp, when I select the text or whatever in the new file, and start the Taper Warp wizard, that the design on my work area gets deselected, so it appears the reason I’m seeing this is that there is nothing selected for the taper warp wizard to warp. No matter what I try, I can’t keep the design selected unless I completely exit and restart LightBurn.