RA2 Pro MM per rotation inaccurate

So my rotary/chuck isn’t turning accurately. Tech specs first…current firmware version for the D1 is 003. I have laserbox 1.30 and I have lightburn 1.1.04. For my chuck I tried using 128 mm per rotation and I tried the old 360 mm per rotation. (I haven’t tested my rollers yet, only the chuck) When I run the test within the rotary page of lightburn using 128 it is accurate and goes around exactly 360 degrees. If I do 360mm it goes way to far. However, when I then try to engrave a square for testing purposes that is 3in x 3in it only rotates maybe an inch around my tumbler using 128mm as per xtools website. Even 360mm doesn’t turn accurately. I’ve remeasured the tumbler countless times and my setting of 302mm diameter is correct so I’m not sure what is going on and why there is this discrepancy. I have been able to get it to rotate accurately with a particular tumbler by changing the 128 to 407mm per rotation. Of course this will work for my current project but I want to know why 128mm per rotation is coming up short on the dimensions. What’s more is in the rotary setup page if I use 128mm per rotation and hit test it is dead on. If I use 407 mm per rotation it goes around my tumbler almost 2 times. But, when doing framing or an actual job if I use 128 the dimensions are WAY OFF. However using 407mm per rotation gives me precise carves. So why is it doing all of this and why would it work in the setup page but not an actual project? Should I roll back the firmware or software?

There has been some discussion on changes to rotary following latest firmware update.

Check out this Topic and see if the fix here works for you:

Thanks for the reply. I tried the 1450mm like the one user suggested but when I run a known sized shape and measure it the dimensions are far to big. For me my trial and error landed me on 407mm. Again, it is WAY off when you run “test” in the rotary menu because my part rotates almost 2 times but when I run an actual burn test I am getting accurate dimensions within a few thousands of an inch. I think I’m stuck with my jerry rigged solution for the time being and just having to add a few extra minutes to projects to ensure the 407mm works for all different diameters. Btw, I am updating diameter measurements in the rotary menu as well….

Not sure which post you’re referring to.

Did you set mm per rotation to 128 based on the last post? Object diameter should match the actual object.

Object diameter or roller diameter?

And what specific parameter are the 1450mm and 407mm referring to?

The post you referred me to a user farther down the page recommended using 1450 as mm per rotation for the chuck. As of now all of my issues revolve around the chuck. 1450mm is far to much on my machine at least and does not give me accurate dimensions. I use 407mm per rotation as per my first post. It’s the only setting that will give me accurate dimensions. However when I use the “test” function within the rotary setting page it rotates my piece two times rather than once. But when I actually run a burn everything is accurate. When I use 128mm per rotation my burns are far to narrow and are distorted Thus why I am using 407mm as opposed to 128mm per rotation which is what is recommended on Xtools website

I don’t see this but I did see one post that refers to 1440 mm which I assume you’re referring to.

I was more focused on the last post that echoes what you’re saying about using 128 mm per rotation:

When you set 128mm per rotation, are you also adjusting the object diameter appropriately? The fact that you’re getting a single rotation with 128mm per rotation makes me think that’s correct. Then you should only need to adjust for object diameter.

You are correct that setting 128 gives me one rotation in the rotary setup page when I input the diameter of my part and then hit test. It goes one complete rotation. The issue is that the rotary page is the only page it does one full rotation. If I exit the rotary page and attempt to run a burn it will not go all the way around…it shortens my height of my burn. So for some reason even though 128 is the correct setting within the rotary setup page it does not translate to an actual burn for some reason. That’s why I have trial an errored my way to 407. In the rotary page it goes more than one turn. But, when doing an actual burn it goes the exact distances. So to recap…128 gives me a full rotation in the rotary setup page, but when trying to get a full rotation via running a burn it goes less than half way around. When using 407 I get almost 2.5 turns in the rotary setup page, but if I try a full rotation with an actual burn it goes around exactly one time. And Yes, my diameter in the settings page is correct for any object I put in the chuck. I feel I may not be explaining this to great as I feel like I am repeating myself so maybe a video would work better….

Can you take a screenshot of your rotary setting and upload the .lbrn file that you’re trying to engrave?

There was another user having the same exact issue in a other post.

So in the settings your inputing the dimensions in metric, and your design is in inches? Maybe try converting the design into metric and see if that aleviates the discrepancy.

302mm diameter? That’s one massive tumbler.

That’s gotta be the circumference that’s only around 3.7" in diameter. I get a lot of circumferences around 280-290 for water bottles.