Rotary xTool D1

Hallo zusammen, ich habe gerade das Problem das mein Rotary in der Verbindung mit LightBuen nur bockmist baut. Erschwerend ist noch das ich blutiger Anfänger bin und mit meinem Latein am Ende bin.
Wenn ich im Setup auf Test gehe dann drehen sich die zwei walzen doch recht lange, bei einem 20mm holz und einer Schrift Größe von ca. 45mmx18mm entstehen nur komische striche und gefühlt macht der stab 20 Umdrehungen. Ich habe LightBurn jetzt schon mehrfach deinstalliert und wider installiert habe sämtlich Dateien gelöscht so das ich den D1 wider neu einrichten konnte. In der Laserbox basic funktioniert der Rotary. Vorab schon einmal ein Großes Dankeschön falls mir jemand einen Tipp hat woran das liegen kann.
Grüße Fox

Hello everyone, I have the problem that my rotary only builds bull**** in connection with LightBurn. What makes it even more difficult is that I’m a complete beginner and I’m at my wits end.
When I go to the test in the setup, the two rollers turn for quite a long time, with a 20mm wood and a font size of approx. 45mmx18mm there are only strange strokes and it feels like the rod makes 20 revolutions. I have now uninstalled and reinstalled LightBurn several times and deleted all files so that I could set up the D1 again. The rotary works in the Laserbox basic. A big thank you in advance if anyone has any advice as to what might be causing this.
Greetings Fox

It’s possible that you’re having the same issue that others are having with the latest firmware but not certain.

See these recent posts:

Hallo Berainlb fielen dank für ihre Hilfe, das habe ich auch schon vermutet bekomme nur leider das update rückgängig. Falls ich eine lösung finde gebe ich es auch gern weiter

Hello Berainlb, thanks for your help, I already suspected that, but unfortunately the update will be undone. If I find a solution, I’ll be happy to pass it on

Yes, exactly the same symptoms. And also that Laserbox works just fine but not LightBurn.

Guten Morgen zusammen, ich habe letzte Nacht mal noch mehrere ältere Versionen installiert.
Leider ohne Erfolg. Falls hilfreich hier mal der Link von LightBurn

Good morning everyone, I installed several older versions last night.
Unfortunately without success. If helpful, here is the link from LightBurn

Bin auch auf die Vorgänger von 1.1.04 da hatte es ja bis zum update geklappt jetzt aber nicht mehr.

I’m also on the predecessor of 1.1.04, it had worked until the update but not anymore.

Unfortunately, I don’t think LightBurn is the problem. The problem is in the D1 firmware and so far I have had no luck finding an older version of the firmware to revert to.

Ive been speaking to another user about the new rotery tool and we both had slightly different experiences. Im thinking it may be do to a firmware update. I will do some test tommorow but i did notice two different values for the (mm per revolution) box. It appears that the updated instructions say to input the actual mm of the device. The chuck being 128 and the rollers 32. However on the old instructions it says to input 360 for the roller. Through some trial and error i came up with 1440mm for the chuck. Im unsure if its just a coincidence that both chuck numbers are the roller multiplied by 4 or not.


1 Like

That’s awesome! I tested 32 instead of 360 for the rollers and it works! Thank you! I wonder how this affects resolution with a number this low.

1 Like

I dont think its the resolution. I am guessing they did it to better suit the ra2 pro. Prior to its release i think the 360 for the rollers was just 360 degrees and not millimeters. With the release of the ra2 pro that measurment wouldnt make sense since it would only apply to the rollers and not the chuck. So they just changed it to make it easier to switch between the two.

That makes sense. The “mm per rotation” in the LightBurn rotary setup really never made sense to me because 360 mm of travel would obviously not be a full rotation on every size cylinder. Degrees would make a lot more sense. I think LightBurn should just have it as “units” because it is up to the firmware to interpret the number in whatever way it wants to, as we’re seeing in this case. As a side note, thanks for the number for the chuck. My RA2 Pro arrives in a few days and that number will come in handy.
Anyway, I would consider this case solved. Thanks again for your help.

Hallo terrybmega :slight_smile: ich würde dies tage auch mal ausprobieren. Die zwei walzen mit je 17mm Durchmesser drehen sich ein gutes stück, müsste man echt mal rechnen bei 360 mm Wegstrecke und hoffe das es klappt… wenn es bei dir ein Zufall war ist es ein verdammt guter.

Hello terrybmega :slight_smile: I would also try these days. The two rollers, each with a diameter of 17mm, turn a good deal, you really have to do the math with a distance of 360mm and hope that it works… if it was a coincidence for you, it’s a damn good one.

Hallo Terryb, jetzt habe ich es gerade ausprobiert und es hat leider nicht funktioniert. Jetzt muss ich mal ganz dumm fragen welche werte hast du jetzt für den rollen Durchmesser gegeben?

Hi Terryb, now I just tried it and unfortunately it didn’t work. Now I have to ask you stupidly what values ​​did you give for the diameter of the roll?

Wie Justin betonte, verwenden Sie 32 statt 360 für die mm pro Umdrehung. Walzendurchmesser soll noch 17 Millimeter betragen.

As Justin pointed out, use 32 instead of 360 for the mm per revolution. Roller diameter should still be 17 millimeters.

j’ai exactement le même problème, et ce, depuis la dernière mise à jour de Lightburn, la 1.1.04.
avant cette mise à jour cela fonctionnait parfaitement, maintenant, ma gravure est multipliée par 3 dans l’axe y !

I have exactly the same problem, and this, since the last update of Lightburn, the 1.1.04.
before this update it worked perfectly, now my engraving is multiplied by 3 in the y axis!

Oui, essayez de régler mm par tour sur 32. Cela a fonctionné pour moi. Je ne l’ai pas encore testé sur un design réel mais j’ai fait un carré de 30 mm et un cercle de 30 mm de diamètre et les deux ont été gravés aux bonnes dimensions.

Yes, try setting mm per revolution to 32. It worked for me. I haven’t tested it on an actual design yet but I did a 30mm square and a 30mm diameter circle and both were etched to the correct dimensions.

#To use LightBurn to operate xTool D1 and RA2 Pro:
If you haven’t updated the firmware of xTool D1 to V003, set the parameters as shown in the following figure when using RA2.


If you have updated the firmware of xTool D1 to V003, set the parameters as shown in the following figure when using RA2.