Random lines engraving that shouldn’t

Hello Sarah,

I’m Stephane, not Stephanie ;p.

I’m not sure if we have exactly the same problem, and if it has the same origine. But yes, if I find something, I will try to share.
And I hope somebody else can help as well.

Thank you

Oh gosh sorry about that, my apologies Stephane!!

1 Like

When doing grayscale engraving, Min Power is used for the white areas, and Max Power is used for the black areas. When the laser is moving between cuts, it is simply off, so neither Min or Max power affect this.

The original poster is pretty clearly not doing a grayscale engraving.

1 Like

Yes, and neither me … I never tried greyscale engraving .

To illustrate my problem, i join a picture.
On this little wood piece, I engraved 2 separates vectors. The Goat (50x50mm) has no default, but the face (Test2, 60*80mm) has an unwanted burned line.

Have you seen this issue before? Any idea what could be causing such inconsistencies in the same file?

If you are looking to change and update this ‘Machines’ information, have a look at this section of the following post:

What firmware are you using to drive this setup?

It was entered by the person that set this account up in the first place, but fixed now so we can move on.

I ask for firmware used to drive this setup, so when you can.

Additionally, thank you for offering assistance, but you have a very different system from that of the OP, and your suggested corrective measures do not apply. We want to help you with the issues you are experiencing as well, but this has become confusing to follow.

1 Like

I didn’t changed the original firmware on my Spark xPRO V5.

Mine is 1.3a, for a XYYZ machine (Workbee). Spark does list their firmware here : https://github.com/Spark-Concepts/xPro-V5/tree/main/Firmware

They are most probably based on GRBL-ESP32 (GRBL1.1) as this device has been launched last year.

I know that my global hardware is not common. But GRBL-ESP32 is common… The xPRO V5 is a standard ESP32 controller, Spark-concept did the job to propose it in a nice and easy to wire box.

So i think that if someone here has a problem with random lines engraving that shouldn’t, his experience can be helpful for other. Maybe I’m wrong (I’m new in laser engraving).

There’s some disagreement on Facebook as to whether these are true Ruida controllers, however if you actually ask Ruida, they’re made by Ruida. :slight_smile:

If you host a lot of files on your controller, it’s worth clearing those out occasionally, as they can cause the controller to behave a bit erratically. Also, when you use the rotary, after turning on the rotary switch and leaving the rotary setup window, power cycle the controller. Failing to do that can also cause odd issues, though this doesn’t look like that would be causing it.

Are you using a Windows or Mac machine to send to the laser?

1 Like

Please go into the electronics compartments and search out the controller then take an image.

It’s really central to looking for an answer


Ok I will do that tonight

I merged your double post into this single, as it is a duplicate. Please do not double post. It makes folks supporting you work more than required to sort the same issue.

Ok, sorry about that. I wasn’t really sure which area to post in since I’m not sure if it’s a software, hardware, or some other type of problem

Same thing here svg file also. ours is coming in from Autocad. we can convert to any other file format and get rid of the random lines. Pdf, Ai, etc. but there will be a quality downgrade to the burn.

Somehow there is some type hidden geometry in the background that is being picked up in svg. I believe.

Hello Jamie.

It’s strange that your problem is just with svg. If that’s true, then you are mentioning a bug in Lightburn that generates errors in the gcode when the source of the work is SVG.

In my case, I’m sure that it’s not a problem with lightburn. I wrote a gcode myself to burn discontinued lines every 1mm, 120 times at 40% power. I uploaded the gcode in the sdcard of my ESP32 GRBL controller, and I launched the work.
I got 1 unwanted line, and it was darker than others lines. That mean that the laser received a PWM > 40%, maybe 100% ??
I launched the same job a second time, but there were absolutly no any problem (proving the random behaviour of the problem)…

To @admins (developers): In my first jobs, I had thous random unwanted lines in whites zones and in some in the overscan zone. Since I enabled G0 for the overscan zone, I never got any unwanted lines in the overscan zone.
That’s why I posted a feature suggestion to add the same option for white zones (using G0 instead of G1). What do you think about it ?

Hi Jamie,
Just out of curiosity when you got the random lines was it each time you ran your file or was it only happening sometimes with the same file?

Also, did it happen with flat work and rotary work?

WE don’t have a rotary. we are just fill engraving flat text. when the lines show up in a file there is no getting rid of them. you can resend, load from a usb stick, pray, cuss whatever. the lines will be there and you cannot get rid of them without converting to different format. you might engrave 20 different files with no problem and then out of the blue get a file with ghost lines…most of the time our lines are really low power… just barely there but it kills the part. I have not been able to generate the lines with A file that I authored yet. But we are changing the file path. Right now the letters are drawn in inventor, redrawn in autocad, redrawn in Corel draw, converted to svg from corel draw and then imported to lightburn. After nearly a month of research, today I succesfully got text from inventor to lihtburn via… drawing in inventor, saving as dwg, using autocad to convert to dxf, and importig to lightburn, but my letters are’t closed so thats another discussion.

Oh ok, that is a really good tip. That sounds like a lot of extra steps but I will try that. When it happens to me I can run the same exact file and have no issues, it’s really a crap shoot. Thank you

Hi, so I did clear my files but it didn’t help. I also tested some flat work pieces and still had the same issue of unwanted lines and even with the laser moving to a different spot in the middle of its job and then returning to what it was doing. I ran the file again and once more got unwanted lines but in differently places but the laser head wasn’t interrupted and didn’t move about in the middle of the job. Both issues keep reoccurring but are not consistent. I caught both on video but don’t know if I can post it