Random stops during jobs

Hello,

I have neje 2S max and I am using latest lightburn trial version. The problem I have is that the job randomly stops every time. I have disable the USB turn off setting in Device Manager and Power Center as well. I still have the same issue. It randomly stops at different times even if I attempt the same job again and again. Any idea why this would happen? Any help is appreciated.

Try using LaserGRBL. Does it still occur?

I haven’t used it. I can try and see if the same issue happens with that software. If it doesn’t then what do you think is the issue?

Try that first.

I don’t work for LightBurn and it could be a few things. Try that first, post results here including pics of using LightBurn and the other programs, as well as the file.

So I tried using LaserGrbl and the engraver stopped working in the middle

Check all of your cabling. Maybe there’s something hit the cable mid way through the burn. If that doesn’t work, make a direct connection if you don’t already have one.

1 Like

Mine does that if the Laptop has not detected me working on it. So I stay with it and periodically move the mouse on the screen. Just like you would to stop the screens aver from coming on.

So the thing is, i actually use a software called move mouse to do that for me and it was running during the time of the engrave job

what do you mean by direct connecton? i have a wired usb cable running between laptop and engraver. is there any other way to do it?

There is a high overhead with grbl based lasers and the massive data stream it generates can lead to USB issues.

:smiley_cat:

1 Like

@rrmanojkumar What exactly happens when the job stops? Do you get an error message? Does the laser stop firing? What happens with the fan? What do you need to do to recover from the stop after it’s occurred? As much detail as possible will help narrow down the potential issue.

Also, does this only occur with raster images or does this also occur with vector images?

Additionally here are a few suggestions:

  1. Try swapping to a different USB cable. You might be dealing with a bad or loose USB connection
  2. If you are able try connecting with a different computer to see if you get a different result. Also, please describe what kind of computer and OS you are using.
  3. The behavior you’re describing sounds a lot like the grounding issue that was common with Ortur lasers. You might be running into something similar. Make sure you have assembled everything correctly.
    ORTUR LASER MASTER 2 - Service Notice - Grounding - Hardware / Ortur Lasers - LightBurn Software Forum
1 Like

When the job stops, light burn thinks it’s still doing the job and no error message pops up in the console. The laser just keeps firing at the same rate it did during the point it stopped moving. So if the laser stopped moving when the intensity was high then the fan runs due the increase in temperature. Only way to recover is hit stop button and throw away the material as most of times it burns a hole and restart with a new one. The issue happens with every kind of image. I could try swapping the cable and see if my neje needs more grounding like the article you mentioned. I have tried with two different computers both running windows 10 and still have the same issue. Thanks for the info

This is very different than the impression I got from your original post and far more dangerous. To be clear, are you saying that the laser continues to turn on and off in sync with the job position but only that the laser head stops moving along with it? Or are you saying that the laser continues to fire if it happened to be on when the head stops moving? I’m trying to isolate if the issue is just in movement or if this is a more general failure.

Please report back after trying another cable but based on what you’re describing and the fact that you get this on both computers makes me think that you’ve got some sort of hardware issue.

Additionally, the job failing with a laser on state is worrying from a safety perspective. I suggest researching or getting in touch with the manufacturer to confirm if this is supposed to have a shutoff safety feature. While in general you should keep a close eye on running jobs in your case I suggest you not step away even for a moment.

As I mention in the previous post the data stream for grbl has codes to turn the laser off and on as well as move the parts around. If the parts are not moving and the laser is on, it more than likely it has an interrupted data stream to the laser.

It could simply be that the grbl board can’t handle massive data stream. It can only queue up a few grbl instructions in it’s command buffer. If the data to turn off the laser doesn’t make it, the laser stays on.

It would seem to add up since it does it on two different machines with images, which is what generates the large data streams along with it’s not the same place that fails.

Wish I had a magic pill, but don’t have a clue about how to fix it… it’s the processor/software (controllers) as far as I know. Don’t know that much about USB, seems to change weekly…

Good luck.

:smiley_cat:

While I see a buffer overrun as a possibility I tend not to think that’s the case here since @rrmanojkumar confirmed that this occurs also with vector images.

@rrmanojkumar If you want to test this you can reduce the baud rate of the connection in your device settings.

@rrmanojkumar Also, please confirm if you installed an interface driver or if you’re using a built-in Windows one. There might be some value in sending a screenshot of the device you have in device manager.