Raycus RFL-P30QS Power Levels not changing between layers

I think you’re doing great for someone who was handed the wrong Markcfg7 file by the vendor or manufacturer. I’ve reached out to the community here to see if anyone else has the same device and the correct file. Perhaps someone here will help out.

Did you get in touch with your vendor or manufacturer?

Pulse width info in the first post here:
https://lahobbyguy.com/bb/viewtopic.php?t=4318

Its hard to understand what he is saying, he told me to choose the right laser, omg, i’ll try one more time…

1 Like

Simple test. Engraving simple text. “test+” working like it should be, but if i engraving “test” second sublayer uses first sub power, this is nonsense… and finally tested on ezcad2, no bugs found video:
(Dropbox - 2024-02-06 21.51.09.mp4 - Simplify your life)
(Dropbox - 2024-02-06 21.51.46.mp4 - Simplify your life)

In LightBurn, please screen-shot, capture, and share your Device Settings page as I have shown above.

Then open EZCad and if the settings are available, screenshot, capture, and share those settings here as well.

So far, most of the persisting power-level behavior has been a result of unusual settings. I need to investigate and confirm this before escalating.

Is this still an ongoing issue? I believe I am experiencing the same thing. My machine will get stuck on a power setting and ignore the power for the next layer. Speed does seem to change.

When I shut everything down and bring it all back up (laser and laptop) it will change, but then get stuck again.

Need a solution please.

Raycus 30W

Thank you!

I can take a look.

There should be a file called markcfg7 on a USB drive that shipped with your device. Please make a copy of that file, change the filename to markcfg7.txt and drag and drop that copy of the file into a reply here.

In LightBurn, with your Galvo laser set up as if you were about to engrave, click File, click Export Prefs and save that file somewhere convenient. Please drag and drop that file into a reply here as well.

I’d also like to know the model number off the back of the Raycus Source. Attaching a picture of that model number is ideal, just knowing it is helpful.

Hey JohnJohn thanks. I can’t find the markcfg7 file, but I’ve put in a request to get it from the company. I’ve tried to put together everything else I could find.

Please let me know if you’d prefer working via email.

Thanks so much!!

FiberPrefs.lbprefs (34.7 KB)




1 Like

I can make out the RFL-P30QS on the back bottom corner of the device. It’s a little blurry but it’s there.

The 4-point warp tool in LightBurn is pretty handy. :slight_smile:

I see three things With yours @PBusardo

The Frequency on the attached sheet says 40-60 kHz

Your settings are 20-80kHz.

OneDrive can touch all your LightBurn files. Your lbprefs file may also have been impacted by OneDrive. Your desktop seems unaffected, so you could move your files to your desktop, moving them out of the OneDrive directory.

I see reference to what looks like a removable storage device labelled Y: It may be beneficial to copy contents from the Y Drive to a folder on the Desktop that won’t be impacted by removable storage issues. LightBurn can work with your files from the Desktop without issue. :slight_smile:

Thanks John. I’ll try moving everything local, change the frequency and give the material test another run. I’ll let you know. Sincerely appreciate the support!

I changed the frequency range and ran another material test. Unfortunately, there is no difference. This is the built in material test and the app is running locally on the laptop.

If your issue is like mine, don’t set power bellow 20%, then laser not engraving at all, no matter what power you set after that… And try to engrave only on 0 or 180 degrees… I still don’t understand why laser gets sometimes bad commands, tried on other computer, different usb wire, reinstalled drivers, nothing helps. But with some changes like mention before it is possible to work, just need to test almost everytime, if the setting are new…

Stoler - THANK YOU

Based on what you said, I setup a material test with a minimum power setting of 30% and an angle of zero. It worked!

Something is going on with Lightburn that needs to be resolved.


!

It’s absolutely possible. For the most part, I’ve seen problematic settings while troubleshooting this.

We don’t have published settings for this engraver and we can’t seem to find a copy of the markcfg7 file to confirm… yet.

If the unwanted behavior doesn’t occur in EZCad 2, please capture the settings used there (with a screen capture).

Happy to keep chasing this until we catch it.