Rdworks won't connect but LB will

I have RDC 6445S controller, but that is not an issue, because I had the same issue on my old controller.

LB connects and work fine, but I cannot upgrade the firmware through LB, so need RDWorks.

I have downloaded Rdworks from Ruida, and also Thunderlaser and neither will connect to my laser? Com port falure or Cannot read controller messages.

Connected via USB, I have changed leads, and checked the USB port (COM 7), which seems to be working fine as LB works.

Does LB interfere with RDWorks USB controller somehow…Not that I have them running at the same time!.

This seems to be a common issue, but not yet found a solution, here, on goolgle etc on a way tpo fix it.

Hopefully someone here with experience might be able to help.

Many Thanks

If lightburn isn’t executing, then it isn’t going to interfere with the machines i/o ports.

It would be a disaster to modify a ‘standard’ USB port and make it unavailable to another program. I don’t run Lightburn as an Administrator, so I know it isn’t ‘modifying’ any of my com ports.

These controllers are ‘dumb as a rock’, so if it’s anything, it’s probably the controller dealing with the com port you are using.

It’s always much better to dump the USB and connect via Ethernet if at all possible.

Good luck on the upgrade…

I’ve seen so many ‘bricked’ devices, I don’t upgrade unless there is a specifically good reason.


If I connect via Ethernet, is that just connecting an Ethernet cable between the PC and Main Board, and setting the ports?
Or does the Main board need connecting into the router where the PC would be connected?
I’ve ready about Ethernet connections but none actually tell you this.

Make sure you install the USB driver that comes with RDWorks - it’s not the same one that comes with LightBurn, so you might need it.

For Ethernet, read here:

Yeah, thanks I have read this already, but it doesn’t actually tell me how to connect it up

I did install the USB driver from Rdworks also several time now…but it has never worked. The Thunderlaser version worked on my old controller but Rdworks it’s self has never connected