Rotary axis not working properly

Hi guys, I have a thunder laser 60W 600x400 laser
RDLC v5.00.35 Rudia 644xg DSP
With a chuck based rotary unit.

All is fine with RD works
All is fine with normal cutting and especially engraving which is far better than using RDworks.
However, when I use the rotary unit to engrave a 10x10mm square comes out 10x50 rectangle
the only way to get a 10x10 engrave is to make a 10x2mm drawing.

I have tried setting the steps per rotation from 100 to 100000 and it makes no difference, in RDworks the setting was 12000 for 82mm diameter objects.

Any ideas?
I would really like to purchase a license as this software gives me far better results but unfortunately, I need the rotary more than I need normal cutting, etc.

Fingers crossed it can be sorted as I’m pulling my hair out atm.

Hi Gary,
Try drawing a line that is the length of your circumference of your part you are engraving. Make your origin at one end. Put a mark on your part and adjust the steps until you start and stop at the same spot.

It’s almost certainly because you have a Thunder Laser, which uses their own special firmware. The rotary works different with them. Can you tell me how old your machine is?

Older versions of the Thunder controller didn’t use the standard Ruida settings for rotary, and instead just scaled the Y axis output being sent to the machine. I haven’t seen enough of these systems yet to fully understand how this is done. Newer versions use the U axis to control the rotary, but are otherwise very similar in how they work to other Ruida models.

Hi, thanks for the replies.
I think it is about 5 years old.
Is there any way it can be made operational?
The output for the rotary unit was a plug inside the top of the unit basically the Y-axis plugged into it and you removed that and plugged the rotary unit into it.
could the U axis be used?

The only way to use the rotary axis on that machine with LightBurn is to scale the job in Y to make it correct. I’m going to be adding support for this to the rotary setup in LightBurn for older controllers, but it will be a bit before I can do it. The U axis cannot be used without updating the firmware in the controller itself.

I’ve just came back from doing a test of the exact solution you have just posted!

I scaled the Y-axis (divided by 5) and the test was great, I’ll do another few tests to get an exact figure to get it spot on.

The engraved image on the glass was a million times better than RDworks without having to go through Paintshop and gimp to get a decent image only for RDworks to butcher it on the glass.

So I’ll be getting a license!
Thank you for a fantastic bit of software!

I’m sorry it’s not easier yet, but I’m happy that works for you in the meantime. :slight_smile:

No problem. :+1:
I’ve been trying to find a picture of my laser on google and I can’t find a single image that matches mine!

It was given to me by a good (bloody brilliant) friend so I don’t know the manufacturer but as it came with RD works I’m guessing Thunder laser but I cannot find the model on their site.

There are a few older ones I know of, not Thunder specific, like the RDLC320A:
image

It looks a lot like the 6442, but it’s USB only, and has a monochrome text display. Is that yours?

That looks like it.
When I query the laser it comes back with ruida 644X (possibly 644xg)
On reset it shows RDLC V5.00.35

Do this for me:

  • Run LightBurn
  • Go to Help > Enable debug logging
  • Right click the 'Devices" button (with your laser powered up)
  • You should see “Found Ruida xxxxxx” or similar along the bottom of the window
  • Turn off debug logging
  • Quit the software

There’ll be a text file called LightBurnLog.txt in your documents folder. Email it to developer at LightBurnSoftware and include a link to this thread. I might not be classifying that controller properly.

Thanks I’ll do it now.

Email sent hope that is the data you need.

Oz, I have a 2-yo Thunderlaser Nova 24 with their chuck-based rotary axis. I haven’t tried to use it yet, but am willing to test it with a Lightburn version that adds direct support should you need someone for that sort of testing.

Is yours the ‘7 pin’ version that plugs into the U axis, or the older style that connects to the Y?

It’s a 5-pin connector with a separate switch to activate it. Does that info help? I haven’t tried to use it yet so don’t know how it is supposed to work but can find out. I would like to use it in future and am willing to take some time to explore it if that will help you make it usable with LB.

That sounds like the older style, but I’ll have to check with Thunder to be sure of that.

Just did some image searching for the controller and you are correct it is a Ruida RDLC320-A
I found it on Aliexpress.
Would a better controller be beneficial or will I be better off just keeping this one?

It’s a capable controller - there’s nothing wrong with it, just a little bit older and a few of the newer settings don’t work with it (rotary included). Swapping out to a 6445G would give you a shiny large LCD display and a nice keypad, but the functionality wouldn’t be affected much (aside from the rotary settings).

I’m going to be adding handling of devices that use scaling for rotary instead of the on-controller settings, so if you can wait for that, you likely won’t see much difference, aside from the above. Doing a controller swap isn’t “hard”, but it can be tedious - you have to move all the settings across, re-do the wiring, test and iterate to make sure everything is set correctly, and it’ll mean a day or two of downtime.

Thanks for the reply I’ll keep this one and use Lightburn.
I’ll just scale any rotary jobs, I only use about six glass sizes when engraving so once they are calculated all will be well.
Just going through the tutorial videos and I’m very impressed so far.

Hopefully, I’ll have the funds for the licence soon, I have 25 days to go so I’ll make it no problem.
Keep up the great work with this software.

Gary