Rotary device setup

HI there again. I have a new problem now. I tried using the Rotary device with lightburn and my design came out very stretched out. I have a chuck rotary device. I the circumfrence of 240mm, diameter was calculated by the software to be approx 76mm. The design was supposed to be 2.7 h x 3.5 W. When I engraved it, the width was really strtched out, but the height seems to be fine. Any clues/suggestions?
TIA
Deborah

If you haven’t set up the “steps per rotation” value yet nothing will come out correctly. You have to get that value correct for your machine, motor controller, etc, and then the others will work as expected.

If the item came out stretched, it sounds like you need to reduce the steps per rotation value. Measure how large the design came out to, then divide that by how big it was supposed to be, and use that number to divide the steps per rotation value by.

For example, if your design came out to 5 inches high, but was supposed to be 2.7, you’d use:

5 / 2.7 = 1.85185

Then, if your current steps per rotation value is 10000, you’d use:

10000 / 1.85185 = 5400

So 5400 would be the new step count to try. Do a few simple tests that are easy to measure, like a rectangle of a known height, and work from there.

I have a 5070 100W Red/Black that Im trying to set up a rotary device on.
I have successfully set up the rotary in the LB setup.
I have read the set up procedures and some other posts in regards to this but no where do I see anything about axis homing. Reason I say this is because when I plug my device in and power the machine on the X will home but the Y will (now Rotary) will spin and spin until I hit ESC.

Ive attempted to run a test and the machine will do nothing when I hit start. In addition I’ll move the X over and then when I attempt to run a test the X axis will home and the Y just spins. Then when I try to use frame the X slams home and jams Y is spinning. Have to hit reset.

What am I missing?
Probably something easy

Thank you! I was wondering about the steps per rotation. In RD works I didnt have to do that. So is there some documentation of these steps that I can refer to? or is it performing tests for everytime I set things up?

thanks again!
deborah

You only need to set this once. It’s a setting stored in the controller itself. I should ask - do you know which model of controller you have? There are older RDC320 models that don’t work this way and I don’t properly support them yet.

Run rotary work in “Current position” mode to avoid this. The machine is still trying to Home your Y axis like normal. You can disable the Y homing when you enable rotary mode, but it’s easier just to quickly hit ESC when you power the machine and then use Current Position mode to run the jobs.

Also, if your question is reasonably different than the original, it’s better to create a new topic so the conversations don’t get jumbled up. I’ll see if I can move this.

Thank you Oz much appreciated

Hey OZ im not having ANY luck here with this rotary…

The X still homes and when I attempt to run a test I get “Y slop over”
Also the stepper motor is extremely hot… So i have something wrong here

If the stepper is running less than about 90c it’s probably ok. 50c is borderline uncomfortable to touch - they often run hot.

For the slop message, how big is your workspace? After you hit ESC on startup, running with the Start From setting in “Current Position” mode generally works.

I didnt get to try that last night, I’ll try tonight. The work space is 700x500

One issue I’m having is that when I run from current position- the rotary jumps over to the beginning of the design when I hit start. Going from still to jump over to the beginning seems to cause a lurch and the begginning of the project is distorted. After the initial jump it settles in and does pretty well.

If it’s an engraving job, setting the job origin to the bottom instead of the top would make it start scanning from where the laser is, or you could change the scan angle to 180 to have it engrave top to bottom. Either should help. You could also lower the rapid speed setting in the machine parameters so it doesn’t move as fast between cuts.

Thanks Oz , it seems to do a pretty good job when it scans in a design, when it comes time to cut (of scan/cut) - it misses badly.

Oh well, worse ways to spend a Saturday!

Which setting controls the “in between” movement?

It’s called “Idle Speed” - the first item in the machine settings, though this is assuming you have a Ruida controller, which you haven’t stated anywhere.

Yes I do, thank you!

If you fill in the “Machines” box in your profile it makes it easier when you post support questions. If you forget, anyone trying to help can just click your name to see what you have.

1 Like

Got it, and that worked perfectly!

But now I removed the rotary, set everything back and my settings are screwed. When homing, it grinds toward too right corner. If i place the nozzle in the middle of my work area and select a design to move to laser position- the design moves way far off the work area down and to the left on the screen.

I’m sure its some setting but I can’t get it figured. Help please.

Did you turn off the rotary enable switch?

Yeah. It was odd. I set the head where the limit switches came on for the X and Y. I then hit reset on machine and things seem to have come back.

Last thing, Oz . I am having to reverse the image for it to burn correctly on rotary. Is that normal?