Rotary first time


(Chuck Delchamps) #1

Is there a setting in Lightburn to input the diameter of an object in the rotary? My first effort came out quite stretched. Nova24 60 W ruida controller.


Rotary step count doesn't change anything
(Rick James) #2

Have you looked at ‘Tools’->‘Rotary Setup’? :slight_smile:

image


(Chuck Delchamps) #3

Thank you. No, I hadn’t found that yet. Since I’ve looked at it now, are the circumference and diameter settings always locked together? What do I do with the steps setting ? “Enable rotary “ seems obvious. Turn it off after the job I’m guessing?
I really do appreciate the help here. Thank you!


(Rick James) #4

If you have set up a rotary on this laser system previously, you can select the ‘Read Settings’ button to pull these settings from your controller into LightBurn. Otherwise, you will need to provide the Rotary type, the ‘steps per rotation’ and if a roller style, the ‘Roller Diameter’ for your specific rotary device. As for the ‘Enable Rotary’, once you have your rotary configured, you can also turn the rotary ON or OFF (‘Enable Rotary’) from the ‘Laser’ window as shown below.

image


(Chuck Delchamps) #5

Is there a tutorial/ video for calculating “steps per rotation “ ?


(Rick James) #6

To save retyping, here are several posts you might benefit from reviewing:

https://forum.lightburnsoftware.com/search?q=steps%20per%20rotation

There is a search tool (image) on the upper right of every page in our forum to help you find topics and posts of interest to you.


(Chuck Delchamps) #7

I’ve read the above topics and I think I’ve followed the instructions but I’m still lost.
I drew a 1" square in LB, entered the diameter,turned on “enable rotary”, clicked “ok”.
My machine burned a 1"x 2.75" rectangle. So, 2.75/1= 2.75. The steps were at 10,000 which I assume is a default, so 10,000/ 2.75= 3636.36 so I re-set the steps to that. No change. then I re-set to 1500…no change.
I have a brand new Thunderlaser Nova 24 60W with Ruida controller. It has servo motors, not steppers, is that a problem? Also, my machine had been demoed at a trade show so it’s possible someone had a rotary on it before.

I sure hope that you can help me.

Thank you.


(Oz) #8

Make sure that the steps setting is sticking - when you go back into the rotary setup, is the value still there?

Do you have a roller rotary, or a chuck?


(Chuck Delchamps) #9

Yes, the value is sticking. I have a chuck rotary.


(Oz) #10

If you have RDWorks, try it there and see if the behavior is the same. It’s possible that the firmware version on your machine stores the values differently, or perhaps that it’s an older controller that doesn’t use the rotary setting at all. Trying it in RD would give another point of reference. In that software, it’s under the user tab, called “Circle Pulse”.


(Chuck Delchamps) #11

Thunder laser is telling me the steps value should be 16000 so I’ll try that when I get home today


(Chuck Delchamps) #12

I’ve installed RDWORKS that came with the machine but I can’t get past “communication error “ when I try to send a file so I haven’t been able to try the rotary with RDWORKS.
I’ve tried LB again. Carefully checked settings in tools-rotary. Steps at 16000 per Thunderlaser tech support , diameter at 73mm for the test piece. Drew 25mmx25mm square in LB. result is a 25mmx60mm rectangle. Double checked settings and they are good. Sure wish I could fix this.


(Anthony Bolgar) #13

Using a ratio, of expected to actual output, I would suggest trying 6,666 as the steps, not the 16,000 Thunderlaser told you. See if that is a more accurate setting.


(Oz) #14

When you saw the communication error with RDWorks, were you still running LightBurn? Only one application can use the laser at once.


(Chuck Delchamps) #15

I double checked. Lightburn was closed. Tried again today just to be sure and got the same error message.


(Chris) #16

I have the exact same problem with both the rotary and with rdworks. I also just bought a thunderlaser. I installed lightburn first instead of rdworks, and now I get the communication error as well. Any help would be appreciated.


(Chuck Delchamps) #17

Hello, I still have the problem with the rotary. I have tried Lightburn and carefully checked all settings. I draw a 25x25mm square and the machine gives me a 25x60mm rectangle. The steps per rotation value has no effect.

So I installed RDWORKS from Thunderlaser’s website. Clay from Texas helped me to ensure the usb driver was correct. I get the exact same results as with Lightburn. The circle pulse value has no effect. 16000, 12000, 6000, 3000, doesn’t matter. I get the same results every time. I can change the results by changing the diameter value but that’s not how it’s supposed to work.
Running out of ideas.


(Chuck Delchamps) #18

I should add that except for the rotary I’m not having any problems with the machine. With flatwork it is perfect.


(Chuck Delchamps) #19

update: have continued talking with Thunderlaser today and changing minor settings and the rotary seems to be working fine with RD Works. The issue seems to be with the usb drivers. Unfortunately, there is no change with the rotary with Lightburn. A 25 X 25mm square drawn in lightburn yields a 25 X 60 mm rectangle.


(Oz) #22

I might have to get a controller from Thunder Laser to see if there’s anything different with how their controller settings interact with RDWorks - it’s possible that theirs is a slightly different version than I’ve seen, and may be set differently.