Rotary not burning & Slop error

Anytime you get a slop error from the Ruida, you have something messed up in how the coordinate system is configured/used.

A slop error means it’s going outside of the work area, usually because of overscan.

If you’re back with the table and no rotary, lets see if we can figure out what you are doing that’s causing the Ruida to complain.

Do you mind posting the offending .lbrn2 file?

Include current settings of start from and job origin.

:smile_cat:

It was operator error. I didn’t turn off the rotary in LD. Flatbed functions are normal now. Is it possible that the Ruida need to use the “U” axis for rotary in the software (LB)? I don’t have a U-axis drive. Could the RUIDA use the U-axis output to control the Y-axis for the rotary function.

I don’t think this is the case.

  1. it wouldn’t operate at all with the wrong axes
  2. I’d think the U axes would be select-able if available

You could try to divide the steps/rotation by the 4.5, although it’s not really a correct fix…

Check out this thread…

If it isn’t solved when that link has been solved, it might be better to have another set of eyes on this… maybe @ednisley has some idea on what to try next… Neither of us have a 6445…

:smile_cat:

Opinion

The reason why cheap CO₂ lasers have a jack shared by the Y axis & rotary motors is to avoid the expense of another stepper motor driver.

As a result, trying to do anything other than plug the rotary motor into the jack is swimming upstream against a strong current. That path is obviously possible, but because nobody in the cheap laser universe actually goes there, it’s untested territory and highly unlikely to work without extreme effort.

I would be unsurprised to learn that big laser manufacturers selling fancy machine can get special firmware to do whatever they want, but that firmware is unavailable to ordinary customers.

So, AFAICT, if you want to use the rotary, plug it into the Y axis like everybody else [*]. If you want to play with the laser, persuading the controller to run the rotary on another axis will provide plenty of amusement.

[*] IMO, having separate config files for linear & rotary operation will eliminate a lot of heartache & confusion. After replugging, load the corresponding config file and it’s ready to go.

Rather than chasing my tail and trying to deal with the non-responsive manufacturer, I have persued using the rotary without the LB rotary setup. The system works as it should except that the axis scale is off. A 10mm line burns at 23mm long. What factor in the RUIDA or LB should I change to correct for this scale problem?

Steps/rotation of the gui is what sets this… I can’t imagine what else would cause this anomaly.

:smile_cat:

Thanks Jack.