Rotary not burning & Slop error

Sorry to be that guy, but it appears I am having the same or similar issue as others have, in that I cannot get my laser to burn in rotary mode.

I have read most, if not all fixes that people have offered and non appear to work for me.

The engraving image sends to the machine fine and frames fine from Lightburn, but does not burn from the Lightburn or after sending it to the machine.
The machine throws up a Slop error if I start from the machine and a Y Slop error if I frame from the machine. Neither can be correct as I am trying to engrave a 10mm circle on a cylinder with it frames on fine.

The machine is a Chinese 130w Co2, with a Ruida 6445G controller running version RDC-V15.01.22 and a PiBurn roller rotary and configured in latest Lightburn Ver. 1.6.00 as such to the Y axis.

I have tried placing the rotary in the middle of the bed (using the machine bed dimensions in the controller 650x 450mm) and configured the software to center dot in “job origin” and using “user origin” while pressing the “Origin” button on the machine controller.

Any help would be greatly appreciated.

Do you home the machine some way or just plug the rotary into it while it’s hot?

If you look at your console, it probably has 0 or some low value in the Y position. If you move the wrong direction, it will go out of the working area… producing the slop error…

I set mine up a bit different, but it should work your way…

Might try moving the Y axes more towards the center of the work area… if you have a 400mm Y axes work area length, use the arrow keys on the console to something like 200. That is in the middle of the work area for the Y axes. Don’t forget to press Origin, once you move the axes.

Maybe a more clear explanation is that your image is to be engraved around the center (Job Origin), so the head must move around that origin in all directions. If that origin is at 0, 0 then the head will be driven outside of the defined work area… such as to -1 … slop error…

Make sense?


Thank you your comments.

Yes I home the machine first (top right corner), then using the controller arrows jog the head to the centre of the bed (1300mm x 900mm) and then connect the rotary and place it under the head and press origin on the machine.
I then attempt to burn a 10mm circle.

When you press origin, what does the x and y axes position indicate?


1 Like

Thank you for your help so far.

OK, I think I have identified the main issue. It appears that when I “Enable Rotary” in the software it causes the issues. If I disable rotary in the software but enable the rotary with only the hardware switch on the machine it works. As soon as I "enable rotary"in the software it throws up the “slop error” message.

Now all I need to do is get the correct sizing working as it is burning rectangles instead of squares as the Y axis step motor size adjustment is not changing the steps.

X axis is correct, but Y axis too long. Interestingly, if I change the square from 25mm to 15mm the dimensions of the Y axis stays proportional.

Thank you again.

11 posts were split to a new topic: Ruida Control 6445__? Slop Error - Can’t set this up

It’s marked solved…is it? Doesn’t sound like it from this post.

If you’d answer the questions, we’d probably have it fixed … You did not answer one of them.


This is the exact problem I had. As I stated above, as soon as a switched off the “Ënable Rotary” toggle in LB software, the rotary and laser stated firing. It’s almost as if the switch was backwards, as in, turn it on and it doesn’t work, turn it off and it works.

Weirdly the hardware switch still works as it should, so it only appeared to a software issue between the controller and LB.

Although I still cannot get the unit to burn images correctly. The images are not proportioned i.e. a square becomes a rectangle (10x10mm becomes 10x15mm) and no matter how I change the steps for the Y axis, it does not change the image.
The only thing that corrects it, is if I re calibrate the Y axis in “Machine Settings” but then this affects the normal flat printing as well. Which means I then have to go back in and change the setting back to the original settings.
There is clearly an issue the the software side of the comms between LB the controller as other functions are correct.

What rotary do you use and on which axes? Y, U?

This thread tells you how to set this up… you should not need to change controller setting values when you change to a rotary. If you have a problem in the setup, please sing out…

Does your machine have relay/switches to enable the rotary?

If the machine is setup properly it, pressing the test button in the setup should turn the chuck the complete rotation and back. If it’s a wheeled or roller rotary the drive wheel should rotate one complete turn and back.

Lets get this rotary configured correctly then we’ll move on…


I have 2 rotaries, one of each (chuck and a roller), however, I am currently trying to get the PiBurn roller working correctly. Both rotaries do the same thing.

I have and applied all the settings on Y axis and followed all instructions on how to set them up the rotary and cannot get the rotary to perform correctly. Regardless of what steps i enter in the LB parameters the rotary does not change the amount it turns.

If I run the “Test” button in LB the rotary settings (rollers or chuck) rotates at least two full rotations, regardless of step count. I ensure that the new step count has been written to the controller and have cycles the power on the controller and nothing changes.

The only thing that does change is if I change the rollers wheel diameter in LB. However that is not consistent either. E.G. if i change the wheel diameter from 63mm (as per Piburn instructions) the it over runs the expected finish point. If I change the diameter to 40mm it under runs by a small amount, however if i add 2mm (making the new diameter 42mm) then it runs over again like it did with the original 63mm setting.

Can you show me a photo of the motor driver switches and what type of driver it is?

Also a screenshot of the rotary setup gui from Lightburn.


Did I misunderstand this from post 10?


1 Like

Hahahaha, I think you are getting confused. There appear to be two people asking for assistance here at the moment, Myself and eyefargone.

Confusion is my normal state … :grimacing:

I apparently didn’t look at the letter in the same color icon… :poop:

Yep, I was getting the wires crossed…

What is the value of start from in the laser window ?


One note, the “read settings…” is not getting the information from the RUIDA. I put in a value of 100 for the steps/rev and then hit the Read Settings… and there was no change. The dip switches on the Y drive indicate the 6400 steps/rev. “Test” runs the chuck about 4.5 full revolutions and then back to 0. I downloaded RDWorks V8 yesterday and set it up to perform rotary operations and it gives me the same results. I would like to eliminate LB as the issue so that I can get closer to the resolution.

What model of motor driver?

It’s easy to misread the switch settings. ON is usually towards the circuit board and ON direction is also marked on the switch.

There isn’t much to how the hardware interfaces, but it has to be as specified if the motor diver is going to move the motor the correct amount.

I assume your rotary has the chuck connected directly to the motor, not intermediate belt/pulley or gearing?

Whatever is off, appears to be off by 4.5 times…

On my machine, the switches are set to 2000 steps/rotation … on the fiber they are 12,800 steps/rotation.


These images are the Y-axis drive control, DIP switch settings, and the RUIDA control module of my machine.

I REALLY APPRECIATE your continued help with this. I am almost certain at this juncture that I have a hardware problem.

These look good, I think you read them correctly.

Using these settings, is it doing the 4.5 turns when you press test?

Basic hardware is pretty well eliminated if your normal Y axes work properly.


Yes. These settings gives me the 4.5 revolutions.

I had to remove the rotary for a job and return it to a flatbed configuration. However, now the Y-axis does not move. I made sure that the rotary switch is set to off. LB will move the Yaxis in “frame” mode but will not control the laser with “start”. Sending the file to the RUIDA and starting the program give me the “slop” error. All the same problems as with the rotary attached and on.