Rotary Setup - Lightburn rotates, controller does not

Hi all,
First post here. I hope I have this in the right category, it seems more like hardware, but touches on Lightburn as well.

I am working my way through @myerswoodshop video tutorial on getting my rotary setup. I got to the point where I am figuring out steps per rotation. I hit start and nothing happened (have never tried hitting start from lightburn before, always send and start from panel) and this is where my trouble started.

I sent the file to the controller, origin, and frame as per my normal procedure. The X axis moves, but Y does not. I can jog the Y axis no problem, so I think thats OK. It just does not work with either frame or start from controller. However, if I click Frame in Lightburn, it will run the framing with both X and Y axis.

Thats the strange bit that has me confused. Frame from lightburn works on both axis, frame from controller only works on X axis.

Any ideas why this behavior is happening? Lightburn is setup for Y axis on the rotary setup tool, but I could not find anywhere where the controller might be trying to use a different axis (U maybe?).

As a side note: My Y axis is a three wire stepper motor with an A/B switch on front of the machine. My rotary is a 6wire stepper that has been tied together by factory to make it a 3 wire motor, but the aviation plug that was on it was a 4pin plug, and this new laser is a 3 pin. So I did some testing and put the 3pin aviation plug in. Works just fine when jogging around so I figured that the wiring is correct there.

Thank you,

What controller are you using?

Did you setup the rotary in the LightBurn rotary setup menu tools-> rotary setup?

Hi @joel1 Thanks for the reply.

Yes I did set up in rotary setup. I was working my way through the turorial. Got everything set execpt for the steps per rotation, thats what I was working out when I came across this.

My controller is a Ruida 644XG Firmware Version RDLC-V15.01.22


I have a 6445G, I have not set up a rotary yet but two things come to mind,

There was a FW update that allowed the 644XG to use the U axis as a rotary. I am not sure if LightBurn supports this yet.

Then there is a place in LightBurn to set up using the Y axis as rotary and switching back and forth ( swapping Y axis control cable ).

I’m not sure which method you are trying to use.

Those are the are only thoughts I have at this point.

Hopefully someone else may have some ideas also if you are still stuck.

Your FW is later than mine ( 15.01.19 ), so in that regard you should be good.

Thanks again @joel1.

I am not using U Axis, its a A/B switch for the Y Axis. There is an aviation plug on the inside of the machine, plug rotary into that and switch the switch to position “2”.

When it is in that position the rotary turns when I can jog it using the panel, it will also turn if I send a file to the laser without having “enable rotary” turned on. If I toggle “Enable Rotary” ON then it will not turn.

I just tried it on my laser ( no rotary but can see if the y axis moves ). I see the same thing, rotary not enabled, y axis moves, enable rotary, y axis does not move.

@LightBurn - what are we missing here?

Thanks for giving that a try @joel1, that’s good info and quite interesting.


Hi, Did you find a solution to this as i am having exaclty the same issue and with the same firmware version?

I am looking for the same firmware to reinstall or later, but cant find it. i can only find V15.01.18

Thaks, Dean

I found this thread that might help,

I went over to Lightobject and installed 15.01.22 which went fine. I still haven’t made or bought a rotary so I haven’t investigated more. I didn’t read the full thread, at least part of it is talking about using the U axis for the rotary.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.