Rotary tool configuration and testing questing

I purchased an omtech chuck rotary tool. I need a little help. I have connected the tool to the U axis and enabled U in the settings of the controller but I can’t get the tool to rotate or respond when I try to manually control it. I have tried 2 different stepper drivers and I’m not having much luck.

So my question is, is there a way to test the motor to make sure it works or something obvious that I might be missing?

From what I can see, the hardware is probably correct… at least you have wires where there should be wires…

There has been a lot of discussion over using the U axes with a rotary on a 6445 and you might benefit from reading some of these threads. I don’t have a 6445, so I haven’t tried to run my rotary off the U axes on the 6442 that I own… actually I don’t think mine supports a U axes rotary.

Good luck


Thank you. I swear I search before posting

Don’t let it keep you up a night :face_with_spiral_eyes:

I can’t find things here sometimes myself…

Let us know how it works out and what the solution is…


So I did a quick review, I see a lot of talk about pressing “origin” and making sure the firmware is correct. But from what I could tell they all relate to getting the image to burn not getting the rotor to just move.

my main issue is I can’t even get the rotary to turn. Are the u+\u- on the control panel supposed to work? No matter what settings I change or wiring I swap, I can’t get the motor to turn.

About the firmware, I downloaded the latest version but then when I try to install it it says version not correct, the threads mention v15 but my controller Says v36…so I’m a bit confused there.

I understand you can’t get it to do the basic functions of rotation.

How did you setup the U axes motor driver steps/rotation?

I’d set them like the other steppers on the machine.

In Lightburn set the steps/rotation to whatever the motor driver is set.

You should be able to press the test button and have a complete rotation and return.

If the firmware isn’t right, I don’t know if you will have a functional rotary, so the way you are testing it may have a flaw.

Since these will drive a Z or U axes are you sure these are enabled in the Ruida… Also when you use the machine console, I think you have to select which axes you want to control…

I don’t have one of these so I don’t have any experience using a rotary on the U axes with a 6445.


I don’t see a connector for the stepper motors power

Thanks for the picture, I will compare my wiring to that and see. For the power, I do have that connected just not in the picture, I have the power temporary ran and the wires were not long enough to leave it connected for the pictures.

I sent a message off to Ruida to see what they say about the firmware numbers. I have 2 of the same controllers and both have the v35. I have a little downtime in my production, so I will try and mess with this again today. I am going to try and swap the plug out to the y axis and see if I can at least the the rotary tool to turn. I would hate to spend a ton of hours on this only to find out my rotary doesn’t actually work.

This may be easier for him to decipher … From the DM542 manual…

Make sense?

If in doubt, read the documentation … :rofl:

Good luck


I am really starting to think that my rotary tool doesn’t work. I have checked the wiring multiple times and used my meter to verify wiring inside of the machine.

From the manufacturer they indicate this is their pin layout.

The other half of the connection has this color scheme

So If I translate that to the end attached to the rotary, it would be this.

And if I go off those colors, it would connect to the driver like this

Assuming that is correct, I cannot get the rotary to respond when I press any buttons. I even swapped the plugs from the X and Y axis on the control board with the U with no difference.

I have tried different voltage settings and stepper settings with no luck.

When I have the driver connected the rotary has some resistance when manually turning compared to when it’s not connected.

The more annoying party is if the rotary tool is DOA, the manufactures warranty expired after 30 days but I bought this around Christmas and am just getting around to installing it. SMH

You’ve got the A and B windings swapped, but it doesn’t matter: there’s no way to get it right the first time. As long as you have the windings connected to the driver, the motor will rotate and you can sort it out from there.

To verify the rotator wiring, use an ohmmeter to check for continuity between the two A pins and the two B pins in the rotary cable connector. If their diagram is correct:

  • The A pins should measure a few ohms
  • The B pins should measure a few ohms
  • No continuity between any A and any B pins

If that’s not the case, then their diagram is wrong. Report back on what you find and we can tweak it from there.

If it’s all good, then set the switches:

  • SW1-3 = ON OFF ON = 1.9 A
  • Sw4 = OFF = half holdIng current
  • SW5-8 = OFF ON OFF ON = 6400

That’s enough current to get started and enough steps to make sense.

Then in Machine Settings, set the axis (whichever one it’s supposed to be) values:

  • Acceleration = 1000 mm/s²
  • Speed = 100 mm/s

Which will be achingly slow, but should verify it works.

The distance/step setting will probably be wrong, but any value will get it started.

Then do some jogging and see what happens. It may move the wrong way, it may not move as far as it should, but it should move. The rest is a matter of fine tuning.

Did the Ohms test and it was .7 on 1&2 and on 3&4, with no continuity between the 1&3 or 2&4.

I changed the dip switches to match what you indicated

Changed the settings in the controller and enabled the rotary.

After writing to the controller I exited out to the main screen. When I press the U+/U- buttons I get no response or movement.

One thing to note, is with the rotary enabled in the settings, the Y axis only moves about 200mm but says it has moved 600mm. This corrects itself if I disable the rotary function and the Y moves the entire length of the bed (600mm) without issues.

So, no matter what the doc may suggest, the rotary should be connected to the Y axis of the controller, which is common with these machines, and the U axis is either unused or (in my machine) connected to what I’d call the Z axis.

Remember to save the machine configurations for normal and rotary setups so you can easily switch back and forth!

Just wondering if on the 6445, is it supposed to indicate someplace on the main controller screen that the U is enabled. I can see a x,y,z coordinate but nothing that indicates “U”

This swapping isn’t really feasible in my situation due to the placement of the production machines and would require me to move the large machine in order to access the control panels. I need the ability to change on the fly depending on production schedules.

Because you have a separate stepper driver for the rotary motor, I think you can make this happen.

  • Install the rotary stepper driver inside the machine, with a nice cable to the connector you already have, wired to the Y axis controller outputs. Make sure the connector is easily reachable, but in a place where it won’t get into trouble.

  • If the Y axis doesn’t already have a similar connector, add one where it’s easy to reach. My machine has it just outside the Y axis rail on the right side. You will use this only to disconnect the Y axis, not to connect the rotary.

Create two Machine Settings files:

  • Normal Y axis (linear distance / speed / accel / whatever)
  • Rotary Y axis (rotary values, ditto)

For normal use:

  • Load Normal config file
  • Put the rotary on the shelf, unplugged from its driver
  • Connect the Y axis to its driver

For rotary use:

  • Load Rotary config file
  • Install the rotary & connect it to its driver
  • Unplug the Y axis from its driver

No need to open the hatches, no need to twiddle individual settings, just install the hardware and run it. Either the rotary turns or the Y axis moves, not both at the same time.

You might not even need to enable Rotary mode in the controller, although I’m not sure about that. AFAICT, the config file could makes the machine think it has a kinda slow Y axis with a different distance-to-step ratio.

There are fancier ways to handle the connect-disconnect thing, but a pair of durable connectors has a lot to like.

Ok I am going to take a mulligan on this one. Before I give the solution, here is a picture, can you spot the difference?

Ok, in the picture I previously posted, I was using 8 strand wire and the brown and black are almost identical….smh

Ok, now that I have the U drive rotating with RDworks. How to do set the dip switches to get the right sizing. I tried a 50x50mm square and it comes out 50(x)x65mm(u)
The rotary tool shows this for its specifications

Well, that’ll teach you to use a headband magnifier with a bright headlight! :grin:

It’s a chuck rotary, so the basic number is how many steps will turn it exactly once, which (contrary to what seems to be common knowledge) is not a free variable.

The stepper driver switch setting gives you the steps per motor rotation.

The gear ratio from the motor to the chuck gives you the chuck rotations per motor rotation. That’s the Speed ratio 1:1.5 in the specs, although I don’t know which way it goes. To find out, mark the chuck and the motor, then jog the motor one turn (or do it manually with the power off) and see if the chuck rotates 1-½ turns or ⅔ turn.

Multiply those two numbers and you’ve got the steps per chuck revolution.

Then feed in the diameter of the workpiece and the result should be pretty close to right.

(I’ve been unusually out-and-about, not ignoring you.)