Ruida 6445 and Rotary

There are quite a few old threads, now closed, in this forum about using rotary control with the Ruida 6445G but none of them come to any real conclusion. Apologies for starring a new thread but I think it’s the only option now those are all closed.

It seems to me that the current situation is:

  1. V15.01.22 of the 6445 firmware (which is what you get if you buy a new unit from Cloudray) has at least some support for rotary on the U axis. The motion control buttons operate this correctly for example.

  2. However trying to use this through Lightburn doesn’t work. No matter what you try with the rotary settings nothing ends up running correctly. Either the laser won’t fire, the wrong motors run, or it fails with an error. One user from LightObject reported getting it to work, but it looks like nobody else (including me) has so far been able to duplicate their success.

  3. To add insult to injury it seems that the previous ‘swap Y with rotary’ method no longer works either! Using the Lightburn rotary settings changes the Ruida’s response such that the Y channel no longer behaves as it did when in rotary mode. ( I assume this is deliberate and the U channel is now supposed to do the job.)

  4. The only way I can get rotary to work with Lightburn and the 6445G with 15.01.22 is to swap Y and rotary, but not tell anyone. That is, don’t enable rotary in Lightburn or in the DSP and instead do the math yourself to scale the y axis appropriately. This works, but is very 20th century. :slight_smile:

I understand this may be out of Lightburn’s control but I request that we establish that as a fact before moving on. Are these changes in the Ruida firmware something that Lightburn can use? If they aren’t, then, at least in my tests, the rotary mode with this model of the Ruida DSP is sadly now of little use.

Lightburn, what say you? If you’ve managed to make it work, please post how you did it. :grin:

1 Like

It works if you press Send instead of pressing Start, then run the file from the machine panel - and according to Ruida this is by design. They were concerned that a user could move the laser head away from the rotary then ‘Start’ and not realize it was off. (I think - sometimes things get a little lost in the language barrier)

I have an updated firmware from them with some additional bits that will allow you to use the ‘Start’ command instead of just ‘Send’, but I need to play with it a bit to make sure I understand what it’s doing, and why.

I’ve tried that I’m afraid. As you say, ‘Start’ does nothing at all. Using ‘Send’ and running from the panel the rotary just spins until you get an error. Is there some option you have to set for the U axis to prevent that?

Make sure you’re in “Current Position” mode instead of absolute, and that you’ve set the rotary steps per rotation appropriately. Other than that, I’m not aware of anything special that needs to be done.

Pretty sure I had both those correct. Now you’ve confirmed it should work and that it’s not just hearsay I’ll try again.

OK, tried again making sure those were correct. Simple box which is 11mm (x) and 154mm (rotary). The rotary is on the U channel. Send the file then run it:

  1. First the rotary (on the U axis) rotates, but much more than it should.
  2. Then the rotation (U) stops and instead the Y axis (???) activates and moves the gantry to the rear of the machine
  3. Ruida triggers a ‘Frame slop’ error and stops.
  4. Laser is not triggered at any point.
  5. X never moves at any point.

Still having no success. Another question, in the thread where the LightObject poster says they had it working, they show a screenshot with an enable rotary checkbox on the main laser tab. I don’t see that, that checkbox is only on the configure rotary window. Is that something I need to configure?

EDIT: Never mind, I found the option to show the enable rotary checkbox on the laser tab. :grinning:

I’d still love to hear from anyone who has the 6445 with the V15.01.22 firmware and has successfully configured and used a rotary. Thanks!

I have a 6445 with the U-axis working. I contacted Cloudray and they emailed me the R6 firmware. In the LB Rotary setup screen: The only option is still Y-axis, The test button only activates the Y-axis and it crashes if I don’t stop it. No option to activate the A-Axis. BUT it does work when you press the send button.

I fought with this tonight to get it set up and going. Shame I was late finding this newer thread, lightburn already officially answered one part I was struggling with. Play doesn’t work, but send does, then I can run the file fine.

I also ran in to the frame slop issue. I think it was because my artwork was just slapped in a random spot within lightburn that was far from 0,0. once I moved the art to 0,0, things worked fine. I think within lightburn I could have also chosen a corner of my artwork as my origin and also fixed that problem.

The test rotary still doesn’t work right for me. Ignorable, but notable.

I’d really love for “play” to function again with this new feature if lightburn wants to share the firmware they mentioned receiving that fixes that. That’s my normal workflow, just hitting play from my laptop. Not a major deal but it does annoy me having to do the send thing and then choose it from the controller.

And just to note my exact procedure if it helps anyone, since I just did it tonight:

Set up the rotary, driver etc for the U axis ports on the controller.

Calculate your steps per rotation. usually (360 / 1.8) * microsteps * gear ratio if relevant

Turn on rotary mode on your controller, its a new option in the User+ menu iirc. Same place you’d enter the above number

Turn on rotary in lightburn

Make sure your origin is something sane, corner of your art, or the art is at 0,0. Use user origin. move it to your piece, click the origin button on the ruida (I think).

Send to ruida. Play it

Ah! The origin setting on the Ruida may be the missing part of the puzzle. Thank you, I’ll try that. :slight_smile:

yea that tripped me up too because I always work from absolute 0,0

I think that is what was causing mine (and others) ‘frame slop’ errors

oddly I also noticed when I activate the rotary on the ruida, the U buttons start moving Y again. Not sure if a reset would make that go sane again or if its a bug, but that’d be on their side, not lightburn’s. Problem for future me

All very useful points, thank you. One question, which version of firmware do you have in the Ruida?

I’m using the file found here: *Update: Rotary support Patch for Ruida R6445G DSP laser controller * - Lightobject.com Support Forum

What my controller says now matches that file name on version

Good, that’s what I’m running too. What I hadn’t tried was setting origin on the controller as well as using relative moves. Out of the office today, but I’ll be trying that tomorrow!

Success! The magic bullet was setting the origin on the Ruida. This is what works for me with V15.01.22 and the rotary connected to the U axis.

  1. Enable rotary in Lightburn
  2. Use ‘Start from current position’ in Lightburn
  3. Jog x and y on the Ruida to move the laser to the required starting point on the work
  4. Press ‘Origin’ button on Ruida
  5. Send job from Lightburn to Ruida
  6. Run job by pressing start button on Ruida.

Step 4 is what I wasn’t doing. Everyone else may have known to do that, but I didn’t! :grinning:

Thank you very much to all for your input, much appreciated.

1 Like

Something that does work and mimics the ‘Play’ method - Hold the Shift key when you click the Send button, and LightBurn will start the job when it’s finished sending to the controller.

@Lignumaqua - Thanks for the step-by-step for getting this to go. That should be very helpful for others.

1 Like

Oh awesome, that is good to know. Thank you @LightBurn

@Lignumaqua Glad you got it going! I spent way too much time tripped up on that origin thing lol

1 Like