Rubber band frame issues

Hi all,

thanks for allowing me in to the group!

I’ve been using lightburn for a few weeks now and something very odd has just started for me. I was wondering if anyone had a similar issue or run into this before and had the solution.

I have a project I want to make. I’ve done this in the past and worked out very well. It’s about the rubber band framing option. When I selected it a few days ago it would work as it supposed to. It would trace the project very well. This makes it easier to place on the acrylic to engrave/cut to maximize the entire space on the sheet.

Today I select the rubber band frame and it seems to start half way through instead of a the bottom left where the little green square is. I move the laser head to the little green square then highlight everything and select the O Frame. When it starts as I said it appears to start in the mid point of the project vice the bottom left corner. If I select the box frame, that works properly. I have the start from set to current position and job origin set to bottom left.

Any info would be appreciated!

Hi there,

Thanks for responding! It was my pleasure serving, I wish I had never retired! On a good side, my son followed in my foot steps and is also in the Air Force.

As for my issue, here is what happens;

I have a piece, it’s 12” wide I initially placed the project around the top left, close to home position. Before doing that I home the head, just so it’s right on the numbers. Then I move the lead to the bottom left corner where the green square is. Then I select the rubber band frame. The head looks as if it goes up slightly and around the half way, say 4.5” instead of the full 9” wide. Then it starts it’s path. In this case the laser head hits the Y rails, I have to unplug the laser to stop it or it binds and will cause damage to the board. Now after I start over again and start the project it will cut and engrave in the position I had it set to on the bed and where it was in lightburn. Hope that makes sense. The reason for wanting to use rubber band frame is to maximize the space on the sheet.

If I do the same positioning and setup and select the box frame, the box frame does it’s thing the right way.

Basically the rubber band frame cuts the project in half and starts at the bottom left but only moves right 4.5” and the starts the frame action. Box frame starts at the bottom left then goes to the full right side of the project and goes around it as it supposed to.

I hope this makes sense? I could upload a video, if that’s at all possible….

No, current position

Tried, it just moves the start point after the frame is done. It’s super weird!

I’m going to attempt a couple of videos, hopefully I’ll be able to upload them! Failure for the videos! I’ll take pics and see those will make sense.

I don’t know, but the screen seems to indicate the your ‘home’ is front/left. I thought the K40 homed in the back…
Ensure your ‘job origin’ is correct when ‘Start from’ is other than ‘Absolute’ Check that…

This indicates you are not properly configured. The only other option is a hardware issue. Does your machine home on it’s own?

Do you usually use “Cut Selected Graphics”?


I’m using an LX4S board and not the M2 Nano board. I guess that makes sense as the M2 Nano doesn’t work with lightburn. The way the GRBL firmware is setup is this way. When you setup the firmware it shows as front left but it homes to rear left.

It should show on Lightburn correctly. Why/where did you find to change that?


I setup the new board with the maker of it, Eric Norton with VMS laser on facebook. I did have a different board but it arrived DOA and the maker was a dick and wouldn’t provide any support and blamed me for the damage. Anyways, Eric has been amazing; however, he’s not a lightburn expert, he an electronics engineer.

This photo is of where I have the project to start. The disc with the hole in it shows the bottom left of the project. If I select square frame it follows the rular across to the feeler gauge, up then back to the hole.

This photo shows the origin position using the rubber band frame. The feeler gauge on the right shows where the far right of the project ends and it circles around to the finish point. See next image

This photo shows where it stops after the rubber band frame. It’s approx 6mm to the right from the start position. If I select the rubber band frame again, it does the same thing; however, ends another 6mm to the right of where I started that frame from. Basically every time I do a rubber band frame it moves it to the right about 6mm, but shows the position as being the original starting position like in image 1 up top. If I I move the laser head back to the home position without selecting home it doesn’t move it back to say 0/0 but however many mm to the right of the starting point. Next image shows that.

This is supposed to be 0/0 which it isn’t. Next image is 0/0

I literally have to select the home button for it to realize it’s actually at the home position.

If I want to use the rubber band frame on anything over 115mm wide this is the issue. If I use the rubber band frame on projects at or under 115mm wide, no issues. I hope this all makes sense.

I have an issue with the configuration. The machines hardware ‘home’ is rear/left?

You are telling the software (Lightburn) that ‘home’ is front/left?

The machine thinks it’s in quadrant iv and you tell the software it’s operating in quadrant i? This will cause issues… Somethings isn’t correct here…

Can you post a screenshot of ‘Edit → Device Settings’?


It all works very well when cutting and engraving. The only issue I have is with aligning with rubber band frame. Not an issue at all with box frame!

I’ve gone to extremes here and swapped out my laptop for a desktop computer because things were sooo messed up! Now when I do the box frame and start a job it begins the job 70mm to the left of where it should start. I have absolutely no idea why this is happening.

I gave up for today, too angry right now. I must have changed a setting somewhere to do this.

Doesn’t matter which frame I use to align the acrylic to cut and engrave, it’s seems that it shifts left from the positioning 70mm give or take when I try to cut or engrave.

So much easier to push pallet, eat banana and not forget how to breath, lol

Thanks much, appreciated! That’s my plan too, there is a solution for sure, just need to figure it out is all.

Look for this place, Keremeos, B.C. Lol

No, applied to the RCMP but they weren’t quick enough, was hired by a different service. Worst mistake of my life. I suffer each and every day now because of it. C-PTSD sucks!

Thanks for the shots.

The first one indicates that the ‘home’ of the machine is the front left. You previous statements indicated it is back/left. There will be an issue if the machine thinks it’s one place and the software thinks it’s elsewhere.

The second one, is the parameters that ‘preview’ uses to emulate the execution and estimate the ‘run’ time. You can ‘read’ it from your controller. It does not effect anything but the ‘preview’.

Before I chase down anything I think might be a bug, I like to make sure it’s properly configured so I’m not chasing something that may go away when it is correctly configured.

Screenshot from 2021-12-03 09-24-16

It’s easy to confirm that the machine homes in the front left, as you have it configured. Does it?

Hoping it is configured right, but…


If you have a YouTube, DropBox, iCloud, etc account you can upload video to one of those and just post a link to it here. You could also post the project file itself, or email it to support@lightburnsoftware with a link to this post so we can have a look and try to reproduce it. It’s hard to guess at what’s happening without seeing your project.

C is for complex, meaning not just one incident, but many! One day I hope the good will out weigh the bad, sadly not right now. That’s why I use things like the laser and 3D printing or gaming to get my head out of the bad place.

I’ll do that later today when I get back from medical appointments.

I’ve also been speaking with Eric Norton, hopefully it’s just an offset that’s throwing things for a loop. It’s to the point now that it doesn’t matter what I do, it’s like I’m telling it to do something completely different. It’s super weird as it was working perfectly a few days ago.