Rudia Laser not working correctly with LB

I have a RDC6445G(EC) controller on a 600 x 400 laser machine, 100w. Here’s the issue I am having.

I set the machine up with RDWorks (latest version) and got it working like I need it to. I bought LB a good while back and used it for a small desktop laser/CNC thingy you can get off Amazon. Worked well but need to step it up a bit.

I can use the RDWorks and everything is fine, but it is limited on it’s functions. I try to use LB and it will not function correctly. For instance:

Using the Focus laser in LB, the X, Y, and Z move but the laser doesn’t fire.
I can draw a line in LB, and the laser will fire, but the Y axis moves at like .3mm/sec. Very Slow!
Z axis moves too fast and it will not slow down.

Haven’t went thru all the settings in LB (I do have the latest version, DSP, and drivers installed BTW) but I Love using LB and would like to get it to work.

Anyone else have these issues, or had them and a solution to them?

You just have a configuration issue, since it pretty good proof it’s a working system. That leaves configuration.

I wouldn’t think a change like that would occur…

Run over you setup and Ruida configuration. Don’t forget to save your configuration if you haven’t already. :slight_smile:


Thanks Jack! I’ll look at the settings some more. I think it may be something with the software sending commands. I can draw the same 20mm line in both programs. RDWorks will cut it at the speed I program but LB won’t.

Or do I have to totally set up the laser using LB?

How are you connecting to your machine? (Ethernet, WiFi, USB)

What is the operating system of your computer with LightBurn installed?

I am connected via USB and its Windows 10.

Hi Jamie, if it’s not config settings try checking the wiring of the ‘y’ and ‘z’ axis, sounds like they’ve been wired wrong.

I have run into some issues with LB and a KT332 control. Similar to what you describe. LB seems to only function in metric for my machine. I set the control panel up on my machine to run in metric and then LB works correctly whether you choose metric or inch in LB. If I set the control panel to Inch and make changes from LB there is no telling what the hell is going to happen.
IN any event if you make changes from LB to any machine setting, you MUST shut the machine control off and back on. If you don’t, you could have anything happen. I have had the machine just take off into space while using a rotary, and then home fine with the rotary. The machine will not calibrate axis at all withouit shutting off and restarting after every change.

After learning these two bits, the only LB issue not solved is no Z axis with KT332. RDworks does do the Z axis. Unfortunately here we are not allowed to use Rdworks, so I am waiting on L B to work with the KT332 or installing another controller.

I don’t think the wiring is the issue since it runs fine with the RDWorks program. The X and Y axis go the correct direction in both software.

I’ll play with these settings and try to restart after I adjust them. I am in MM/SEC in both softwares as default but will check. It’s just strange. I may save it as a GCode and inspect what it is sending to the controller.

Hi Jamie, i read that wrong.
Seems strange though that ‘y’ axis is running at a set slow speed and the ‘z’ axis is running at a fast speed when it should be the opposite :thinking:
But that’s just me thinking(probably got that all wrong as i don’t use auto focus)
Good luck.

You can adjust step size and fix this.

Did you try this beta? I thought saw your ‘tracks’ there.

KT332 (EC) Control Z and U swap


your controller doesnt use gcode, I do not think you an inspect anything for that matter

He can save the ‘rd’ file. The controller can read them from the USB ‘drive’. He can also examine it. However it’s not like gcode.

The RD file is binary format, so no general text editor to look at it. I’ve ‘hd’ (hex dump) in Linux.

Here are the op codes for the Ruida, good luck :slight_smile:

Here is an ‘on-line’ app that will Reverse Engineering of Laser Cutter Controller RDLxxx and RDCAM Software.

Did this 40mm square drawing.

square.lbrn2 (4.4 KB)

This is the output from the ‘Reverse Engine…’ link above.

Same game, just a little more difficult to decode… :slight_smile:

I’m sure there is a competent op code decoder out there somewhere. I can’t imagine trying to debug some output in binary…


As you can see that decoder is fairy incomplete. The Lightburn ppl did a much better and completer job.

Yes, I found one at on a search earlier this year that seemed to function better. The idea is that you can look at the code… I wouldn’t spend the time with it’s format binary and no tools…

Here’s the dump of that rd file:
$hd square.rd
00000000 d2 19 fa 7a 8b 89 d2 89 70 8f 89 89 89 89 89 89 |…z…p…|
00000010 89 89 89 89 70 b1 89 70 0b 89 89 89 89 89 89 89 |…p…p…|
00000020 89 89 89 70 0f 89 89 8b b1 c9 89 89 8b b1 c9 70 |…p…p|
00000030 d9 89 89 89 89 89 89 89 89 89 89 70 59 89 89 8b |…pY…|
000001e0 89 89 89 89 89 89 89 64 70 89 d4 09 8f a9 89 89 |…dp…|
000001f0 89 09 a9 89 89 89 09 a9 6e 0d 89 89 09 2f 15 60 |…n…/.`|

Pretty boring… :frowning:


Ok, I want to thank everyone for the help on this. I finally got this thing working. I can’t explain it but this is what I did (and what all I did). I went through all the settings and found nothing different between the 2 programs.

Original problem was RDWorks and LB did not yield the same results with the same settings in the controller. I tried uploading and downloading from both software and could not get the laser to operate remotely close.

X axis was within 10% on speed from both software.
Y was no where close and couldn’t control the speed.
Z was no where close and couldn’t control the speed.

RDWorks was on Ethernet and LB was on USB.

I deleted the connection from my computer on the LB USB and manually entered the machine via Ethernet.

LB now works equal to the RDWorks. I did have to enable the 2nd laser to get it to fire but that was a simple fix. It was enabled before I redid the connection but defaulted to off when I connected via Ethernet. May have been something in my connection or could be the difference from USB to UDP.

All is good now, and thank you everyone again!!!

1 Like

USB on laser controllers these days…

More like:

Universal Serious Bust



Cut using LB. 2.5mm leather.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.