Ruida 6442 Stepper motor parameters Z axis U axis

Hello Lightburn, Humbly glad to be here. I have a chinese (from ebay) Laser 500 x 700 (red and back) with a Ruida 6442 controller/ Over the last couple weeks Ive done some upgrades. I removed the “dumb” motor which controlled the Z table up and down and installed a Hybrid stepper motor which I found the motor and driver n ebay for 80 bucks. I know nothing about stepper motor torque and the 4 post screws looked like it may be a job going up and down. with a great search I found the correct wiring diagram so if anyone is interested in how I did my Z axess ill be glad to offer what I had. after installation I initially had speed problems, mainly it went so fast it caused itself to freeze after about 5 inches. I was fortunate enough to find someone on youtube who had a similar sized machine as mine also with a larger stepper motor. He posted a picture of his parameters he used RD works, I used Machine parameters in Lightburn and after 5 minutes, it worked perfectly. slowed down nicely. I actually wont know if the sensor works till friday when my new one comes. Because when I first tried out autofocus in Light bre, my table crashed into my laser head and sensor messing the works up. Opps. anyway Im sure this will all work.

So with the Z axis out of the way, I also purchased one of those inexpensive (100 dollars) rotary devices along with its own driver. I say that because most machines like mine come with a 4 pin aviation plug with a harness hanging from it designed to be plugged into the Y axis. I thought it would be better and easier if my U axcess had its own driver.
Well this is where im asking for help. I plugged in the U axis device, tried to do the same ting I did with my Z axis by copping down parameters from m,y own Y axis. It didn’t work, the roller device is still going to fast, heres the rub, I thought I was typing everything into the U axis spot in Machine Pariters in lightburn. Except when I went to move the Y axis with the machine up down controls the Y axis moved sub snail, Worse it only moved 1 inch either way. I did see somewhere where it asked for my roller size which is 1 inch about 25 mm. I may have put that in somewhere but dont know.
The simple question anybody have a Ruida machine 500 x 700 mm and be willing to give me your Y parameters.
Before I sound totally stupid. Before I did anything I thought I made a backup of parameters both in Light Burn and RD works just t be safe So now when I open Machine parameters in Light burn the box marked OPEN is greyed out meaning I can see it but it doesn’t click. Otherwise I would just load the backup.

even if I did that I would ask anyone if they could help ,me with parameters for my U axis. or im afraid Ill just bunk it up again.

The U axis is for a feed roller device only, on a Ruida controller, the rotary must be controlled by the Y axis. This is a limitation of the Controller itself, not LightBurn.

1 Like

I think I understand, except then why am I able to adjust u parameters in both light burn and in RD Works? Are you saying that if I unplug the Y harness from the Y driver and plug the roller into the Y driver it would work? Not trying to sound cocky because I truly don’t understand because logically all roller devices are not created equil. For example mine is a simple device, 3 - 1” rollers inside a metal square. Those rollers will want to run different speeds than the stepper on my Y axis or a different roller device that had. Like a 4” end pin ( sorry if I get my terms wrong) no initially thought like you except it didn’t make sense to me that the Y axis and other roller devices were all very different. Anyway once I get my Y axis working again I will try your method. My real problem is I need parameters to get my Y axis to function as it once did. I thought of using the X parameters but they are too different from the Y that’s why I hoped to find someone with a Ruida 6442 and machine Size 500 x 700 those parameters should be identicle thank you

Just extending your logic a bit farther if once I had the parameters for my y axis working I could copy them into my new U driver than Ruida won’t know the difference right? Cause she’s just looking for insreucrions and shouldn’t care from what driver it does make sebaceous in a way that the x and Y axis work together the u replacing the y when burning on something round just not sure how different roller sixes effect this

Also lightburn (happily ) until yesterday I still thought I had to keep RD works around for machine adjustments but I took a chance and found Machine parameters, which totally allow me to deep 6 RD Works a software designed for Windows XP so no it’s not a lightburn thing but because at least my lightburn controls every aspect of my laser then yes it is

By the way thank you for answering me I don’t want to seem like I know it all because I don’t. Grateful for your help.

The U axis does have its own settings, it’s not able to be used for rotary work. Some machines have a feeder table, which basically turns the bed into a conveyor belt, and the U axis settings are for that only.

1 Like

With the machine turned off I unplug my y axis. Then I plug my rotary into the y axis port. Then I turn the machine on. In Lightburn I go to the rotary settings and enable rotary or click the switch on the main screen. When you switch back to your y axis you must check that rotary is once again disabled. Lightburn was able to read my rotary device so it entered the steps/pulses automatically. Which I realized after I attempted to calculate it on my own. Mine is 1.8 degrees so I figured it was 200 steps per but the number entered is 10000 which was entered automatically. The only number you should need to enter is the diameter which you will have to measure each time you put a new size cylinder on the roller/rotary. I was overwhelmed at first and tried to overthink everything but I’m starting to see it is easier than I thought. Just read as many blogs and forums as you can and learn from others and trial and error

1 Like

Hello Mark, not to hijack your post, but I have a Chinese blue/white (basically same as yours but smaller bed, I think). 100W Reci, Ruida. I have a power z bed only controlled by buttons. I would love to convert it so it can be controlled by lightburn. Is this what you accomplished? I assume the ‘dumb’ motor you refer to is what I must have. I know there must be quite a bit more to it than changing the motor… ie: stop switches? wiring into ruida and/or power supply. Do you mind sharing or pointing me to info on what all is required? It seems this must have been covered somewhere but have not found anything comprehensive.

Im thinking of throwing the damn rotary thing out. I don’t need it for my work it was a toy and now its got me all screwed up I just read your responses and Ill go out now ant try them, I am so grateful. Overwhelmed doesn’t cover it, Can anyone tell me why when I was able to re install my backed up settings noting changed it didn’t work? Until now I thought just basic logic could fix anything. Not here. I do not know anything about stepper motors,

So this is why when I thought I was putting parameters in for the U drive it didn’t matter. Example my rotary device is a simple one just has 3 rubber coated 1" diameter tubes, I typed in my rotor or disk size, This is when my Y drive would move only an inch either way makes since. Sort of. It would be nice if Ruida would actually make a real american style manual. Again mine is The Ruida 6442G which seems to be Ruidas latest offering and popular. It seems like it can be simple to operate if there were good instructions. I confess when I first started to work with computers I would try to learn how everything worked. Then Glorious PLUG and PLAY was born. Now we expect that for everything. And why not right ?? lol Thanks for your help I am very grateful Ill get back to you after my next attempt

Could it be you are a bit impatient? Maybe you should invest a bit in reading about your machine. I have a 500x300 machine with “50W” and 2 different rotaries. Made both work without problem and did not have any knowledge about these machines whatsoever before I bought it.

Thanks for your advice. Unfortunately I still find very little to read about my machine. It doesn’t even have a beard name. Just the name of the controller which I RD 6442g. I was able to get everything working again. I’ve actually had my machine over 2 years so I think I’ve been plenty patient. The user that told me that even though my controller shows it supports 4 axis, there is still no documentation that I can find saying I MUST. Use the Y axis for rotary device. My controller supports xyz and u axis. I pit originally came with only 2 drivers x and Y. It came with a motorized work table most would call. Z axes except mine came with a “dumb” motor. I just successfully installed the driver and I purchased a hybrid stepper closed loop for the z axes. Initially it was going way fast was able to set parameters to slow it down.

At any rate, that kind user in this forum was right when he told me I had to use the Y axes. My whole problem was having the software switch on saying Rotary device available. Figuring at first I could just use the U axes I could leave that on. But I can’t do wken I turned it off and reset the parameters everything worked. Not sure how you pictured me being impatient. Frusteratec yes but I wasn’t impatient. And now I’m very grateful for this forum and the kind user that bIked me out. Have a great day

1 Like

Hi yes there is. I purchased a hybrid stepper motor with driver on eBay real good price just over 80 bucks. I don’t know anything about figuring torque etc. so I shopped and found with high torque numbers. It works great. Basically you will no longer be able to use your buttons. At least I haven’t figured that out. But when the machine is on, if you have the same Ruida 6442g controller I do, when your machine is on by the arrows that mone your x and y drive you’ll see a. U/z in the center. Touch that. At the very top I believe is z ( or u) sorry brain fart. You highlight the Z. Then you use the right and left arrows to move the bed up and down. The main purpose for the stepper driving your motorized table is auto focus. On your Ruida Driscoll there are 3 locations for autofocus driver on the left. There are 3 locations for motor control on the right. I’ll be glad to give you more if you want. I had to reorder my sensor. Why? Because I’ve been doing major retiring plus ,
Making engraved black white black control panels and I removed my kill switch. When I hit auto focus something wasn’t right and the table crashed into my sensor and laser head. I couldent reach around the machine fast enough to get the switch.
I love it when someone else goes all the experimenting so I can learn from their mistakes lol. unfortunatly for me I haven’t found anyone online who had done the autofocus surgery.

One of the pain in the ass things is you gotta think motion with cnc wires and hoses. Mine came with a cable drag chain just big enough for my air hose and the red light by the laserhead. What do you do with the new 3 wire harness. Snap ties hanging it from the original gantry sucked. I indeed up getting the next sized larger plastic chain. But it still doesnt lay down right. This is after getting a softer air hose and trying different wires. The signal is very low current do you can use cat6 wire if you want. Don’t because most of that is solid not stranded, yup that helped hold it up. I discovered a heat gun made it all lay down. My heat in the shop has been low this winter remodeling. But I think when I get up to 70 I’ll be ok. Anyway I’ll be glad to help you out if you have more questions. Like with anything else with these Chinese machines I think once you figure our the flow of these things it’s not too hard. Good luck ! Mark

Justin. I wanted to thank you. You bailed my rear out. Yeah as soon. As I shut the rotary switch off r
Things started to get alive again. If not for you I think. I mighta jumped lol. Seriously the difference in the cost betwee these Chinese machines and the American machines is one main thing. Support and software. Light burn and a camera which in still working got me excited about my laser again. And this forum ( I’m not a big forum uguyiohih guy) but it’s made it worth it to get the Chinese unit. Thanks again for your help:

If I can help anyone else now that I’ve been greatly helped let me know. Thanks again. Mark

2 Likes

Sorry about the extra letters, I’m typing from my iPad. I’m tired and it’s supper easy to bump a few dozen extra letters lol

This is just a little tip about the z homing feature. I have disabled z homing in the soft wear . if it is enabled the table will rise while the x and y are moving to home and you could rip your laser head off . A lesson I learned the hard way. The z focus button will still work in lightburn.

Thank you Mark. I’m going to start researching a bit on this, I guess the first thing is to figure out what kind of motor I need. I will reach out when I get to the point of more questions. Thank you so much for your reply

Its not too difficult. But after you get everything all hooked up make sure you run the table all the way down. This way you’ll have time to shut the machine off before the table crashes into the top.
1 install motor and driver
Link to the motor and driver I purchased, Its quite substantial compared to the rest of mine

Motor and driver for Z axes []
(https://www.ebay.com/itm/US-Free-1AXIS-NEMA-23-Closed-Loop-Stepper-motor-2-8N-m-400oz-shaft-%CE%A68mm-2440/123499656210?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649)https://www.ebay.com/itm/US-Free-1AXIS-NEMA-23-Closed-Loop-Stepper-motor-2-8N-m-400oz-shaft-%CE%A68mm-2440/123499656210?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

there are 3 places for wire on the bottom left of the Ruida 6442g Controller. BTW there are other cool things you can do with the controller. As soon as I got mine I installed a 24 volt Air solenoid. It easily wires to the top left side of the controller so when you click on air or wind it works automatically. Once is set up in a project it automatically turns it self on. there is a link here for the 24 v solenoid


above is the 24 volt solonoid

The camera I got for light burn https://www.ebay.com/itm/Logitech-C615-HD-Portable-1080p-Webcam-with-Autofocus-8-0-Megapixel/121512463104?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

The autofocus required for the Z axes to function it also comes with a new laser head longer than standard
Let me know if I can help any

ttps://www.ebay.com/itm/CO2-Laser-Head-Set-Auto-Focus-Focusing-Sensor-Automatic-Up-Down-Engraver-Cutter/264169372101?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

emphasized text

Hey Mark. I am a bit confused on the units used in Machine setting in LB for Z Axis Settings.

Step Length is set to 3.938 um
Max speed 100

In the Move window in LB if I have my Distance set to 100 and Speed set to 100 then the bed will move 10mm. Any Idea on how to get that to move 10mm with a 10 instead of 100?