Ruida 6445S and Lightburn/Rotary

I have updated the firmware on my Ruida 6445S to RDLC-V26.01.13. I have installed a separate driver for it as well. How do I get Lightburn to show the U axis on the rotary setup? I can control the roller rotary via the control panel but can not get Lightburn to acknowledge the axis. I have attached a picture of my controller acknowledging the U axis.

.18 is the newest firmware I’m aware of.

Might look at this thread…

Good luck


I believe RDLC-V26.01.13 is the correct firmware for U-axis rotary engraving. In the Rotary Setup window in LightBurn, you will still need to select ‘Y’ as your rotary axis, and the controller should handle transferring commands to U.

I tried that, JTR and the head still moves to lower left of the machine bed

Are you using ‘Current Position’ as your Start From mode?

Try sending your file to your laser through LightBurn, making sure rotary mode is enabled on the controller, and starting it from there.

ok, will do and get back with you

OK, I made a test file, set it to current position and turned on rotary in LB. The rotary turned for a while then headed back home like “I don’t feel like doing this”…BAHAHA! It would not do anything until I sent the file to the laser manually. Start on the software did nothing

I just remembered to hit origin on the control panel. What does Frame Slop mean?

That means the controller thinks one of your graphics is extending beyond the bounds of the workspace- this can happen when using a rotary due to the design being stretched. Through your controller, try turning off ‘Enable Reset’ on the Y axis.

I turned off “Enable Reset” and I am still getting frame slop. When I hit enter to continue there is no change. I also sent a fresh file to the laser with the word “test” smaller

Try resetting your controller after making these changes. Make sure it homes properly- it’s possible you’ve lost position somewhere along the way.

ok I will do that

OK, it worked!!! THANK YOU!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.