Ruida 6445s - How to enable rotary with U-axis?

Ugh, I guess we jinxed your working setup to act like ours now :upside_down_face: Sorry to hear that… I’m actually not sure where to get the “default” initial firmware - but i’ll surely try and keep my eyes open!

Good thing he wasn’t ‘hot swapping’ anything :crazy_face:

My rule on firmware. Like most other things, “if it works don’t mess* with it”… bricked too many of these newfangled devices…

  • don’t actually use the word ‘mess’…

@LazerArt like a backup, keep a couple of firmware versions, if possible. I wouldn’t update without a backup if I could help it. Of course i realize you probably don’t have the original. In that case I would have attempted to locate the ‘installed’ version somewhere before the update… It’s a bit of very low cost insurance.

It’s probably out there…somewhere

Good luck.


Sorry for digging up an old chat, well not that sorry because I am. Did you find the .13 file and get things working .17 is out now too which I will be testing later today. If you search “rds 6445s lightburn firmware” your will come back to this forum where Dave has a link to his google mod page (drive) that has .13 and .16. The text file with the explanation that .13 goes to U while .16 goes to Y is also in there. Thanks Dave, if you’re reading this. I will be trying both of those as well as .17 later today. Yes it’s 2:23 AM and I’m about to close my eyes.

1 Like

Hi Greg - Would you mind sharing v. 17? Where did you get it? Any changelog? :slight_smile:
I don’t see v. 17 on the google mod page:


My source is a manufacturer in China via a friend who sells lasers. Getting any firmware out of them is like pulling teeth, no change log. Did install it today but its not on my machine so was not able to do a lot of testing. The rotary function worked fine. I was unable to upload the file here. Sorry, don’t check these pages very often.

Thats what I thought - it seems like you need contacts to get your hands on their firmware updates :frowning: I wonder why such a widely used brand, doesn’t have it easy accessable with some changelog overview - so much confusement out there.

Would you be able to send it to my email: I’d love to try it out and can (with your permission) upload it here aswell

Try this

Yup, that’s where I downloaded v.16 … But Greg has a spanking new v.17 :slight_smile:

From what I read, Greg wants .13 to get the U axis working on the rotary? doesn’t matter if he as .17 or .19 or whatever, just load in .13.

Greg already confirmed that the rotary is working with v.17 - so i’d surely be interested in testing that out

What’s the behaviour of .17 — rotary on the U-axis (fingers crossed) or (still, like .16) on the Y-axis?

Has anyone tried .22 found here
I was on v15.01.19 then found v15.01.30 with u axis option so I upgraded to this version with still no sucess
So I have gone back to a toggle switch controlling the ground wire to the 2 drivers running on y axis

You’ve run into the “classic” confusement about these controllers :slight_smile: This topic is about the S-version and you’re talking about the G-version - firmware’wise very different.

Both though with a thing in common - big confusement about how to get version upgrades and what they actually changed :sweat_smile:

Sorry, I don’t check in here very often and I’ve also been busy with my daughters wedding. Apparently I don’t know how to upload the file type .upd here. Other than that, I’m guessing there is some confusion in that the last time I checked, LightBurn was not setup to specify U or Y. I am making the change in RDWorks and then using it in LightBurn. I look forward to a time when LightBurn can both upgrade firmware as well as make the axis selection. I did email you the file a few moments ago and don’t see a reason why you couldn’t post it if you are able.

I believe the default of .17 still goes to the Y-axis. I’m using RDWorks to change that selection and it seems to stay at the new selection when using LightBurn. I don’t have the S controller myself at this point so I only have about 20 minutes of play time so far.

I’ve tried .22, but this discussion is primarily regarding the S version of the board vs the G. But since we’re here… I’ve also tried .27, .28, .29, .30 and .31. Version 22 defaults to U axis and if I remember correctly version 30 is the first one where you get to choose Y or U but you need to make that selection in RDWorks until such time as LightBurn adds that feature. I am currently running 31 without any issues but I’m an experimenter, not a heavy user.

I been in rdworks and was unable to find any setting to change to u axis.
Do you remember where the setting is?
Where can I get .31
Thanks A


On the right side of the screen under the tab and then . A ways down you will find the rotary settings. I have 31 at home but I’ll take a quick look online to see if I can find it. 30 works as well and I know that’s online. 31 I got from a manufacturer in China.
Version 30 is here, it works. RDC 6445 firmware - Google Drive
I can email 31 or someone can tell me how I can post it here when it’s not an allowed file type or how to contact Dave to get it onto his google drive.

Hi Greg
just checked there and no setting for U axis

thanks Anthony

The primary difference between the two menus seemed to be ‘Enable Rotating’. This may allow access to the rest of the menu for the U axis.