Ruida 6445s - How to enable rotary with U-axis?

Have anyone managed to get a rotary working with the U-axis on a Ruida 6445S controller?

Researching it appears to be a (in)famous topic - with no real bulletproof guidance or solution…
A lot of people including myself mistakenly bought the controller thinking it was the 6445G (which seemingly is “easier” getting to work).

I managed to find one topic saying “upgrading the firmware to RDC6445S-V26.01.16” worked:

I did that myself, however in the rotary settings I can still only choose Y-axis for the rotary. (= no apparent changes to the issue)

I’m running newest versions of Lightburn (v1.1.03) + RDWorks (.60)

Yup

Thats the only option for us folks using Ruida. The U axis is useless unless you are using it for a shuttle conveyor. I have tried many times to get this to work, with absolutely no luck.

This was a year ago, has some links from ‘them that know’… :crazy_face:

Good luck

:smile_cat:

“Yup” → As in, you have a working Rotary wired up as the U-axis? :slight_smile:

Or do you simply plug-in your rotary to the Y-axis slot on the controller every time you need to use your rotary?

Thanks, it seems to be a real and disturbing struggle… :sleepy:
The topic you refered to is for the G version of the controller - which sadly is an entire other thing than the S version → firmware’wise atleast

I plug mine into the Y.

The machine is useless for ‘non rotary’ use with the rotary sitting in the middle of the machines workspace and it’s taller than my lenses are long.

Might be nice to just plug it in, but I haven’t seen a good fix yet…

:smile_cat:

There are some firmware out there that’s supposed to work… I have the 6442G, so it isn’t on the top of my list. Seems I’ve seen some using the Z axes…

:smile_cat:

May I ask what your workflow is? What happens when you turn on the controller - won’t it mess with the default attempt to do a homing sequence?

Really astounished that this seems to have been an on-going topic for years

The RDC6445S-V26.01.16 firmware I mention in my original post, is one of those mentioned “fixes” - but I dont see any difference at all.

I also tried plugging my rotary into the Z-axis instead of U-axis, but in the rotary settings the option to pick Z-axis is disabled (greyed out)

My habit is to power up the machine and let it home, and ‘hot’ unplug the Y, with a ‘hot’ plugin of my rotary… Use it almost weekly and have about 7 months of doing it that way.

It didn’t seem to make any difference when I power cycled it and had to hammer the ‘esc’ key. The hardware looked pretty tough, so I started and have been just doing ‘hot’ swaps.


You can ‘esc’ out of the boot or reset…


I don’t know of a way to enable it at the controller

There is an option in ‘edit → device settings’ for enabling the Z axes, but I don’t remember it showing up in the rotary menu…


I cringe whenever I power equipment up, that’s when it always fails.

:smile_cat:

I have 6445S and use U axis for rotary with no issues.

I bought a 3rd Axis driver and installed it on the U axis, added a port into the machine to plug the Rotary into, and also added a switch to turn it on/off if not using it.
All I have to do is set rotary -yes on the controller (or via LB) send the file from LB to the controller and hit run from the controller. It just runs the rotary from the U axis driver because Rotary is on. I can have all the settings for the rotary set on the U axis, and no need to keep changing them by plugging it in the Y axis.

How does it know to use the U axes?

My rotary menu dose not have a U axes option.

:smile_cat:

Just because you set rotary to Yes, I assume.

But it just works from the U axis when plugged in and rotary is set to Yes. without changing anything else (run from the console, not LB)

Ill do quick Video tomorrow when at work to show

Do you have separate control of the Y axes while using the rotary?

:smile_cat:

Please do - would be very interesting to see your setup @ approach.

I haven’t tried what you’re doing:
Running it directly from the controller vs. running the job through Lightburn. I can move the rotary via the U-axis +/- on the controller itself, so could make sense that it would perhaps work.

Although would be great if it could just be run through Lightburn. But I guess right now, any solution that can work via the U-axis would be cool

Awww yeaaa, “hot swaps” was the thing I wanted to avoid in the first place buying a controller which actually had place for all axis. And my wiring is so flimsy, so would really want to avoid pulling the plug in and out :sweat_smile:

I’m pretty sure the answer is yes, everything except that U-axis would work intact from Lightburn - just the job itself which would use X + U-axis directly from the controller.

But let’s see what Neil shows us :slight_smile:

1 Like

What A Nightmare!!! Went to do the video this morning

I upgraded the firmware a few months ago, have not used the rotary since and now it doesn’t want to work like it did before…it wants to use the Y Axis…I can still turn the Rotary manually using the U axis controlls but when running the job, it tries to move the Y axis (very slowely) instead of the U like it did before…

Does anyone have the old Firmware still on their machine? 26.01.13? or have a copy of it please? (NOT 26.01.16) this latest update seems to make it want to use the Y instead of U for rotary, and I cannot find anything in the settings to revert this…

and you worry about a ‘hot swap’.?

:smile_cat:

No reason to push my luck :sweat_smile: