Ruida 644XG red lights on and one blinking

This is a 60W red and black Chinese laser.
The main power supply quit.
I could not find a proper replacement, so I replaced this power supply with a 24V and another 5V.
Both are supplying the correct voltage.
When I turn the machine on, this error message shows up on the display “Machine Protected press Esc”.
On the CN5 connector 5 the red light is constantly on.
On the CC5 connector 4 the red light is blinking.
Next to the AxisZ area on the controller, connector 9, the red light is continuously on.
I do not know whether these lights are supposed to be on or not.
I have checked and rechecked my power supply wiring and I can’t find where I reconnected anything improperly.
Does anyone have any idea what I should check to resolve this problem?

Note, the lights on the Ruida controller are numbered (1 - 15) and indicate assigned status for the following:

CN5 - 5 doesn’t have a light assigned to it.

Jeff, thank you for your prompt reply.
Lightburn identifies the Ruida as a 644XG, not a 6445G.
I took some pictures but I can’t figure out how to upload them to this post. If you can tell me how to do that I will upload them for more clarity.

Otherwise, I can email them to you.
My email is
Cellphone 281-740-9929.

I also just noticed that the green light does not come on the chiller either. It is, however circulating water.

Thank you for your help.

Hi Ken, I have updated your access so you should be able to post pictures now. You can use your system Copy & Paste features to post an image or use the ‘Upload’ button while in post edit mode.


Thanks Jeff.
I have uploaded the pictures.

You have either a limit switch (CN3-4,5)(CN4-2,3,4,5) door switch (CN2-3) or water protection (CN5-4) halting your machine. Also, the way your controller is wired for CN5 (Laser 1) is not how Ruida suggests for a glass tube. I am not saying it won’t work using PWM (CN5-3) to the Laser PSU (because I do not know). I’m only referencing the Ruida documentation and the way my machine is wired. Ruida suggests, for a glass tube, using L-AN1 for laser power control.

From your photos it looks like you are getting a water protection fault. Looking at your cooler, 31 degrees seems quite high. Is this a chiller or a passive cooler?

It is a CW-3000 Industrial Chiller. I guess that is a passive cooler.
I think the water controller switch(?) the one that goes inline with the water input is a normally open switch. I shorted it out with the chiller running thinking that would fool the controller and tell it that water was flowing in case that switch was defective. The only thing that did was cause the lower LED light on the controller to go out. Still got the same error message. I put ice in the chiller and cooled it down to 25 but that didn’t change anything either. The gantry’s function as well as the frame button on the top readout. The normal green light on the chiller is still not coming on. Do you know of any way to override the warning about the water flow just to see if that is the problem? Also, the controller has 15 LEDs on it. I wonder if there is a problem manual that might describe the meaning of those lights if they come on and maybe some possible remedies. The frustration with this thing has just about got me to the point of going to the liquor store!
I really appreciate your help with this.

I will check the limit switches. Are the limit switches that you mention normally open or normally closed? When I bought this thing, I was told that the limit switches did not work. I was also told that I probably would never need them.
I am so new at this that I really do not know exactly what the function of the limit switches are except to limit the gantry travel in case it tries to go too far.

I will also check pin 4 WP1 to see if it is enabled. I’m thinking that when I wired the new power supply, maybe I somehow caused the 24v not to be getting to this pin.

A problem is there are a lot of ways to wire these things.

I’m not sure why someone would have told you the limit switches are not needed. The system needs to home to be able to know where it is. Not sure anything can work right without homing first.

My water protection is wired directly to my laser power supply, I don’t use the WP1 or WP2 pin on the controller. My 6445G has water protection disabled. In my setup the laser power supply will signal the controller there is a water fault. So you might check that the WP pin on the power supply is set properly.

Can you tell me where you got the source defining the lights on the controller? I have googled everything I can think of and have not found that information.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.