Ruida and lightburn not able to do dithering

Hi I have great success with diode and k40 but recently upgraded to 50w with ruida controller and that’s it can’t engrave anything.
I can do greyscale no problem but when dithering laser not firing at lighter spots.
All mirrors and lens clean and set 100%
I tried compound lens, 1.5 2.5 and same results
I was playing with min and max power on controller and in lightburn no changes simply none of dithering is working. Can’t achieve any shading whatsoever
I’m 99% sure that is something to do with ruida more than lightburn.
New tube and psu so no problem there I think
Does anyone had similar problems please share or if anyone got any ideas what can be a problem
Thank you in advance

Exactly what doesnt work? Without settings you try to do it is a bit difficult to say what doesnt work really. Not firing at lighter spots? I have a “50W” with Ruida that has a diode as well and settings for both laser heads are very different.

First 2 photos are made with k40 and LX4 Controller
Last one with 50w ruida controller
I tried all sorts of dpi from 200dpi to 600dpi
Min power on machine 1 5 10 and few in between
Max power 30 50 99
Min power in lightburn 0 2.5 5
Max same as above from 12 to 40
All this settings in different combination

When I’m doing test fire with max 10 laser is firing no problem

Speed from 140 180 200 250

It doesn’t matter if I’m doing jarvis or stucki dithering or even pass through pre edited photos (dithered or newsprint) same poor quality only effects and power variations are noticed in greyscale

you have too much power for this plywood, you are blasting away the top layer

I can deal with the power but it won’t improve nothing in the areas untouched by laser and that’s the problem I try to work out. I simply take a photos of most obvious overburdened engravings to point out that lack of power is not causing it

That’s another for k40 so I’m not a total nob and I have an idea how to play with speed power and editing

Try to defocus on your big laser then?

Your 50W has like 50% more power than your K40,
more power takes more effort to find the best settings.

that picture is also much bigger than your tests on the other picture

This is the first try with Ruida controller, no optimizing in any way, just resized it to 70mm wide, burned with my Diode laser.
The software and the controller are not the problem. You need to find a way to make your burn darker on the big laser.

Click the “Reset to Defaults” button in the cut layer, and try those settings with no change at all, except lowering both the Min and Max Power to 10%. Then start adjusting one thing at a time from there.

1 Like

What my understanding is that my controller on K40 can do 1024 shades of grey and ruida only 256 but I might be wrong

Your understanding is incorrect. A Ruida has 14 bit PWM resolution, or 16,384 different power levels. Higher wattage CO2 lasers tend to vaporize material before it has much chance to darken. Diode lasers burn quite slowly by comparison, so the material darkens much more.

It’s possible to use other means to darken the burn:

But my problem is not with darker areas or overpowering but with light spots and lack of power variations.

In GRBL I have $30 1000 what’s the equivalent of that in Lightburn and Ruida?

There is no equivalent - The range is fixed in the DSP controller.

Your problem is that you have a completely different machine to learn, and are expecting your existing knowledge to apply. :slight_smile: It will to a degree, but there will be quite a few differences as well.

When you turn the power up high enough to make a dark impression with the smallest dots, you may find the darker areas of the image burned too much or too deep. Starting with the default settings and playing with a single parameter at a time to see how it affects the result will help you figure out how the new machine differs from your previous one.

1 Like

I have diode dialed k40 dialed and it looks like lots of coffee and sleepless nights on front of me.
But on serious note.
When I hit it with high power so dark spots are burnt too much why I don’t have a single mark in grey areas it should be at least some marks as power increase for them as well and they remain untouched.

Any number of reasons, most likely you are going too fast and/or have the DPI set too high to fire a dot long enough to make a mark. The dark areas are a continuous line, not a series of individual dots. If you make the DPI too high, you could be missing dots entirely, or they could actually be there and just not be visible yet because again, vaporizing vs burning. You can defocus a little to help this, but it also fattens the beam.

I was going with speed ranges 100 - 250, dpi using compound lens 202 254 318 362
I will try to be off a bit as I was like 100% on spot with focus

To show what’s possible, this was done tonight for my girlfriend using LightBurn only, and is about 45mm around:

It’s about twice as large on screen as it is in real life.

It was engraved on basswood using a 60w Thunder Laser (Nova 24), Ruida controller, 350mm/sec, 360 DPI, 17% power, 0.7 gamma, +4 contrast, -4 brightness.


I have a 50W ruida laser when I do photo’s they come out great with a setting of 100mms and a power of 20 max and 0 min I get really good results with these setting’s I hope this help’s

1 Like

I have the exact same problem for last 3 weeks tested tirelessly hundreds of dollars in material wasted only successful on greyscale, I have to constantly reset my controller as it does weird stuff every other time machine is fairly new and works good on rdworks. Trying to figure this out. People on Facebook being trying to help me but they are stumped also.