Ruida controller stuck on 10000mm for x and y axis

Has anyone fixed it?
I am facing the same isue here!

1 Like

Not yet. Jeff Posted possible solution above but I cannot find “manufacture settings” or “user settings” on my control pad. Do you have these options on your control pad? I have Ruida RDC6442G-B (ec) controller. I’ve found user parameters in user manual but no info on how to access these from key pad.

Also, purchased my machine from OM Tech. They are supposed to get back to me today with possible solution.

I am furious. I have chinese ferari Aeon Mira 9, and today suddenly bams, you got x10000, y10000 , u 10000 and o top of that my z is not working if i try to move bed up. reading everywhere. i have heard there is something to do wtith using RD works.

Ou yeah, i ended up doing factory reset, and cant undo that!

1 Like

those settings are in RDworks or Lightburn not on the machine
both programs can read the machine settings and write them back.

Still no response about how you have set your origin, create a new machine profile and set the origin to left back and see if that is any better?

Yeah my homing pos is right back, its wierd but i use job origin on left back, its just few extra steps for controller, but it worked. Today something hapened and

  1. Cannot switch off blower, runs all the time
  2. x10000 y10000 on every time i switch off machine,
  3. z is not going UP, only down. shows that limit swich is activated!

well factory reset is was not very useful,
now you have to load a back up of the settings for your machine,
if you have some of the settings that used to work, would be good.

@bcl do you have your origin set like this?


I did originally but tried front left with no change. I’ll check this afternoon. Regarding the user parameters and solution Jeff posted… Should I be using rdworks now? Because I don’t see the user parameters and manufacturing settings that Jeff posted in lightburn. He sent me Ruida manual to find parameters so I assumed the settings to change were on controller keypad. Is Ruida and RDworks the same company?
Thanks for your patience!

I did receive original settings from OM Tech yesterday. I deleted my controller using Lightburn. Started from scratch… added controller, reset default settings using HF8888 password, entered all original settings, and write to controller. My x and y axis went to x:300 and y:100. Controller actually moved using keypad and through lightburn correctly. I clicked home through lightburn and it went to back left corner and made squeaking noise but not banging like it was. I though I was getting there. However, I turned machine off for an hour and when I started it back up,x and y were back to 10000mm and back to square one.

You should reach out to the nice folks at Aeon for the factory settings that came with this system. They should be able to tell you exactly the settings applied when this laser was built.

Have you tried that?

I would share this information with the folks at OMTech, as this could be a failing controller, needing to be replaced. You should be able to change controller settings, write those changes to the controller and have them stick.

If you are not able to successfully navigate your way through the winding roads of the controller’s menus, then you can make the changes through RDWorks. ← (that’s a direct link to the download from Ruida ACS)


Manufacturer / Vendor Settings can be found:



Be sure to READ the controller first. If you make any changes here, be sure to WRITE to the controller when you are done. (I highly recommend you back up your setting before you make any changes).


The user parameters can be found in the upper right corner under the user tab. You will then find the controller’s Home Parameters there when you choose the auxiliary radio button. Again, be sure you first READ the controller, then write to the controller after you make any changes that you want saved:


That’s unfortunate. I agree with what @Rick stated. Also, I found a picture of the 6442 board and it doesn’t appear to have a battery for the purpose of storing settings. But I cannot confirm this:


I will try using RDworks tonight and I’ll let you know how it goes.
Thank you!!

No Luck! I went through using RDworks and Lightburn again. It seems to read correct settings from controller and writes successfully but still displays 10000mm for x and y.

Please Help
Following all instruction i still have issue when machine goes to x,y 10000 after reset or turning off machine!
HOW do i save permanently user and vendor parameters!

Good question!

You write them to the controller. Here is a baseline test:

Through the Ruida HMI (that’s the control panel on your machine), change a setting, write the setting. If you find that this setting has reverted back after power cycling the controller, then you either did something wrong or perhaps your controller is corrupt.

What version of firmware is the controller? Have you considered upgrading your controller’s firmware?

I think you have to read the settings first then make your change then write back

I have done the following using Lightburn and RDworks…

Deleted device(controller) added new device. Read settings, changed and write to controller. When I read again my new settings are correct. X and y show whatever I changed them too when I read again from controller but x and y still show 10000mm on key pad of machine. Controller may have lost firmware, do you know how I would get firmware and reload to controller? I’ve contacted OM Tech but haven’t received response in a few days.