Ruida Max/Min power issue

Building a new laser and just installed/configured a Ruida 6432G controller. Always had a Trocen before so this is a bit new to me. Worked out most of the kinks but have one that I can’t figure out. Trying to make a test cut. No matter what I set Min/Max power to it always outputs at minimum value. Min power does change to output level… but Max seems to do nothing… Is this normal?

What speed are you trying to run at? Below Ruida’s “start speed” (which is typically 10mm/s by default) the controller defaults to the min setting.

Max Power: The power level to run the laser at

Min Power: The power value used for corners, or when moving at low speed (DSP only)

Note: On GCode based systems, you only get “Max Power” - the power the laser will use when running at the chosen speed. On DSP systems, you have the additional ‘Min Power’ setting, which is used when traveling at low speed, or when cornering.

If you are cutting at a low overall speed (for example, 10 to 20 mm/sec on a CO2 machine) the laser might only ever use the ‘Min Power’ setting, so it is recommended when cutting at very slow speeds to set these both the same. If you are doing ‘surface marking’ you ideally want Min Power to be just above the firing threshold of the laser, so corners still produce a burn, but without scorching. - Cut Settings Basics - LightBurn Software Documentation

On a Ruida controller (and most DSPs) the controller starts using ‘Min Power’, and as the speed passes a setting called the Start Speed (or corner speed), it ramps up toward Max Power. If your cut never goes faster than that Start Speed setting, it only uses the Min Power, not the max. The default for this on a Ruida controller is 10mm/sec, so that’s the most likely reason you’re not getting power. Configuring a Ruida - LightBurn Software Documentation

1 Like

Thank you… Weirdly my Trocen never acted this way. The speed was the correct diagnosis. Once I sped the job up it changed to the Max power. Also, thank you for the setup doc. It helped me with a few things I still hadn’t resolved and after over a year of using Lightburn I never knew it had some of these settings.

1 Like