Ruida rotary settings have no effect - part 2

I wanted to add a follow up to this topic that I started a few months ago, but it was automatically closed so I’ll just leave a note here in case anyone else has an issue like this in the future.

It turns out that we were hitting some kind of max limit on the pulse rate. Past a certain point any changes to the um/pulse setting didn’t make any difference. Our setup is probably a bit odd since we have a geared stepper motor on our rotary and that requires a higher step rate than most. This setup had worked fine previously with 2 different types of controller, so we didn’t expect that it would be an issue with this one. We ended up reducing the microstepping on the stepper driver from 1/16 to 1. This apparently put it back into a range that the controller could handle, and we were able to adjust the settings more or less as expected.

That’s good to know - do you remember what the number was that you were trying to use?

I’ll try to find the numbers we were using.