Ruida rotary settings have no effect

I’ve been trying to set up a roller-type rotary for our laser cutters that use Ruida controllers. One is an RDC6442G running 8.00.58 and the other is RDC6442S running 8.01.56. I’ve tried them both with the rotary connected in place of the Y-axis. In both cases it seems that the rotary settings don’t do anything. No matter what value I put in for Diameter and Steps per revolution the distance that the rollers travel doesn’t change. It moves the same amount as it does with the rotary disabled. The only thing that I’ve found to get the rotary to move the correct distance is to disable rotary mode and change the distance per step setting for the Y axis.

We’re using LightBurn Beta 0.9.04.

Anyone know what the issue might be? These machines are in use in a makerspace, so we would much prefer for our members to be able to use the rotary just by enabling rotary mode instead of having to change the Y-axis settings.

1 Like

Are the machines Thunder Laser machines, by chance?

Nope. We have a Rabbit machine that we installed the Ruida controller in after the original failed and another machine that we bought directly from China from a manufacturer that I can’t recall at the moment.

How old are the controllers? I know there are models out there where they don’t actually have the “Circle Pulse” setting exposed. Is it settable through RDWorks?

Is there a way to tell how old they are? The controller in the Rabbit was purchased about 3 months ago, and we got the other machine a little over a year ago.

I seem to be able to change the settings with LightBurn just fine and read them back after restarting both the machine and LightBurn. I can also change them in the ‘user’ tab in RDWorks.

When you change the Circle Pulse or Diameter setting in RDWorks, does it affect the rotary? It’s possible that the controller firmware is different than what I’ve seen, and has a slightly different command set. The reason I asked if they were Thunder Laser machines is that those are different, and I’ve just added support for that variant.

I haven’t really tested in RDWorks yet, I’ll give that a shot.

I tried it out in RDWorks 8.01.24 wit the same results. No matter what numbers I enter for the steps/revolution or diameter the rotary moves the same amount. I’ll bust out the oscilloscope when I get some time to confirm, but it seems like the settings are having no effect on the step output.

I’ve been thinking about workarounds for this issue, and I suppose we could change the step settings for the y-axis to get the scaling right. I don’t really want to do that, though. These machines are in use at a makerspace, so most of the users are in the process of learning how to use them. Having a simple on/off switch is much better for our purposes than having users try to modify axis step settings.

Would it be possible to get an alternative rotary mode setting in LightBurn that just modifies the Y-axis settings instead of the rotary settings? That would solve this issue, and would also let you adjust the acceleration, which currently isn’t possible with the stock settings. It seems like this would be a pretty simple addition; I would add it myself if the software was open source. :wink:

Someone else recently requested this, and there are other controllers that don’t support the rotary step count, so it will likely happen before long. You should create a suggestion here so it doesn’t get lost in the shuffle: http://lightburn.fider.io

4 Likes

Done: https://lightburn.fider.io/posts/654/alternate-rotary-setting-for-y-axis

Let me know if I can help in any way. I’m more than happy to help with testing if you need it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.