Ruida to Mac Via Ethernet with Adapter

Hi guys, thanks for such a great resource. Unfortunately I’ve not been able to find a solution to my problem. I tried the USB path with zero luck so now looking at the ethernet option.

Lightburn is not recognising the device.

I added the device manually as per the instructions from the ethernet post.
I’m running a Ruida to a Macbook Air via Ethernet and an Apple ethernet adapter.
Running through the router isn’t an option as it’s at the other end of the house. Unless I buy another, which I’d rather avoid if possible.
I’ve added a compatible IP address to the Ruida and the adapter inline with the IP of my computer as per advice from previous posts. I’ve also added the same gateway code to the Ruida and adapter.
I’m not getting a ping.
Out of curiosity I tried to add the same IP to the adapter as the Ruida and it recognised that IP was already in use and thus wouldn’t allow it. I presume this is a good sign that the Ruida IP is being recognised somewhere.
I’ve turned everything off and on again MANY times.

I’ve just read about using a cross over cable. I’m using the ethernet cable that came with the machine so guessing it’s not a crossover. If anyone thinks this may be the problem let me know and I’ll pick one up tomorrow.

I’m a bit of a techno spaz but I’ve read and tried as much as I dare in fear really buggering something up, beside the crossover cable…

Looking forward to your help.

If it’s a modern MacBook / network adapter, it should figure out that the connection is direct and emulate the crossover for you, but there’s no harm in using a crossover cable directly.

I’m not sure if this will help or not, but these are the standard instructions for connecting with Ethernet:

There might be something in there that you’ve missed, so start with those.

Thanks Oz. Yeah followed those directions in addition to further actions from complimentary posts.

The adapter is new but USB 2 into 2014/15 MacBook Air. Would this have the crossover recognition?

The Ruida is also showing Lan ON.
I’m getting a ping to the adapter but not the Ruida.
I’m guessing the fact I’m not getting a ping even though the system recognises the Ruida IP on some level is the key issue here.

So any further suggestions are welcome.

So after trying the crossover cable with no joy I came across another forum discussing a similar but different issue. The suggestions was made to turn off wifi on the macbook as that may be overriding the ethernet connection.

Switching off the wifi worked and connection was established. When wifi is switched back on I lose connection. I can still control the Ruida while offline which is strange because I’m still using the trial and have not requested offline operation. I’m only just getting this thing fired up so time will tell how this pans out.

In my search I also found a post on Lasergods about making the Ruida wireless;
I wish I had found this first as I would have spent the $50 on another wireless router instead off the USB Ethernet adapter I needed for the direct ethernet connection. Oh well. Live and learn.

I’ll post below my solution summary.

Before proceeding consider making the Ruida wireless as per this post;
For the cost of a USB to Ethernet adapter you may be able to purchase a wireless router and have a wireless option.

I hope that helps.

LightBurn doesn’t require an internet connection for anything other than activating the license. You can use LightBurn without an internet connection as long as the license is activated already.

1 Like

Ah cool. Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.