Saving/Fetching LB Project Files from Google Drive

I having been using LB for several years and in the past saved my projects to my iCloud account. I use an iMac for design and a Macbook to control the laser. I intermittently have issues with NOT being able to connect to the laser via usb. Due to this I am considering using an older i7 desktop using ubuntu 18.04 to control laser via usb rather than install the LB Bridge.

As a test, I booted an ubuntu 18.04 usb stick and installed Lightburn run version on the “try ubuntu before installing” startup option on the i7. I added my Google drive account to Online accounts and was able to access all my Google drive project files under ubuntu File Manager just fine.

When i open LB and go to File Open, I can NOT seem to see the Google drive files. Being a ubuntu newb, I don’t know if this is because I did not do an actual install of ubuntu or if there is some option or preference I need to activate in ubuntu or is it a Linux LB limitation?

Any tips, suggestions on how to have Google drive be accessible from within LB would be appreciated.



That would be a remote drive that has an http type path. If you can figure out how to make it look like one of your computer files it would probably work.

I’ve never seen any option to use google drive via Lightburn. I run Ubuntu 20.something…

You iCloud may work differently with Apple stuff, like the Mac.

I wouldn’t give up until you hear from one of the other people that might use this option.


Thanks Jack, I got a reply from Support to switch Load/Save File Dialogs from Internal to External but only options available of Internal or Bypass. I tried Bypass and still didn’t see Google drive inside Lightburn.

I had another thought, to double click the LB project files (*.lbrn) from File Manager and if Default Application is set as Lightburn it should open. However, I could not find LB as an application in the ubuntu Settings pages. Any idea why its not listed and/or how I can add it from command line?

On windows i use google drive v58.0.3.0 set to mirror locally, this gives me a virtual drive letter for the google drive files. All my computers are set the same to mirror locally not stream. This is on windows havent used on linux to know how to do it on there but it is possible on windows. My guess is that with the live version of ubuntu your not saving the files locally just streaming them.
This is old but might help.

the link below is a detailed description of how you can mount Google Drive(among others) in your local file system.
Once mounted it is visible as a local folder and you can access it from Lightburn. This will work in Ubuntu. I am using Ubuntu 22.04 but it should work in Ubuntu 18.04. I think it is preferable to use a more recent version of Ubuntu.

Thanks all for your suggestions. My issue is not a failure to map my Google drive on ubuntu. I did so successfully in both 18 and 22. I can see my google drive files just fine in File Manager and, in fact, I can open text files in my google drive via Libre Office Writer Open File dialog and edit them.

The issue is when I open the LB File Open, the dialog box has no entries for Other Locations or Network, so I cannot point LB to the ubuntu mounted Goggle drive. I tried to explicitly write the entire google drive path and filename in the LB filename box but it seems to ignore everything up to the filename because it throws an error dialog box stating it can’t find xxx.lbrn; ie drops all the share name info prefixing the filename.

I thought this might be due to the fact that I activated LB as a trial on ubuntu. I thought possibly this feature was only available on a fully licensed LB instance. To test this, I removed a license from my account and used the available license slot to activate the ubuntu instance of LB. I then closed LB on ubuntu and re-opened it and still in the Open File dialog there was no ability to access Other Locations or Network shares mounted on ubuntu.

My guess is the developer who created the LB linux run instance, either forgot or was unable to include Other Locations when they packaged LB up for ubuntu. Can this please be escalated to someone at LB who can confirm this?

I have invested over 20 hours in researching this and trying different installs, etc. I switched to ubuntu because it was the “supported” version for LB, first tried 18.04 because Oz said it was preferred version somewhere on this site , so I then switched today to 22.04 as suggested by Peter. Still no luck!

Can someone who has Google drive working on please explain how they are using LB to open files on Network shares in ubuntu? Should I download the 7Z LB linux version and try installing it?

Thanks, all.

Hi John, sadly I must agree with you. The Gnome Google Drive client(accessible from Settings) works very well but I can find no way to link the Google drive to a local folder, which is what we need for Lightburn access.

Both Rclone and Ocamlfuse work and allow one to create symbolic links to local folders. But they are painfully slow to the point that it is nearly unworkable in Lightburn.

Right now I think the only workable solution is to use the Gnome Google Drive client(standard in Ubuntu) in the File Manager to copy files from Google Drive to a local folder. There you can work with them in Lightburn in the normal way. When you have finished you can copy the changed files back to your Google Drive. I know this is not ideal and it is not what you want but it does work well.

I right-click the file on google drive and use the download option…


Here is the problem, see the screen capture below. I have mounted my Google Drive from Settings in Ubuntu 22.04. All my files are visible and accessible from my file manager (pcmanfm), Okular, Inkscape and Image Viewer(as examples). However Lightburn gives the message shown below. It is using the mangled, untranslated file name(found in /run/user/1000/gvfs) and thus cannot recognize the format. It needs to perform the translation performed by the other Ubuntu/Gnome/KDE apps.

Jack when I right click on the google drive lb project file, the drop down does not show an option for Download. It does have copy, paste or Move to. Can you clarify?

Also, I moved a project file to my desktop from google drive. Tried to open two ways, one by right clicking and choosing LightBurn as the application, second from LB Open file dialog. Both methods throw an LB Open Dialog saying it can’t find the file, even though it showed it in the file dialog box of files.

Furthermore, I have tried to access Google drive to open text files with several built-in programs like Libre Office Writer or Text Editor and they open fine. Although in Text Editor the file name is the “google file name”(GFN), as in Peter’s example. I found a link mentioning a cmd line gio program that translates GFN’s to a human readable form. However, other apps like Visual Code’s Open File Dialog behaves the same as LB.

I also installed rclone and mounted gdrive to my Home dir, LB see files in Open File dialog and as Jack said are a little slow.

My conclusion is that this is probably due to the Open File dialog code used by the different apps.

I have tried to send an email with screen shots to support but it fails due size limits on Support email server. Anyone know mail limit size so I can break up my zip files into several smaller messages that it will accept.


I uploaded a .lbrn2 file to my google drive.

When I right click on it the bottom entry is delete, the next one up is download.

Can’t take a screenshot, as it looses ‘focus’ and the drop down on the google drive goes away.

Google has added an obfuscation layer… :crazy_face:



Figured out what was going on, you went to google drive inside a browser, I went to the mapped drive on ubuntu. The right click options are different in them.

Thanks for all the suggestions on How to Mount Google drive on Linux. I have been able to do so with several of the suggested methods. The problem is the LightBurn Open File Dialogue box does NOT show me the mounted Google Drive in the left hand pane of the dialog box as it does on Mac and presumably the Windows version of LightBurn.

I was told to add this a a Feature request, which I have done. Can you please add support for this by voting for it?


1 Like

The first one on this list says it will host files locally but its not free.

I was told to add this a a Feature request, which I have done. Can you please add support for this by voting for it?

I have added my support.

I have found out a few things since last post.

  1. Google Drive is Mounted in Ubuntu @ /run/user/user id/gvfs .
  2. Samba Network Shares also mounted there.
  3. USB drive mounted files also Not Found via LB File Open Dialog in Ubuntu. Why?
  4. When accessing LB project Files via any of the mounted locations above and Right Clicking all fail to be found. Understand Google Drive files since naming convention is non-standard but the others seem like a bug.
  5. Using Open File Dialog and Navigating down the Directory tree to the gvfs mount point, and choosing a LB project file LB throws a File Not Found message box.

Any thoughts? I think there this is a bug in Linux implementation of the Open File dialog.

The file dialogs are provided by Qt (the framework used by LightBurn) or the OS.

If you go to Edit > Settings, under the ‘File Settings’ tab, can you try changing to use this setting:

If you do that, are the network or other drives available?

I have done that and mounted external and flash drives are available, but no network drives.

This is what my file manager shows

It shows that my Google drive is mounted, though it is not visible to Lightburn


If I switch the File Settings, the behavior is the same; i.e., I can open LB, click on FIle Open and walk down the Directory tree to choose a project file and it opens the project.

However, if I use the File Manager, either Nautilus or PCManFam, and walk down the Directory tree to the same file; I get a File Not Found error dialogue box. See below:

Here is my Settings screen:


Please look closely at the File Not Found error box; two different delimiters are used at the beginning and end of the Fully qualified filename string; a " and ’ '; a quote and two single quotes separated by a space. Is that what you intended to display?