Scanning offset [BUG]


i found a bug in the scanning offset feature in 1.1.04
Below you see image where scanning offset should move the start of the line by the set scanning offset but it wont.

It doesnt work for filled objects or photoengraving. This has worked earlier. Im using lightburn to save the work into gcode and i open it up in a separate program. The preview shows the same issue in the output.

This will ruin my engravings because the offset @ 10m/min feed is something like 1mm every other line. so its bad.

Can you check and please fix this asap! Or let me know if you can get it working in some way so i can try it out.

Its related to flood fill

if flood fill is disabled, scanning offset works

You don’t have an entry for 10mm/m.?

On the Ruida, if the speed you are running is not exactly what is listed in the offset, it will not apply any offset…

Flood fill has some idiosyncrasies in itself with how it operates…

10,000mm/m is over 160mm/s and 15,000mm/s is 250mm/m. Didn’t think a 3018 would go that fast…

Both of us have ‘speed’ limits set within the controller, mine are set in the at 800. If so, it will not exceed that value.

Screenshot from 2022-06-04 05-40-39

1mm backlash seems rather large…

Good luck


i have a custom built ballscrew driven CNC and it goes up to 20m/min = 20000mm/min when laser engraving (raster).
I dont use flood fill but somehow it was enabled (maybe by mistake) and it stopped working. When i disabled flood fill, it started working normally.

below 5000mm/min there is non or small scanning offset and thats why its not defined in the list.

and there is not a backlash in my machine, backlash of mechanical means. This offset comes from laser on/off delay. If it would be backlash, i would fix it in controllers sw backlash settings. But as said this is more of an timing / syncing thing which cannot be 100% perfect as i’ve tested. Near perfect but not perfect.

Unless it’s seized there is some form of backlash. Mechanical parts require clearance to operate and that equals backlash. It may be so small it’s not worth dealing with, but it is nevertheless present.

As far as I knew, scanning offset is backlash. I use that for my Ruida to adjust the ‘overhang’…

I understand what you mean shift in where it lases, but I haven’t seen it in my little machines. I don’t have your controller…

I don’t know how that would happen unless it has something to do with the spindle and how it’s managed…

I think you’ve tapped me out as far as suggestions…

Good luck


i thought you only had to put a couple of values in and it WOULD apply the calculated backlash at other speeds??

The exact speed… So set them up for the speeds you use…

The Ruida, as far as I know, doesn’t do any of that, it’s in the device settings…


i agree the controller doesn’t…but lightburn i believe is supposed to do that calculation and apply the offset

I’ll have to try it and see. It’s really not too linear of a plot…


yes thats what lightburn support said to me also. You need 2 separate speeds and you get a linear plot. But i dont know how it works further with unlinear values.

I talked about 10m/min which is 10000mm/min so that speed was in the list.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.